MVE2 Module Documentation

Strings

Version: 1.0.5141.21392
Runtime version: 2.0.50727

Modules

Zcu.Mve.Strings.DirectoryIterator | In a single map run, iterates through all items (files, directories, both) matching a specified mask in a selected directory.
Zcu.Mve.Strings.DirectoryLister |
Zcu.Mve.Strings.FileNameComposer | Module that composes a filename form a prefix, number and a suffix. Leading zeroes may be optionally added for the number to be of given length
Zcu.Mve.Strings.RegExReplacer | Performs a regular expression replace on the input string.
Zcu.Mve.Strings.StringSource | A source of constant string. Use the Value property to set the string value.

Data structures

Zcu.Mve.Strings.MveString An MVE representation of a string. Encapsulates a single string and implements the IDataObject interface.

Created by MMDoc 28.01.2014 11:54:18


Zcu.Mve.Strings.RegExReplacer

Index | Overview | Settings | Events

A module that performs a regular expression replace on the input string.

Input Ports:
  • InString - The input string.

Output Ports:
  • OutString - The replaced string.

Details:

Type of module: Filter.String|String.Filter
Version: 28.01.2014
Author: Oldrich Petrík


Zcu.Mve.Strings.RegExReplacer


Zcu.Mve.Strings.DirectoryIterator

Iterates through all items (files, directories, both) matching a specified mask in a selected directory. Sets the output to the current item name and waits for an input before proceeding to a next item.

Input Ports:
  • InDirectory - [optional] Base directory path.
  • InUpdate - Any IDataObject which causes the map to update.

Output Ports:
  • OutItemName - Name of the current file or directory.

Details:

Type of module: Source.String|String.Source
Version: 28.01.2014
Author: Oldrich Petrík


Zcu.Mve.Strings.DirectoryIterator


Zcu.Mve.Strings.StringSource

A source of constant string. Use the Value property to set the string value.

Output Ports:
  • String - Output MveString.

Details:

Type of module: Source.String|String.Source
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Strings.StringSource

You can set these properties:

  • Value
    String value that will appear as output. Should not contain the ]]> sequence as it cannot be exported to XML.


Zcu.Mve.Strings.FileNameComposer

Module that composes a filename form a prefix, number and a suffix. Leading zeroes may be optionally added for the number to be of given length

Input Ports:
  • Number - An MveInt port that determines the number that will appear in the middle of the resulting filename.
  • Prefix - An MveString port that determines the first part of the resulting filename.
  • Suffix - An MveString port that determines the last part of the resulting filename.

Output Ports:
  • Filename - An MveString port that exposes the composed filename

Details:

Type of module: Filter.String|String.Filter
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Strings.FileNameComposer

You can set these properties:

  • AddLeadingZeros
    Sets whether or not leading zeros should be added to the beginning of the number
  • NumberLength
    Sets the total length of the number part of the filename. If AddLeadingZeros is set to true, then leading zeros will be added to each number so that the set length is matched, otherwise has no effect.


Zcu.Mve.Strings.DirectoryLister

Input Ports:
  • BaseDirectory -
  • FileNumber -

Output Ports:
  • FileName -
  • FileNameWithPath -

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Strings.DirectoryLister


Zcu.Mve.Strings.MveString

Index | Overview | Members

An MVE representation of a string. Encapsulates a single string and implements the IDataObject interface.

Inheritance:

System.Object
Zcu.Mve.Strings.MveString

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Strings.MveString

Index | Overview | Members

Constructors

MveString ( )
Only used by XML serializer, don't call explicitely.

    MveString ( System.String val )
    constructs a new instance of MveString that encapsulates a string passed as argument.

    • val
      String to be encapsulated by the MveString instance.

    Public methods

    virtual System.Boolean Equals ( System.Object obj ) ;
    Determines whether the specified Object is equal to the current Object.
    • obj
      Specified Object to compare with the current Object.

    Returns:
    True if the specified Object is equal to the current Object. Otherwise, false.

    final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
    Read data from Xml file to current structure.

    • xmlTextReader
      Stream to be read.

    final virtual System.Boolean CheckConsistence ( ) ;
    Check the consistency of current data structure.

      Returns:
      True if structure is consistent.

      final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
      Deep copy of data object and its subelements.

        Returns:
        Same data, different memory space.

        virtual System.Int32 GetHashCode ( ) ;
        Returns a hash code for the current Object.

          Returns:
          A hash code for the current Object.

          static System.Boolean Equals ( System.Object a, System.Object b ) ;
          Determines whether the specified Objects are equal.

          • a
            First Object.
          • b
            Second Object.

          Returns:
          True if objects are equal. Otherwise, false.

          virtual System.String ToString ( ) ;
          Returns a String that represents the current Object.

            Returns:
            String that represents the current Object.

            final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
            Write current data to Xml file. CDATA is used for the case of escape characters in the string

            • xmlTextWriter
              Stream to be write.

            Public properties

            final virtual System.String[] LibNames { get; }
            Returns array of assembly name.

            Public fields

            System.String Value
            Value encapsualted by the class


Elementals

Title: Modular Virtual Environment 2 - Elementals
Description: Elementals contains some usable modules for input, output and control data.
Company: University of West Bohemia in Pilsen, Czech Republic
Copyright: © 2004 - 2005 University of West Bohemia, Czech Republic
Version: 0.2.5141.21392
Runtime version: 2.0.50727

Modules

Zcu.Mve.Elementals.ConsolePrinter | Module prints content of a data structure to the standatd output.
Zcu.Mve.Elementals.DataChecker | Module checks a data consistence by calling the CheckConsistence methodof data object.
Zcu.Mve.Elementals.DummyLevelDescreaser |
Zcu.Mve.Elementals.GenericJunction | Sends through data from one of the two inputs based on the control parameter/input
Zcu.Mve.Elementals.MultiPortEvaluator | A module for executing multiple branches of a map tree on a single request. When executed, updates all preceding modules and passes through the output of the selected module.
Zcu.Mve.Elementals.XmlLoader | Module for reading data object from XML file.
Zcu.Mve.Elementals.XmlSaver | Module for saving data into XML file.


Zcu.Mve.Elementals.XmlSaver

Module receives data from input port and saves them into XML file with filename specified in setting window of module.

Input Ports:
  • Input - Data to save

Details:

Type of module: Saver
Version: 19.06.2004
Author: Miroslav Vavruška


Zcu.Mve.Elementals.XmlSaver

Enter the name of file, where data object will be saved.
You can choose it by clicking on the button with three dots. Standard window for file saving is showed.


Zcu.Mve.Elementals.ConsolePrinter

Module prints content of a data structure to the standatd output. It uses the method ToString().

Input Ports:
  • input - Data to be printed.

Details:

Type of module: Output|Output
Version: 26.08.2004
Author: Milan Frank


Zcu.Mve.Elementals.ConsolePrinter


Zcu.Mve.Elementals.DummyLevelDescreaser

Input Ports:
  • Input -

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Elementals.DummyLevelDescreaser


Zcu.Mve.Elementals.MultiPortEvaluator

A module for executing multiple branches of a map tree on a single request.

Input Ports:
  • Input1 -

Output Ports:
  • Output -

Details:

Type of module: Generic
Version: 28.01.2014
Author: Oldrich Petrík


Zcu.Mve.Elementals.MultiPortEvaluator

Returns the setup dialog for the module.


Zcu.Mve.Elementals.XmlLoader

Module reads a data object from XML file, which has to be entered by setting window of the module.

Output Ports:
  • Output - Readed data object (IDataObject)

Details:

Type of module: Loader
Version: 19.06.2004
Author: Miroslav Vavruška, Libor Váša


Zcu.Mve.Elementals.XmlLoader

You can set these properties:

  • Reload
    Deterimines wether or not will the file be reparsed each time data are requested. Set to tru when some other program changes the xml data, otherwise keep the false value to speed up the computation


Zcu.Mve.Elementals.GenericJunction

Input Ports:
  • Control -
  • Input 0 -
  • Input 1 -

Details:

Type of module: Generic
Version: 28.01.2014
Author:


Zcu.Mve.Elementals.GenericJunction


Zcu.Mve.Elementals.DataChecker

Module checks a data consistence by calling of the method CheckConsistence of data object. This method is declared in the Core's interface IDataObject.

Input Ports:
  • Input - checking data

Details:

Type of module: Output
Version: 26.08.2004
Author: Milan Frank


Zcu.Mve.Elementals.DataChecker


Examples

Title: Modular Virtual Environment 2 - Example
Description: Example of MVE2 library.
Company: University of West Bohemia in Pilsen, Czech Republic
Copyright: © 2004 - 2005 University of West Bohemia, Czech Republic
Version: 1.0.5141.21396
Runtime version: 4.0.30319

Modules

Examples.ChangablePorts | Sample module. Example of varying ports.
Examples.Convolution | Module performs a convolution of a image.
Examples.DebugLevelExample | Module shows how to use the Module.Write* method to .
Examples.GenerateGraph | Module creates given number of samples of connected function.
Examples.InverseTriangleMeshDiagonal | A module that returns inverse body diagonal of a TriangleMesh. Useful for coordinate normalization.
Examples.PointInterpolator |
Examples.PositionRandomizer |
Examples.Sinus | Module calculates sinus of given number.
Examples.TestSource |
Examples.UnstrGrid2TriangleMesh |
Examples.VertexEdgeDetector | A module that computes the number of edges of a mesh. This module is useful for checking of consistence of meshes. Adds a new point attribute to the input mesh, that determines the number of open edges for each vertex.


Examples.VertexEdgeDetector

A module that computes the number of edges of a mesh. This module is useful for checking of consistence of meshes. Adds a new point attribute to the input mesh, that determines the number of open edges for each vertex.

Input Ports:
  • TriMesh - A mesh to be checked.

Output Ports:
  • OutMesh - Reference to the input TriMesh.

Details:

Type of module: unspecified
Version: 28.01.2014
Author: Libor Váša


Examples.VertexEdgeDetector

You can set these properties:

  • TriangleCellsName
    Gets or sets the identifier of triangle cells that will be used for computation. If set to an empty string, then the first triangle cells will be used.
  • OutputAttributeName
    Gets or sets the name of the output point attribute.


Examples.TestSource

Output Ports:
  • UnstrGrid -

Details:

Type of module: unspecified
Version:
Author:


Examples.TestSource


Examples.PositionRandomizer

Input Ports:
  • Input mesh -

Output Ports:
  • Output mesh -

Details:

Type of module: unspecified
Version:
Author:


Examples.PositionRandomizer


Examples.DebugLevelExample

Module shows how to use the Module.Write* method to output some information. WriteConsole outputs the message to Console windowWriteDebug outputs the message to Debug windowWriteLog outputs the message to Debug windowWrite generic method The generic Write method can be called with different WriteTargets or predefined Globals.DebugLevel*.

Details:

Type of module: Generic
Version: 25.06.2007
Author: Petr Vanecek


Examples.DebugLevelExample


Examples.PointInterpolator

Input Ports:
  • Mesh A -
  • Mesh B -
  • Mix -

Output Ports:
  • Output mesh -

Details:

Type of module: unspecified
Version:
Author:


Examples.PointInterpolator


Examples.ChangablePorts

Sample module. This demostrates a possibility of module to add and remove ports.

Input Ports:
  • input - Only ScalarNumber and VectorND can be connected.

Details:

Type of module: Example
Version: 28.01.2014
Author: Milan Frank


Examples.ChangablePorts


Examples.Sinus

Sample Module. Module calculates sinus of given number.

Input Ports:
  • in - Independent variable

Output Ports:
  • out - Dependent variable

Details:

Type of module: Filter.Number|Number.Filter
Version: 28.01.2014
Author: Milan Frank


Examples.Sinus


Examples.Convolution

Module performs a convolution of a image.

Input Ports:
  • Image - An image, with which a convolution going to be performed.
  • Mask - Input convolution mask.

Output Ports:
  • Result - Resulting image.

Details:

Type of module: Filter.Image|Image.Filter
Version: 28.01.2014
Author: Milan Frank


Examples.Convolution


Examples.UnstrGrid2TriangleMesh

Input Ports:
  • UnstrGrid -

Output Ports:
  • TriangleMesh -

Details:

Type of module: unspecified
Version:
Author:


Examples.UnstrGrid2TriangleMesh


Examples.GenerateGraph

Module creates 100 samples of connected function in <0, 10> interval. Sample module with NonAutoUpdate and NonEvokeUpdate ports.

Input Ports:
  • y - Input dependent variable.

Output Ports:
  • graph - Output generated graph.
  • Sample number -

Details:

Type of module: Filter.Number|Number.Filter
Version: 28.01.2014
Author: Milan Frank


Examples.GenerateGraph

You can set these properties:

  • NumSamps
    Number of asked samples.


Examples.InverseTriangleMeshDiagonal

A module that returns inverse body diagonal of a TriangleMesh. Useful for coordinate normalization.

Input Ports:
  • Mesh - Input mesh that will be used.

Output Ports:
  • Inverse diagonal - A scalar value that is equal to 1/(length of body diagonal) of the input mesh

Details:

Type of module: Filter.Mesh|Mesh.Filter
Version: 28.01.2014
Author: Libor Váša


Examples.InverseTriangleMeshDiagonal


Numerics

Title: Modular Virtual Environment 2 - Numerics
Company: University of West Bohemia in Pilsen, Czech Republic
Copyright: © 2004 - 2005 University of West Bohemia, Czech Republic
Version: 1.0.5141.21390
Runtime version: 2.0.50727

Modules

Zcu.Mve.Numerics.ComplexBinaryOp | Modul for binary operations with Complex type
Zcu.Mve.Numerics.ComplexSource | A source module for Complex
Zcu.Mve.Numerics.Counter |
Zcu.Mve.Numerics.FileCount |
Zcu.Mve.Numerics.IntegerBinaryOp | Modul for binary operations with Integer type
Zcu.Mve.Numerics.IntegerSource | A source module for Integer
Zcu.Mve.Numerics.LinearTransform | A module that linearly transforms MveInt on the input. Coeficients of the transform are specified by the A and B properties, the result is computed as A*input+B.
Zcu.Mve.Numerics.Scalar2IntegerConvertor |
Zcu.Mve.Numerics.ScalarAbsoluteValue | Modul for calculating absolute value of a Scalar
Zcu.Mve.Numerics.ScalarBinaryOp | Modul for binary operations with Scalar type
Zcu.Mve.Numerics.ScalarSource | A source module for Scalar
Zcu.Mve.Numerics.VectMultScalar | Performs the multiplication of 2D vector by scalar value: result = vector * scalar.
Zcu.Mve.Numerics.VectorComposer | A module that composes a VectorND from input scalar values
Zcu.Mve.Numerics.VectorNorm | Module computes the absolute value of vector.
Zcu.Mve.Numerics.VectorRenderer | Module for vector rendering.
Zcu.Mve.Numerics.VectorSource | Source of n-dimensional vector.

Data structures

Zcu.Mve.Numerics.Complex | This structure represents a complex number of real and imaginary part.
Zcu.Mve.Numerics.Integer | This structure encapsulates a single integer value and implements the IDataObject interface.
Zcu.Mve.Numerics.IVector | Interface that represents a vector.
Zcu.Mve.Numerics.Matrix |
Zcu.Mve.Numerics.Scalar | This structure represents a scalar value.
Zcu.Mve.Numerics.Vector2D | This structure represents a 2D vector defined by two elements - X and Y.
Zcu.Mve.Numerics.Vector3D | This structure represents a 3D vector defined by three elements - X, Y and Z.
Zcu.Mve.Numerics.VectorND | This class represents a ND vector defined by N elements.


Zcu.Mve.Numerics.IntegerSource

A source module for Integer

Output Ports:
  • Integer - Resulting Integer

Details:

Type of module: Source.Number|Number.Source
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Numerics.IntegerSource

You can set these properties:

  • Randomize
    Generate random Integer
  • ForceExecution
    Force execution when nothing changed.
  • RandomSeed
    Random seed
  • Value
    Integer value that will be used as output of the module. If randomized is set to true, Value is used as upper limit.


Zcu.Mve.Numerics.IntegerBinaryOp

Input Ports:
  • Arg1 - First argument
  • Arg2 - Second argument

Output Ports:
  • Result - Result of the binary operation

Details:

Type of module: Filter.Number|Number.Filter
Version: 28.01.2014
Author: Petr Vaněček


Zcu.Mve.Numerics.IntegerBinaryOp

You can set these properties:

  • Operation
    Binary operator.


Zcu.Mve.Numerics.VectorSource

Setup for VectorSource property setting .

Output Ports:
  • output - n-dimensional vector

Details:

Type of module: Source.Number|Number.Source
Version: 04.09.2004
Author: Milan Frank


Zcu.Mve.Numerics.VectorSource

Invoke model setup.


Zcu.Mve.Numerics.ScalarSource

A source module for Scalar

Output Ports:
  • Scalar - Resulting Scalar

Details:

Type of module: Source.Number|Number.Source
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Numerics.ScalarSource

You can set these properties:

  • Randomize
    Generate random Scalar
  • RandomSeed
    Random seed
  • ForceExecution
    Force execution when nothing changed.
  • Value
    Scalar value that will be used as output of the module. If randomized is set to true, Value is used as upper limit.


Zcu.Mve.Numerics.ScalarBinaryOp

Input Ports:
  • Arg1 - First argument
  • Arg2 - Second argument

Output Ports:
  • Result - Result of the binary operation

Details:

Type of module: Filter.Number|Number.Filter
Version: 28.01.2014
Author: Petr Vaněček


Zcu.Mve.Numerics.ScalarBinaryOp

You can set these properties:

  • Operation
    Binary operator.


Zcu.Mve.Numerics.ScalarAbsoluteValue

Input Ports:
  • Arg - First argument

Output Ports:
  • Result - Result of the Abs operation

Details:

Type of module: Filter.Number|Number.Filter
Version: 28.01.2014
Author: Oldrich Petrík


Zcu.Mve.Numerics.ScalarAbsoluteValue


Zcu.Mve.Numerics.VectorComposer

A module that composes a VectorND from input scalar values

Input Ports:
  • V1 - First element of the vector, if an input is connected to this port an additional port appears that can accept the next element of the vector.

Output Ports:
  • Vector - Resulting VectorND

Details:

Type of module: Filter.Number|Number.Filter
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Numerics.VectorComposer


Zcu.Mve.Numerics.FileCount

Output Ports:
  • FileCount -

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Numerics.FileCount


Zcu.Mve.Numerics.ComplexBinaryOp

Input Ports:
  • Arg1 - First argument
  • Arg2 - Second argument

Output Ports:
  • Result - Result of the binary operation

Details:

Type of module: Filter.Number|Number.Filter
Version: 28.01.2014
Author: Petr Vaněček


Zcu.Mve.Numerics.ComplexBinaryOp

You can set these properties:

  • Operation
    Binary operator.


Zcu.Mve.Numerics.Scalar2IntegerConvertor

Input Ports:
  • Scalar -

Output Ports:
  • Integer -

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Numerics.Scalar2IntegerConvertor


Zcu.Mve.Numerics.VectMultScalar

Module performs the multiplication of 2D vector by scalar value: result = vector * scalar.

Input Ports:
  • scalar - scalar value
  • vector - vektor

Output Ports:
  • result - result

Details:

Type of module: Filter.Number|Number.Filter
Version: 28.01.2014
Author: Milan Frank


Zcu.Mve.Numerics.VectMultScalar


Zcu.Mve.Numerics.VectorNorm

Module computes the absolute value of vector.

Input Ports:
  • vector - vector

Output Ports:
  • scalar - absolute value of vector

Details:

Type of module: Filter.Number|Number.Filter
Version: 28.01.2014
Author: Milan Frank


Zcu.Mve.Numerics.VectorNorm


Zcu.Mve.Numerics.ComplexSource

A source module for Complex

Output Ports:
  • Complex - Resulting Complex

Details:

Type of module: Source.Number|Number.Source
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Numerics.ComplexSource

You can set these properties:

  • Randomize
    Generate random Integer
  • Real
    Real part of complex number that will be used as output of the module
  • Imag
    Imaginary part of complex number that will be used as output of the module
  • ForceExecution
    Force execution when nothing changed.
  • RandomSeed
    Random seed


Zcu.Mve.Numerics.VectorRenderer

Panel for vector rendering.

Input Ports:
  • Input - Vector for rendering.

Details:

Type of module: Output.Number|Number.Output
Version: 04.09.2004
Author: Miroslav Vavruška


Zcu.Mve.Numerics.VectorRenderer


Zcu.Mve.Numerics.Counter

Output Ports:
  • Value -

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Numerics.Counter


Zcu.Mve.Numerics.LinearTransform

A module that linearly transforms MveInt on the input. Coeficients of the transform are specified by the A and B properties, the result is computed as A*input+B.

Input Ports:
  • Input - Input MveInt value

Output Ports:
  • Output - Output Scalar value

Details:

Type of module: Filter.Number|Number.Filter
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Numerics.LinearTransform

You can set these properties:

  • A
    Specifies the multiplier in the linear transform
  • B
    Specifies the absolute part of the linear transform


Zcu.Mve.Numerics.Matrix

Index | Overview | Members

Summary description for Matrix. Internally, the matrix is stored as an array of doubles.

Inheritance:

System.Object
Zcu.Mve.Numerics.Matrix

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Numerics.Matrix

Index | Overview | Members

Constructors

Matrix ( System.Int32 w, System.Int32 h )
Default constructor, constructs a new Double matrix of width w and heigh h.
  • w
    Width of the new matrix.
  • h
    Height of the new matrix.

Public methods

final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
Writes data to given xmlTextWriter.
  • xmlTextWriter
    A xmlTextWriter instance to be used.

final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
Reads data from xmlTextReader. Data format should match the format used by the WriteData(...) method.

  • xmlTextReader
    A xmlTextReader instance to read from.

final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
Returns anew instance of Matrix that contains a copy of the current matrix.

    Returns:
    A deep copy of the matrix.

    final virtual System.Boolean CheckConsistence ( ) ;
    Checks consistence of the matrix instance. Always returns true, but may also write warnings when matrix contains infifnities of NaNs.

      Returns:
      Always true.

      Public properties

      System.Int32 Height { get; }
      Height of the matrix. Read-only.

      final virtual System.String[] LibNames { get; }
      Returns a list of libraries necessary for the type.

      System.Int32 Width { get; }
      Width of the matrix. Read-only.

      System.Double Item { get;set; }
      Public indexer that returns matrix value at given row and column. No consistency checks are performed, may throw exception when wrong indices are passed.

      System.Double[] Array { get; }
      Returns the reference to matrix data array.


Zcu.Mve.Numerics.Complex

Index | Overview | Members

Complex number that consist of real and imaginary part.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Numerics.Complex

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Numerics.Complex

Index | Overview | Members

Constructors

Complex ( System.Double r, System.Double i )
Constructor.
  • r
    Real part.
  • i
    Imaginary part.

Public methods

virtual System.String ToString ( ) ;
String representation of number.

    final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
    Read data from Xml stream to current structure.

      static Zcu.Mve.Numerics.Complex FromModArg ( System.Double modulus, System.Double argument ) ;
      Construct complex number from modulus and argument.

      • modulus
        Modulus.
      • argument
        Argument.

      Returns:
      Complex number.

      final virtual System.Boolean CheckConsistence ( ) ;
      Check the consistency of current data structure.

        final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
        Deep copy of data object and its subelements.

          Zcu.Mve.Numerics.Complex Power ( Zcu.Mve.Numerics.Complex exp ) ;
          Complex power of complex number.

          • exp
            Complex exponent

          Returns:
          Power of complex number

          Zcu.Mve.Numerics.Complex Power ( System.Int32 exp ) ;
          Integer power of complex number. It is faster for small exponents. For large exponents use the Complex version.

          • exp
            Integer exopnent.

          Returns:
          Power of complex number.

          final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
          Write current data to Xml stream.

            static Zcu.Mve.Numerics.Complex Power ( Zcu.Mve.Numerics.Complex cbase, Zcu.Mve.Numerics.Complex exp ) ;
            Complex power of complex number.

            • cbase
              Complex base
            • exp
              Complex exponent

            Returns:
            Power of complex number

            Public properties

            Zcu.Mve.Numerics.Complex Conjugate { get; }
            Complex conjugate.

            Zcu.Mve.Numerics.Complex Sign { get; }
            Returns the sign of complex number.

            System.Double ModulusSquared { get; }
            Squared modulus.

            System.Double Modulus { get; }
            Modulus.

            final virtual System.String[] LibNames { get; }
            Returns array of assembly names (filename without extension!) that contain definition of current data structure and its sub elments.

            System.Double Argument { get; }
            Argument.

            Public fields

            System.Double Real
            Real component.

            System.Double Imag
            Imaginary component.

            static System.String XmlTag
            Xml tag for storage pruposes.

            static Zcu.Mve.Numerics.Complex One
            One: 1+i0.

            static Zcu.Mve.Numerics.Complex Zero
            Zero: 0+i0.


Zcu.Mve.Numerics.IVector

Index | Overview | Members

Interface that represents a vector.

Inheritance:

Zcu.Mve.Numerics.IVector

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Numerics.IVector

Index | Overview | Members

Public methods

abstract virtual System.Double Abs ( ) ;
Absolute value of vector

    Public properties

    abstract virtual System.Int32 Length { get; }
    Get number of elements of vector.

    abstract virtual System.Double Item { get;set; }
    Get/Set element of vector.


Zcu.Mve.Numerics.VectorND

Index | Overview | Members

This class represents a ND vector defined by N elements.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Numerics.VectorND

Implements:

Zcu.Mve.Core.IDataObject
Zcu.Mve.Numerics.IVector


Zcu.Mve.Numerics.VectorND

Index | Overview | Members

Constructors

VectorND ( params System.Double[] values )
Create a VectorND object.
  • values
    n-dimensional array of vector values.

VectorND ( )
Implicit constructor - creates an empty object.

    Public methods

    final virtual System.Double Abs ( ) ;
    Returns the absolute value of vector.

      Returns:
      The absolute value of vector.

      virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
      Read data from Xml file to current structure.

      • xmlTextReader
        Stream to be read.

      virtual System.Boolean CheckConsistence ( ) ;
      Check the consistency of current data structure.

        Returns:
        True if structure is consistent.

        virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
        Deep copy of data object and its subelements.

          Returns:
          Same data, different memory space.

          virtual System.Boolean Equals ( System.Object obj ) ;
          Determines whether the specified Object is equal to the current Object.

          • obj
            Specified Object to compare with the current Object.

          Returns:
          True if the specified Object is equal to the current Object. Otherwise, false.

          virtual System.Int32 GetHashCode ( ) ;
          Returns a hash code for the current Object.

            Returns:
            A hash code for the current Object.

            static System.Boolean Equals ( System.Object a, System.Object b ) ;
            Determines whether the specified Objects are equal.

            • a
              First Object.
            • b
              Second Object.

            Returns:
            True if objects are equal. Otherwise, false.

            virtual System.String ToString ( ) ;
            Returns a String that represents the current Object.

              Returns:
              String that represents the current Object.

              virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
              Write current data to Xml file.

              • xmlTextWriter
                Stream to be write.

              Public properties

              final virtual System.Int32 Length { get; }
              Get number of elements of vector.

              final virtual System.Double Item { get;set; }
              Get/Set element of vector.

              System.Double Norm { get; }
              Alias for Abs()

              System.Double[] Array { get; }
              Returns the reference to VectorND data array.

              System.Double[] Values { get; }
              Get the n-dimensional array of vector values. For acces to concrete vector element use indexer.

              Public fields

              static System.Double Epsilon
              The toleration for equality operator.


Zcu.Mve.Numerics.Integer

Index | Overview | Members

A source module for Integer

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Numerics.Integer

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Numerics.Integer

Index | Overview | Members

Constructors

Integer ( System.Int32 val )
Constructs a new instance of MveInt, that will wrap the value passed as parameter.
  • val
    Value to be wrapped by the new instance.

Public methods

virtual System.Boolean Equals ( System.Object obj ) ;
Determines whether the specified Object is equal to the current Object.
  • obj
    Specified Object to compare with the current Object.

Returns:
True if the specified Object is equal to the current Object. Otherwise, false.

final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
Read data from Xml file to current structure.

  • xmlTextReader
    Stream to be read.

static Zcu.Mve.Numerics.Integer Power ( Zcu.Mve.Numerics.Integer a, Zcu.Mve.Numerics.Integer b ) ;
Integer power

    final virtual System.Boolean CheckConsistence ( ) ;
    Check the consistency of current data structure.

      Returns:
      True if structure is consistent.

      final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
      Deep copy of data object and its subelements.

        Returns:
        Same data, different memory space.

        virtual System.Int32 GetHashCode ( ) ;
        Returns a hash code for the current Object.

          Returns:
          A hash code for the current Object.

          static System.Boolean Equals ( System.Object a, System.Object b ) ;
          Determines whether the specified Objects are equal.

          • a
            First Object.
          • b
            Second Object.

          Returns:
          True if objects are equal. Otherwise, false.

          virtual System.String ToString ( ) ;
          Returns a String that represents the current Object.

            Returns:
            String that represents the current Object.

            final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
            Write current data to Xml file.

            • xmlTextWriter
              Stream to be write.

            static Zcu.Mve.Numerics.Integer BitShift ( Zcu.Mve.Numerics.Integer a, Zcu.Mve.Numerics.Integer b ) ;
            Bit shift. If shift is greater than zero, the left shift is performed, otherwise the right shift is performed.

            • a
              Number.
            • b
              Shift.

            Public properties

            final virtual System.String[] LibNames { get; }
            Returns array of assembly name.

            Public fields

            System.Int32 Value
            wrapped integer value


Zcu.Mve.Numerics.Vector2D

Index | Overview | Members

This structure represents a 2D vector defined by two elements - X and Y.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Numerics.Vector2D

Implements:

Zcu.Mve.Numerics.IVector
Zcu.Mve.Core.IDataObject


Zcu.Mve.Numerics.Vector2D

Index | Overview | Members

Constructors

Vector2D ( System.Double vx, System.Double vy )
Create a Vector2D object.
  • vx
    x-vector value.
  • vy
    y-vector value.

Public methods

final virtual System.Double Abs ( ) ;
Returns the absolute value of vector.

    Returns:
    The absolute value of vector.

    final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
    Read data from Xml file to current structure.

    • xmlTextReader
      Stream to be read.

    final virtual System.Boolean CheckConsistence ( ) ;
    Check the consistency of current data structure.

      Returns:
      True if structure is consistent.

      final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
      Deep copy of data object and its subelements.

        Returns:
        Same data, different memory space.

        virtual System.Boolean Equals ( System.Object obj ) ;
        Determines whether the specified Object is equal to the current Object.

        • obj
          Specified Object to compare with the current Object.

        Returns:
        True if the specified Object is equal to the current Object. Otherwise, false.

        virtual System.Int32 GetHashCode ( ) ;
        Returns a hash code for the current Object.

          Returns:
          A hash code for the current Object.

          static System.Boolean Equals ( System.Object a, System.Object b ) ;
          Determines whether the specified Objects are equal.

          • a
            First Object.
          • b
            Second Object.

          Returns:
          True if objects are equal. Otherwise, false.

          virtual System.String ToString ( ) ;
          Returns a String that represents the current Object.

            Returns:
            String that represents the current Object.

            final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
            Write current data to Xml file.

            • xmlTextWriter
              Stream to be write.

            Public properties

            final virtual System.Int32 Length { get; }
            Get number of elements of vector.

            final virtual System.String[] LibNames { get; }
            Returns array of assembly name.

            System.Double Y { get;set; }
            Get/Set y-vector value.

            final virtual System.Double Item { get;set; }
            Get/Set element of vector.

            System.Double X { get;set; }
            Get/Set x-vector value.

            Public fields

            static System.Double Epsilon
            The toleration for equality operator.


Zcu.Mve.Numerics.Vector3D

Index | Overview | Members

Converts Vector3D from one data type to another. Access this class through the TypeDescriptor.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Numerics.Vector3D

Implements:

Zcu.Mve.Numerics.IVector
Zcu.Mve.Core.IDataObject


Zcu.Mve.Numerics.Vector3D

Index | Overview | Members

Constructors

Vector3D ( System.Double vx, System.Double vy, System.Double vz )
Create a Vector3D object.
  • vx
    x-vector value.
  • vy
    y-vector value.
  • vz
    z-vector value.

Public methods

final virtual System.Double Abs ( ) ;
Returns the absolute value of vector.

    Returns:
    The absolute value of vector.

    final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
    Read data from Xml file to current structure.

    • xmlTextReader
      Stream to be read.

    final virtual System.Boolean CheckConsistence ( ) ;
    Check the consistency of current data structure.

      Returns:
      True if structure is consistent.

      final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
      Deep copy of data object and its subelements.

        Returns:
        Same data, different memory space.

        virtual System.Boolean Equals ( System.Object obj ) ;
        Determines whether the specified Object is equal to the current Object.

        • obj
          Specified Object to compare with the current Object.

        Returns:
        True if the specified Object is equal to the current Object. Otherwise, false.

        virtual System.Int32 GetHashCode ( ) ;
        Returns a hash code for the current Object.

          Returns:
          A hash code for the current Object.

          static System.Boolean Equals ( System.Object a, System.Object b ) ;
          Determines whether the specified Objects are equal.

          • a
            First Object.
          • b
            Second Object.

          Returns:
          True if objects are equal. Otherwise, false.

          virtual System.String ToString ( ) ;
          Returns a String that represents the current Object.

            Returns:
            String that represents the current Object.

            final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
            Write current data to Xml file.

            • xmlTextWriter
              Stream to be write.

            Public properties

            System.Double Y { get;set; }
            Get/Set y-vector value.

            final virtual System.String[] LibNames { get; }
            Returns array of assembly name.

            System.Double Z { get;set; }
            Get/Set z-vector value.

            final virtual System.Double Item { get;set; }
            Get/Set element of vector.

            System.Double X { get;set; }
            Get/Set x-vector value.

            final virtual System.Int32 Length { get; }
            Get number of elements of vector.

            Public fields

            static System.Double Epsilon
            The toleration for equality operator.


Zcu.Mve.Numerics.Scalar

Index | Overview | Members

A source module for Scalar

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Numerics.Scalar

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Numerics.Scalar

Index | Overview | Members

Constructors

Scalar ( System.Double val )
Create a Scalar object.
  • val
    Scalar value.

Public methods

virtual System.Boolean Equals ( System.Object obj ) ;
Determines whether the specified Object is equal to the current Object.
  • obj
    Specified Object to compare with the current Object.

Returns:
True if the specified Object is equal to the current Object. Otherwise, false.

final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
Read data from Xml file to current structure.

  • xmlTextReader
    Stream to be read.

final virtual System.Boolean CheckConsistence ( ) ;
Check the consistency of current data structure.

    Returns:
    True if structure is consistent.

    final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
    Deep copy of data object and its subelements.

      Returns:
      Same data, different memory space.

      static Zcu.Mve.Numerics.Scalar Power ( Zcu.Mve.Numerics.Scalar a, Zcu.Mve.Numerics.Scalar b ) ;
      Power

        virtual System.Int32 GetHashCode ( ) ;
        Returns a hash code for the current Object.

          Returns:
          A hash code for the current Object.

          static System.Boolean Equals ( System.Object a, System.Object b ) ;
          Determines whether the specified Objects are equal.

          • a
            First Object.
          • b
            Second Object.

          Returns:
          True if objects are equal. Otherwise, false.

          virtual System.String ToString ( ) ;
          Returns a String that represents the current Object.

            Returns:
            String that represents the current Object.

            final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
            Write current data to Xml file.

            • xmlTextWriter
              Stream to be write.

            Public properties

            final virtual System.String[] LibNames { get; }
            Returns array of assembly name.

            Public fields

            System.Double Value
            Scalar value.

            static System.Double Epsilon
            The toleration for equality operator.


Visualization

Title: Modular Virtual Environment 2 - Visualization
Company: University of West Bohemia in Pilsen, Czech Republic
Copyright: © 2004 - 2005 University of West Bohemia, Czech Republic
Version: 1.1.5141.21393
Runtime version: 4.0.30319

Modules

Zcu.Mve.Visualization.Loaders.BinaryReaderMultiAttributes | Module for loading raw data from file to RegGridND.
Zcu.Mve.Visualization.Loaders.BinaryReaderSingleAttribute | Module for loading raw data from file to RegGridND.
Zcu.Mve.Visualization.Loaders.DICOM_Loader | Module loads set of DICOM images (.dcm) from selected directory.
Zcu.Mve.Visualization.Loaders.MeshLoader | Module for loading of mesh from .tri, .stl, .ply and .cmx file formats.
Zcu.Mve.Visualization.Loaders.ObjLoader | Module for .obj format import. Produces Mesh.
Zcu.Mve.Visualization.Loaders.PictureLoader | Module for loading of 2D image from a file. Supported formats (JPEG, GIF, BMP). Image is returned as RegGrid2D.
Zcu.Mve.Visualization.Loaders.TriangleLoader | Module for loading of triangle mesh from .tri format file.
Zcu.Mve.Visualization.Processing.AppendAttribute |
Zcu.Mve.Visualization.Processing.ArrayIterator | Generic module for iteration through UniformDataArray. Returns an element at a specified index. Index is specified by the Index port, array is specified by the Array input port. Output port updates its type upon connecting to output. Checks for type compatibility, throws runtime error.
Zcu.Mve.Visualization.Processing.AttributeHistogram |
Zcu.Mve.Visualization.Processing.BlockCutting | Module for block using by "convex polyhedron cutting"
Zcu.Mve.Visualization.Processing.CalculateDisplace | Assigns scalar attributes to regular 2D grid points according to color attributes of adjacent cells. Scalar attributes will be in [0; 1] range. Supports alpha channel and allows RGB color channels masking.
Zcu.Mve.Visualization.Processing.ColorMapingUnstr | Module which maps ColorRGBA value on chosen atribute of UnstrGrid type. It takes atribute selected by user, sends out it's remaped scalar values to any color palette and returned color values are saved as new, user named attribute.
Zcu.Mve.Visualization.Processing.ConvexPolyhedronCutting | Module for cutting by polyhedron
Zcu.Mve.Visualization.Processing.DisplaceMap | Creates a 3D triangle mesh from planar triangle mesh or regular 2D grid. Elevation (Z coordinate) is computed from XY plane according to scalar point attributes. Module provides advanced control over regular 2D grid sizing and positioning.
Zcu.Mve.Visualization.Processing.Distance | Finds the longest distance between the points in the set.
Zcu.Mve.Visualization.Processing.EditablePalette | A module that transforms a Scalar value into a ColorRGBA. Values lower or equal to zero will be computed as equal to zero, values greater or equal to one will be computed as equal to one , values in between will become linear interpolation or cosine interpolation among control points.
Zcu.Mve.Visualization.Processing.Elevation | Paints triangle mesh points according to their elevation. Direction of elevation may be specified arbitrary in module setup dialog or by Vector3D connected to module input. Several color mappings are available.
Zcu.Mve.Visualization.Processing.GeometryCut | This modul provide cutting off geometric cells according to points scalar attribute. The name of points scalar attribute with evaluation for cut can be set by property. If property not set, first points scalar attribute is use.
Zcu.Mve.Visualization.Processing.Glyphs |
Zcu.Mve.Visualization.Processing.GlyphsFromRegGridNd | Module can transfoms Normal3D or Vector3D or Scalar or Integer point atributes to glyphs
Zcu.Mve.Visualization.Processing.GlyphsFromUnstrGrid | Module can transfoms Normal3D or Vector3D or Scalar or Integer point atributes to glyphs
Zcu.Mve.Visualization.Processing.IsoSurfaceExtractor |
Zcu.Mve.Visualization.Processing.MarchingCubes | Marching Cubes iso-surface extractor. Module shall be used with 'VolLoader' module, which provides desired input data.
Zcu.Mve.Visualization.Processing.MarchingTetrahedra |
Zcu.Mve.Visualization.Processing.MarchingTetrahedra5 | Marching Tetrahedra iso-surface extractor. Module shall be used with 'VolLoader' module, which provides desired input data.
Zcu.Mve.Visualization.Processing.MarchingTetrahedra6 | Marching Tetrahedra iso-surface extractor. Module shall be used with 'VolLoader' module, which provides desired input data.
Zcu.Mve.Visualization.Processing.MeshDualGraph | Module constructs a dual graph for a triangular mesh. The module uses the first attribute of the Triangle type. The vertices of the output are located at centres of original triangles, neighbouring triangles are connected by edges.
Zcu.Mve.Visualization.Processing.MeshSmooth | Module makes TriangleMesh more complex using PN Triangles.
Zcu.Mve.Visualization.Processing.NeighborTetrahedra |
Zcu.Mve.Visualization.Processing.NormalComputer | Module that computes vertex normals for a TriangleMesh. Normals are placed in a new point attribute of name specified in the AttrName property.
Zcu.Mve.Visualization.Processing.PaletteLinear | A module that transforms a Scalar value into a ColorRGBA. Values lower or equal to zero will become C1, values greater or equal to one will become C2, values in between will become linear interpolations of C1 and C2. This module can be used with the ScalarAttr2ColorRGBA module as a palette.
Zcu.Mve.Visualization.Processing.PaletteRainbow | A module that transforms a Scalar value into a ColorRGBA. Values lower or equal to zero will become C1, values greater or equal to one will become C2, values in between will become linear interpolations of C1 and C2. This module can be used with the ScalarAttr2ColorRGBA module as a palette.
Zcu.Mve.Visualization.Processing.PlaneCutting | Module for plane distance calculate used to cutting
Zcu.Mve.Visualization.Processing.PointDistanceCutting | Module for point distance calculate used to cutting
Zcu.Mve.Visualization.Processing.RegGridNDCalculator | A module that performs scientific calculations on point or cell attributes of an RegGridND.
Zcu.Mve.Visualization.Processing.SeparateAttribute |
Zcu.Mve.Visualization.Processing.Slicer | Module for slicing volume data.
Zcu.Mve.Visualization.Processing.Streamlines | Streamlines generator
Zcu.Mve.Visualization.Processing.TriangleMeshFixer |
Zcu.Mve.Visualization.Processing.Tube | Converts lines into tubes and points into spheres.
Zcu.Mve.Visualization.Processing.UniformDataArrayComposer | A general class that composes a new uniformDataArray. Any Dataobject can be attached to the input port, causing further ports of the same type to appear.
Zcu.Mve.Visualization.Processing.UnstrGridCalculator | A module that performs scientific calculations on point or cell attributes of an UnstrGrid.
Zcu.Mve.Visualization.Processing.UnstrGridModifyTransform | Modifies Transform matrix of UnstrGrid. Points of UnstrGrid remains untouched.
Zcu.Mve.Visualization.Processing.UnstrGridTransform | A module that transforms and UnstrGrid or its descendant. Each point is transformed using given transformation matrix.
Zcu.Mve.Visualization.Processing.UserTagChecker | Module checks user tags assigned with a dataSet. Found user tags are printed to console.
Zcu.Mve.Visualization.Processing.VolumeCut | Module for cutting, tresholding, etc.
Zcu.Mve.Visualization.Processing.VolumeDataConvertor | This module converts input volume from selected data type to output volume data of selected data type.
Zcu.Mve.Visualization.Processing.VolumeDataHistogram | This module analyzes volume data in the sense of creating histogram from its values.
Zcu.Mve.Visualization.Renderers.CurveRenderer | Module for curve rendering. This module renders input uniform data array of Point2D using polyLine or Bezier interpolation.
Zcu.Mve.Visualization.Renderers.RegGrid2DRenderer | Module for rendering of RegGrid2D (essentially picture). The user may choose which cell attribute to display (the AttrName property). Attributes of Scalar and ColorRGBA type may be used. When Scalar values are drawn, then values are normalized so that the whole white->black scale is used in the image.
Zcu.Mve.Visualization.Renderers.VolumeRendererWrapper | Wrapper for Pre-Integrated Volume Renderer
Zcu.Mve.Visualization.Renderers.VolumeSliceViewer | Module renders volume data as separate slices. Comment: Pixel values are normalized to 0-255 interval within all the dataset (i.e. not only each one image independently to the others in the dataset.).
Zcu.Mve.Visualization.Savers.BinarySaver | Module for saving volume data into a binary file. Processes one attribute of the Scalar or Integer type. Optionally can write a .vif file with file description
Zcu.Mve.Visualization.Savers.MeshSaver | Module for saving of mesh to .tri, .stl and .ply file formats.
Zcu.Mve.Visualization.Savers.ObjSaver |
Zcu.Mve.Visualization.Sources.PlaneSource | A module that produces a planar triangle mesh. The plane is represented by a point and two vectors of any dimension. The planes is split into specified number of facets. A, V1 and V2 should be vectors of equal dimension.
Zcu.Mve.Visualization.Sources.PointNDSource | A module that constructs a single PointND of any dimension. Use the Coords property to set the point coordinates.
Zcu.Mve.Visualization.Sources.RandomVectorGrid | Generates 3D regular grid with random vectors in every point.
Zcu.Mve.Visualization.Sources.RegGridNDSource | A source module for RegGridND. Grid's dimension, position and resolution can be controlled using the Mins, Maxs and Sizes properties.
Zcu.Mve.Visualization.Sources.RotationTransformSource | Source of Transform3D rotation matrix.
Zcu.Mve.Visualization.Sources.ScaleTransformSource | A module that represents a source of a uniform scale matrix. The scale coefficient will be read from the Scale factor input.
Zcu.Mve.Visualization.Sources.SphereSource | Source of a TriangleMesh containing vertices and triangles of sphere
Zcu.Mve.Visualization.Sources.Transform3DSource | Source of Transform3D matrix. Values from input ports are preffered. After input port disconnecting, last values remains.
Zcu.Mve.Visualization.Sources.TransformTranslationSource | A source of a translation transform matrix.

Data structures

Zcu.Mve.Visualization.AbstractTransform |
Zcu.Mve.Visualization.ColorIntensity |
Zcu.Mve.Visualization.ColorRGBA |
Zcu.Mve.Visualization.DataSet | Base class for all composed data types.
Zcu.Mve.Visualization.Grid2D | Two dimensional structured grid. Contains two tables: <ul> <li>table of cell (pixel) attributes with height x width resolution 2D uniform arrays.</li> <li>table of point (pixel vertices) attributes with height+1 x width+1 resolution 2D uniform arrays.</li> </ul>
Zcu.Mve.Visualization.GridND | N-dimensional structured grid.Contains two tables:<ul><li>table of cell (element) attributes with height x width resolution ND uniform arrays.</li><li>table of point (element vertices) attributes with height+1 x width+1 resolution ND uniform arrays.</li></ul>
Zcu.Mve.Visualization.IAttribute | Typical base class for any attribute data.
Zcu.Mve.Visualization.ICell | Represets a topological information. Triangle, Line, Tetrahedron are its typical examples. Only instaces of this type are accepted by UnstrGrid as topological information.
Zcu.Mve.Visualization.IColorVector | Interface that represents a color vector.
Zcu.Mve.Visualization.IGridCell |
Zcu.Mve.Visualization.INeighbor |
Zcu.Mve.Visualization.INormal | Represent a normal vector.
Zcu.Mve.Visualization.IPoint | Represents any geometric information. Point2D and Point3D are its typical subclasses. Only this type is accepted by UnstrGrid as geometric information.
Zcu.Mve.Visualization.Line |
Zcu.Mve.Visualization.Mesh | Specialization of UnstrGrid. Can contain only Triangle, TriangleStrip, TriangleFan, Line, PolyLine cells, Polygon. Attributes are not limited.
Zcu.Mve.Visualization.MveArray | Static multidimensional homogenous data array.
Zcu.Mve.Visualization.Normal2D |
Zcu.Mve.Visualization.Normal3D |
Zcu.Mve.Visualization.NormalND | Represents a n-dimensional normal defined by N elements.
Zcu.Mve.Visualization.Pixel |
Zcu.Mve.Visualization.Point2D | Represents a 2D point defined by two coordinates - X and Y.
Zcu.Mve.Visualization.Point3D | Represents a 3D point defined by three coordinates - X, Y and Z.
Zcu.Mve.Visualization.PointND |
Zcu.Mve.Visualization.Polygon |
Zcu.Mve.Visualization.PolyLine |
Zcu.Mve.Visualization.RectilinearGrid2D | Structured, semiregular, 2-dimensional grid.
Zcu.Mve.Visualization.RegGrid2D | Object represent ortogonal, regular two dimensional grid. Structure consists of pixels (cells) and points. Point location is given implicitly. Point with zero indices have [0,0] cooordinate values. Point with [height, width] indices have [1,1] cooordinate values.
Zcu.Mve.Visualization.RegGridND | Object represent orthogonal, regular N dimensional grid. Structure consists of points only. Point location is given implicitly.
Zcu.Mve.Visualization.Slice |
Zcu.Mve.Visualization.SliceSet | Specialization of UnstrGrid. Class represents set of slices. Only Slice can be a topological element.
Zcu.Mve.Visualization.StructGrid | Base class for all strucutured datatypes.
Zcu.Mve.Visualization.Tetrahedron |
Zcu.Mve.Visualization.TextureCoord |
Zcu.Mve.Visualization.Transform3D |
Zcu.Mve.Visualization.Transform4D |
Zcu.Mve.Visualization.Triangle | Structure represent topology of a Triangle. It is defined by tree point indices.
Zcu.Mve.Visualization.TriangleFan |
Zcu.Mve.Visualization.TriangleMesh |
Zcu.Mve.Visualization.TriangleNeighbor |
Zcu.Mve.Visualization.TriangleStrip |
Zcu.Mve.Visualization.TriangleStripMesh |
Zcu.Mve.Visualization.UniformDataArray |
Zcu.Mve.Visualization.UniformDataArray2D |
Zcu.Mve.Visualization.UniformDataArrayND |
Zcu.Mve.Visualization.UnstrGrid | Base class of the most general data type in Visualization library. <br></br>It consists of explicit arrays of points, cells, attributes.<br></br>Points are stored in one UniformDataArray. Thence it follows only one type of points is allowed. <br></br>Cells are stored in table of UniformDataArray. Thus there is possible to store arbitrary number of cells of different types. Each cell array is identified by a string ID. (Have to be unique in frame of one instance of UnstrGrid.)<br></br>Attribute arrays (uniform) are associated with points and cells array. Each cell or point array can have arbitrary number of attribute arrays. Attribute arrays are identified by a string ID. (Similar to cell arrays)
Zcu.Mve.Visualization.UnstrGridEigCell | Specialization of UnstrGrid. It contains a hash table that represents a set of available cell types. For more details see Mesh class.
Zcu.Mve.Visualization.VertexNeighbor |


Zcu.Mve.Visualization.Processing.IsoSurfaceExtractor

The iso-surface extractor module.

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Visualization.Processing.IsoSurfaceExtractor

You can set these properties:

  • NormalAttributeName
    Set name of normals point attribute. Default set to "Normal3D"
  • PointAttributeName
    Set name of RegGridND point attributes. Default set to "Values"
  • UseThresholdAsIsoValue
    Specifies whether to use input threshold as percentual value from min/max interval or directly as iso value.
  • Threshold
    Threshold of iso-surface value in percents. If 'useThresholdAsIsoValue' flag is set to True, is this value directly used as iso value to be searched (used for implicit surfaces visualization).
  • LinearInterpolation
    Interpolation type: true = linear interpolation false = center point.


Zcu.Mve.Visualization.Processing.MarchingTetrahedra

Module extracts iso-surface from input volume data with Marching Tetrahedra algorithm. Generates even more triangles/points than Marching. Cubes algorithm - it would be nice to use some module for triangle mesh simplification or another suitable post-processing. Module shall be used with 'VolLoader' module, which provides desired input data.

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Visualization.Processing.MarchingTetrahedra

You can set these properties:

  • NormalAttributeName
    Set name of normals point attribute. Default set to "Normal3D"
  • PointAttributeName
    Set name of RegGridND point attributes. Default set to "Values"
  • UseThresholdAsIsoValue
    Specifies whether to use input threshold as percentual value from min/max interval or directly as iso value.
  • Threshold
    Threshold of iso-surface value in percents. If 'useThresholdAsIsoValue' flag is set to True, is this value directly used as iso value to be searched (used for implicit surfaces visualization).
  • LinearInterpolation
    Interpolation type: true = linear interpolation false = center point.


Zcu.Mve.Visualization.Processing.MarchingTetrahedra6

Module extracts iso-surface from input volume data with Marching Tetrahedra algorithm. Generates even more triangles/points than Marching. Cubes algorithm - it would be nice to use some module for triangle mesh simplification or another suitable post-processing. Module shall be used with 'VolLoader' module, which provides desired input data.

Input Ports:
  • InRegGridND - Input volume data.
  • InThreshold - This value defines iso-surface threshold (in percents). Non-required input port.

Output Ports:
  • Out - Output data - triangle mesh.

Details:

Type of module: Filter.Volume|Volume.Filter
Version: 28.01.2014
Author: Jiří Zapletal


Zcu.Mve.Visualization.Processing.MarchingTetrahedra6

You can set these properties:

  • NormalAttributeName
    Set name of normals point attribute. Default set to "Normal3D"
  • PointAttributeName
    Set name of RegGridND point attributes. Default set to "Values"
  • UseThresholdAsIsoValue
    Specifies whether to use input threshold as percentual value from min/max interval or directly as iso value.
  • Threshold
    Threshold of iso-surface value in percents. If 'useThresholdAsIsoValue' flag is set to True, is this value directly used as iso value to be searched (used for implicit surfaces visualization).
  • LinearInterpolation
    Interpolation type: true = linear interpolation false = center point.


Zcu.Mve.Visualization.Processing.VolumeCut

Universal main module for cutting, tresholding, etc.

Input Ports:
  • Input Grid - Input RegGridND data

Output Ports:
  • Output Grid - Output RegGridND data

Details:

Type of module: Filter.Volume|Volume.Filter
Version: 28.01.2014
Author: Roman Soukal


Zcu.Mve.Visualization.Processing.VolumeCut

You can set these properties:

  • ChangeValue
    Set new value for cutted voxels. Default set to 0
  • ResultAttributeName
    Set name of RegGridND result attribute after cutting. Default set to "ResultValues"
  • CutValue
    Set new value for cut. Default set to 1
  • PointAttributeName
    Set name of RegGridND point attribute. Default set to "Values"
  • TypeOfComparing
    Set type of comparing operation (<, >, =, <=, >=). Default set to Lower (<)
  • CuttingAttributeName
    Set name of RegGridND attribute with cutting information. Default set to"CuttingValues"


Zcu.Mve.Visualization.Processing.Slicer

Module for slicing volume data

Input Ports:
  • Input array - RegGridND of any kind of data and any dimension to be sliced.

Output Ports:
  • Output data array - UniformDataArray2D that represent a slice of the input data.
  • Output triangle array - TriangleMesh that represent a slice of the input data. Points have attributes: Normal3D and ColorRGBA (default name).

Details:

Type of module: Filter.Volume|Volume.Filter
Version: 28.01.2014
Author: Vladimír Geršl


Zcu.Mve.Visualization.Processing.Slicer

You can set these properties:

  • Parameters
    Comma separated double values that represent coefficients a, b, c, d which defines plane of slice: ax + by + cz + d = 0. Values a, b, c defines normal vector and d is an offset.
  • Resolution
    Index of the dimension that will be used as width and as height of the slice. Must be >=1.
  • Interpolation
    Trillinear interpolation. If is it 'true', then interpolate values.
  • OutAttrName
    Output attribut name.
  • InAttrName
    Attribut name.


Zcu.Mve.Visualization.Loaders.DICOM_Loader

Module loads set of DICOM images (.dcm) from selected directory.

Input Ports:
  • DICOMDirectory - Directory containing DICOM images.

Output Ports:
  • OutRegGridND - Loaded data.

Details:

Type of module: Loader.Volume|Volume.Loader
Version: 28.01.2014
Author: Jiří Zapletal


Zcu.Mve.Visualization.Loaders.DICOM_Loader

You can set these properties:

  • Path
    Path to the DICOM directory.
  • PointAttributeName
    Set name of gridND point attributes. Default set to "Values"


Zcu.Mve.Visualization.Processing.MarchingTetrahedra5

Module extracts iso-surface from input volume data with Marching Tetrahedra algorithm. Generates even more triangles/points than Marching. Cubes algorithm - it would be nice to use some module for triangle mesh simplification or another suitable post-processing. Module shall be used with 'VolLoader' module, which provides desired input data.

Input Ports:
  • InRegGridND - Input volume data.
  • InThreshold - This value defines iso-surface threshold (in percents). Non-required input port.

Output Ports:
  • Out - Output data - triangle mesh.

Details:

Type of module: Filter.Volume|Volume.Filter
Version: 28.01.2014
Author: Jiří Zapletal


Zcu.Mve.Visualization.Processing.MarchingTetrahedra5

You can set these properties:

  • NormalAttributeName
    Set name of normals point attribute. Default set to "Normal3D"
  • PointAttributeName
    Set name of RegGridND point attributes. Default set to "Values"
  • UseThresholdAsIsoValue
    Specifies whether to use input threshold as percentual value from min/max interval or directly as iso value.
  • Threshold
    Threshold of iso-surface value in percents. If 'useThresholdAsIsoValue' flag is set to True, is this value directly used as iso value to be searched (used for implicit surfaces visualization).
  • LinearInterpolation
    Interpolation type: true = linear interpolation false = center point.


Zcu.Mve.Visualization.Sources.RandomVectorGrid

Module for generation of 3D regular grid with vector field

Output Ports:
  • vectorGrid -

Details:

Type of module: Source.Volume|Volume.Source
Version: 28.01.2014
Author: Martin Dohnal


Zcu.Mve.Visualization.Sources.RandomVectorGrid


Zcu.Mve.Visualization.Processing.Glyphs

Module can transfoms Normal3D or Vector3D or Scalar or Integer point atributes to glyphs

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Visualization.Processing.Glyphs

Modul Gui

You can set these properties:

  • AttributeName
    Name of attribute that will used to generate glyphs
  • GlobalScale
    Value of global scale factor
  • OriginalAttributeName
    Name afo ettribute that contains original attribute values
  • Orient
    If true glyphs will be oriented accoeding to vector input attributes
  • AttributeType
    Type of actual glyph (sphere, cone, cylinder , arrow, box)
  • KeepAtributes
    If true, original attribute that was used from glyph generation will be add to output unstrgrid
  • UseScale
    If true local scalin will be perfomed
  • AddIndexes
    If true point attribute that contains index of point from wich glyph was created, will be add to output unstrgid
  • IndexAttributeName
    Name of attribute that contains original point indexes
  • RandomMode
    if true glzph will be generated in random order, else in equal
  • UseGlobalScale
    If true global scaling wiil be perfomed
  • MaxGlyphs
    Maximal number of glyphs
  • MaskPoints
    If true maximun nuber of glyphs condiditon will be used


Zcu.Mve.Visualization.Processing.GlyphsFromUnstrGrid

Module can transfoms Normal3D or Vector3D or Scalar or Integer point atributes to glyphs

Input Ports:
  • UnstrGridGlyphIn - User defined glyph
  • UnstrGridIn - Unstrgrid from which point attributes will be created glyphs

Output Ports:
  • UnstrGridOut - Output Unstrgrid that contains glyphs

Details:

Type of module: Filter.Mesh|Mesh.Filter
Version: 28.01.2014
Author: Vaclav Bystricky


Zcu.Mve.Visualization.Processing.GlyphsFromUnstrGrid

You can set these properties:

  • AttributeName
    Name of attribute that will used to generate glyphs
  • GlobalScale
    Value of global scale factor
  • OriginalAttributeName
    Name afo ettribute that contains original attribute values
  • Orient
    If true glyphs will be oriented accoeding to vector input attributes
  • AttributeType
    Type of actual glyph (sphere, cone, cylinder , arrow, box)
  • KeepAtributes
    If true, original attribute that was used from glyph generation will be add to output unstrgrid
  • UseScale
    If true local scalin will be perfomed
  • AddIndexes
    If true point attribute that contains index of point from wich glyph was created, will be add to output unstrgid
  • IndexAttributeName
    Name of attribute that contains original point indexes
  • RandomMode
    if true glzph will be generated in random order, else in equal
  • UseGlobalScale
    If true global scaling wiil be perfomed
  • MaxGlyphs
    Maximal number of glyphs
  • MaskPoints
    If true maximun nuber of glyphs condiditon will be used


Zcu.Mve.Visualization.Sources.SphereSource

Output Ports:
  • Sphere mesh -

Details:

Type of module: Source.Mesh|Mesh.Source
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Visualization.Sources.SphereSource


Zcu.Mve.Visualization.Processing.PaletteLinear

A module that transforms a Scalar value into a ColorRGBA. Values lower or equal to zero will become C1, values greater or equal to one will become C2, values in between will become linear interpolations of C1 and C2. This module can be used with the ScalarAttr2ColorRGBA module as a palette.

Input Ports:
  • Value - Scalar value to be transformed into ColorRGBA

Output Ports:
  • Color - Resulting ColorRGBA value

Details:

Type of module: Filter.Number|Number.Filter
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Visualization.Processing.PaletteLinear

You can set these properties:

  • C1
    Color that will be used for values lower than zero, and as a blend for values between zero and one
  • C2
    Color that will be used for values greater than one, and as a blend for values between zero and one


Zcu.Mve.Visualization.Processing.EditablePalette

A module that transforms a Scalar value into a ColorRGBA. Values lower or equal to zero will be computed as equal to zero, values greater or equal to one will be computed as equal to one , values in between will become linear interpolations among control points.*

Input Ports:
  • Value - Scalar value to be transformed into ColorRGBA

Output Ports:
  • Color - Resulting ColorRGBA value

Details:

Type of module: Filter.Number|Number.Filter
Version: 28.01.2014
Author: Jan Štefány


Zcu.Mve.Visualization.Processing.EditablePalette

Method, which invokes setup


Zcu.Mve.Visualization.Sources.RotationTransformSource

Source of Transform3D rotation matrix.

Output Ports:
  • outTransform3D - Resulting transformation matrix.

Details:

Type of module: Source.Number|Number.Source
Version: 28.01.2014
Author: Jan Kaiser


Zcu.Mve.Visualization.Sources.RotationTransformSource

You can set these properties:

  • ShowInAngle
    Show/hide input port. When angle input port is shown,angle value is read from input port and value set in module properties is ignored.
  • RotationAxis
    Rotation axis.
  • Angle
    Rotation angle.
  • Unit
    Units in which the rotation angle will be provided. User can choose between degrees and radians.


Zcu.Mve.Visualization.Processing.Distance

Finds the longest distance between the points in the set.

Input Ports:
  • Points - Set of points

Output Ports:
  • Distance - Maximum distance
  • Index0 - Index of the first point forming the maximum distance
  • Index1 - Index of the second point forming the maximum distance

Details:

Type of module: Filter.Mesh|Mesh.Filter
Version: 28.01.2014
Author: Vit Ondracka


Zcu.Mve.Visualization.Processing.Distance


Zcu.Mve.Visualization.Processing.ColorMapingUnstr

Module which maps ColorRGBA value on chosen atribute of UnstrGrid type. It takes atribute selected by user, sends out it's remaped scalar values to any color palette and returned color values are saved as new, user named attribute.

Input Ports:
  • ColorRGBAIN -
  • UnstrGridIN - UnstrGrid Input

Output Ports:
  • ScalarOut -
  • UnstrGridOut -

Details:

Type of module: Filter.Mesh|Mesh.Filter
Version: 28.01.2014
Author: Jan Štefány


Zcu.Mve.Visualization.Processing.ColorMapingUnstr


Zcu.Mve.Visualization.Savers.BinarySaver

Input Ports:
  • Data - A 3D reggrid with input data
  • FileName - Optional input, contains file name to be saved. If not connected, then the filename propert will be used instead

Details:

Type of module: Saver.Volume|Volume.Saver
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Visualization.Savers.BinarySaver


Zcu.Mve.Visualization.Processing.UnstrGridTransform

A module that transforms and UnstrGrid or its descendant. Each point is transformed using given transformation matrix.

Input Ports:
  • Data - UnstrGrid to be transformed. When link is attached to this port a new output port is created with the same type as the input data.
  • Transform - Transform matrix used to transform geometry of the input.

Details:

Type of module: Filter.Mesh|Mesh.Filter
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Visualization.Processing.UnstrGridTransform


Zcu.Mve.Visualization.Processing.DisplaceMap

Creates a 3D triangle mesh from planar triangle mesh or regular 2D grid. Elevation (Z coordinate) is computed from XY plane according to scalar point attributes. Module provides advanced control over regular 2D grid sizing and positioning. If there is a triangle mesh at module input the resulting 3D triangle mesh won't have any point or cell attributes even if input mesh has had some. This is because the third dimension of created mesh may give attributes different meaning or make them a nonsense. For example point distance from origin or triangle normal vector would become incorrect.

How it works:
In case of planar triangle mesh input things are quite simple. Points of newly created 3D mesh have the same X and Y coordinates as those from original planar mesh. Z coordinate is computed as point elevation (point scalar attribute) multiplied by elevation factor which may be set in module configuration.

If there is a regular 2D grid at module input some additional computing is necessary. Z point coordinates are calculated the same way as in prewious case. Except this we have to determine coordinates X and Y. The input grid is regular so we can compute them quite easily according to grid size and position. See module setup description for further details about possible grid size and position settings.

Triangle mesh vertices are created in rows from left to right. Rows are created from bottom to top. Triangles are then made in strips (not real triangle strips, they are still just isolated triangles) in the same direction as vertices. Example of point and triangle creation order is shown in picture below. All triangles have counterclockwise vertex order.

Input Ports:
  • InputMesh - Regular 2D grid or planar triangle mesh with scalar point attributes.

Output Ports:
  • OutputMesh - Elevated 3D triangle mesh.

Details:

Type of module: Filter.Image|Image.Filter
Version: 15.05.2005
Author: Jiří Skála


Zcu.Mve.Visualization.Processing.DisplaceMap

DisplaceMap module setup dialog.

Elevation factor sets the multiplier of point elevation attributes. It's in fact point elevation scale. Elevation attribute name is the name for scalar point elevation attributes. It is recomended to use the default value unless you really need different attribute name.

The panel below provides settings for regular 2D grid input. Output mesh position determines where in the XY plane will be the output triangle mesh placed. It may be centered in the origin or start in the origin and continue to the first quadrant. See example in the image below.

The grid size may be set in two ways. First is to enter dimensions of a single grid cell. If you want cells to be square just check appropriate check box and enter X edge size only. Another way is to specify overall grid dimensions. Again you may only enter X edge size and check the check box to maintain original grid aspect ratio.


Zcu.Mve.Visualization.Renderers.CurveRenderer

Panel for data view.

Input Ports:
  • Input - UniformDataArray of Point2D for rendering.

Details:

Type of module: Output.Number|Number.Output
Version: 11.10.2005
Author: Miroslav Vavruška


Zcu.Mve.Visualization.Renderers.CurveRenderer

You can set these properties:

  • AxesLegendFont
    Axes legend font
  • ShowGridX
    Show grid on X-axis
  • ShowGridY
    Show grid on Y-axis
  • ShowLegendY
    Show legend on Y-axis
  • ShowLegendX
    Show legend on X-axis
  • ShowIndices
    Show indices
  • InterpolationType
    Type of interoplation
  • MarksLineColor
    Marks color
  • AxesLegendColor
    Axes legend color
  • DecimalPlacesCountY
    Number of decimal places in Y-axis legend
  • SegmentCountY
    Number of segments on Y-axis
  • SegmentCountX
    Number of segments on X-axis
  • HighlightMarksColor
    Highlight marks color
  • ShowGraphLine
    Show lines
  • Graph_mark_size
    Marks size
  • GraphMarkLineWidth
    Marks width
  • HighlightMarksWidth
    Highlight marks width
  • ShowBorder
    Show border
  • AxesLineColor
    Axes line color
  • AllowHighlighting
    Allow highlighting
  • HighlightMarksSize
    Highlight marks size
  • GraphLineColor
    Line color
  • IndicesFont
    Indices font
  • HighlightMarksFont
    Highlight marks font
  • DecimalPlacesCountX
    Number of decimal places in X-axis legend
  • ShowGraphMarks
    Show marks
  • GraphLineWidth
    Line width


Zcu.Mve.Visualization.Processing.BlockCutting

Module for block using for module "cutting by polyhedron" Block have 3 important parametres (width, height, deepth) and own location in space.

Output Ports:
  • Output - Output UnstrGrid block data

Details:

Type of module: Filter.Volume|Volume.Filter
Version: 28.01.2014
Author: Roman Soukal


Zcu.Mve.Visualization.Processing.BlockCutting

You can set these properties:

  • PlaneAttributeName
    Set name of RegGridND attribute with each plane information. Default set to"Planes"
  • BlockCoordinations
    Coordinates of left buttom corner of block. Example: a, b, c where a, b, c are floating point numbers.
  • Height
    Set height of block. Default set to "0.5"
  • Width
    Set width of block. Default set to "0.5"
  • Deeph
    Set deeph of block. Default set to "0.5"


Zcu.Mve.Visualization.Sources.RegGridNDSource

A source module for RegGridND. Grid's dimension, position and resolution can be controlled using the Mins, Maxs and Sizes properties.

Output Ports:
  • RegGridND - Resulting RegGridND.

Details:

Type of module: Source.Volume|Volume.Source
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Visualization.Sources.RegGridNDSource

You can set these properties:

  • Maxs
    Maxima in each dimension, separated by a comma
  • Mins
    Minima in each dimension, separated by a comma
  • Sizes
    Resolutions in each dimension, separated by a comma


Zcu.Mve.Visualization.Renderers.VolumeRendererWrapper

Wrapper for Pre-Integrated Volume Renderer.

Input Ports:
  • Input3DGrid - Three dimensional RegGridND to display

Details:

Type of module: Output.Volume|Volume.Output
Version: 28.01.2014
Author: Martin Holubář


Zcu.Mve.Visualization.Renderers.VolumeRendererWrapper

You can set these properties:

  • File
    Execute file of Pre-Integrated Volume Renderer
  • AnotherArguments
    Another arguments for renderer
  • OutDataType
    Indicates if data from RegGridND will be represented as a byte or ushort.
  • TargetFile
    Name of target file, where data will be saved
  • ScalarAttributeName
    Name of scalar cell attribute to be rendered
  • Directory
    Working directory, where the execute file of Pre-Integrated Volume Renderer is.
  • Colored
    If true, the color map will be created and used. Module needs to be connected with any palette


Zcu.Mve.Visualization.Processing.ArrayIterator

Generic module for iteration through UniformDataArray. Returns an element at a specified index. Index is specified by the Index port, array is specified by the Array input port. Output port updates its type upon connecting to output. Checks for type compatibility, throws runtime error.

Input Ports:
  • Array - The input UniformdataArray.
  • Index - Zero-based index of the desired element of array.

Output Ports:
  • Out - Array element at specified index. Updates port type on first connection.

Details:

Type of module: Generic
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Visualization.Processing.ArrayIterator


Zcu.Mve.Visualization.Processing.PaletteRainbow

A module that transforms a Scalar value into a ColorRGBA. Values lower or equal to zero will become C1, values greater or equal to one will become C2, values in between will become linear interpolations of C1 and C2. This module can be used with the ScalarAttr2ColorRGBA module as a palette.

Input Ports:
  • Value - Scalar value to be transformed into ColorRGBA

Output Ports:
  • Color - Resulting ColorRGBA value

Details:

Type of module: Filter.Number|Number.Filter
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Visualization.Processing.PaletteRainbow

You can set these properties:

  • C1
    Color that will be used as start/end color. Should be a saturated colour.


Zcu.Mve.Visualization.Savers.MeshSaver

Main class of MeshSaver. Loads and saves configuration file and runs file savers.

Input Ports:
  • FileName -
  • Input - Zcu.Mve.Visualization.Mesh - must contains vertices, triangles or polygons (for ply format), ...

Output Ports:
  • Output -

Details:

Type of module: Saver.Mesh|Mesh.Saver
Version: 24.05.2005
Author: Jan Bárta


Zcu.Mve.Visualization.Savers.MeshSaver


Zcu.Mve.Visualization.Loaders.MeshLoader

Main class of MeshLoader. Loads and saves configuration file and runs file readers.

Input Ports:
  • FileName -

Output Ports:
  • Output - Zcu.Mve.Visualization.Mesh - contains triangle mesh (tri, stl, cmx format) or polygons (ply format).

Details:

Type of module: Loader.Mesh|Mesh.Loader
Version: 24.05.2005
Author: Jan Bárta


Zcu.Mve.Visualization.Loaders.MeshLoader


Zcu.Mve.Visualization.Renderers.VolumeSliceViewer

Module renders volume data as separate slices.\n\nComment: Pixel values are normalized to 0-255 interval within all the dataset (i.e. not only each one image independently to the others in the dataset.).

Input Ports:
  • InVolumeData - Input volume data to be viewed.

Details:

Type of module: Output.Volume|Volume.Output
Version: 28.01.2014
Author: Jiří Zapletal


Zcu.Mve.Visualization.Renderers.VolumeSliceViewer

You can set these properties:

  • Plane
    Plane to be sliced.
  • Index
    Index of the slice in the selected plane (1 stands for the first slice). If the index exceeds number of the slices in the current plane, first slice will be selected.
  • PointAttributName
    Cell attribute name.
  • ZoomFactor
    Zoom factor of the viewed plane. Acceptable values for zoom: - OUT are smaller or equall to -2, defining how many times the plane will be reduced (e.g. -2 results in 1/2x = 50% of the original size, -3 in 1/3x = 33.333% size etc.). - IN are greater or equall to 1, defining how many times the plane will be magnified (e.g. 1 results in 1x = 100% = original size, 2 in 2x = 200% size etc.).
  • Invert
    Inverted image?


Zcu.Mve.Visualization.Processing.UserTagChecker

Input Ports:
  • Input dataset - DataSet instance to be checked. Only Visualisation.DataSet instances have user tags.

Details:

Type of module: Generic
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Visualization.Processing.UserTagChecker


Zcu.Mve.Visualization.Processing.UnstrGridModifyTransform

Modifies Transform matrix of UnstrGrid. Points of UnstrGrid remains untouched.

Input Ports:
  • inData - UnstrGrid whose transform matrix is to be changed.
  • inTransform - Transform matrix.

Details:

Type of module: Filter.Mesh|Mesh.Filter
Version: 28.01.2014
Author: Jan Kaiser


Zcu.Mve.Visualization.Processing.UnstrGridModifyTransform

You can set these properties:

  • TransformOperation
    Option to replace or multiply former transform matrix.


Zcu.Mve.Visualization.Renderers.RegGrid2DRenderer

Module for rendering of RegGrid2D (essentially picture).

Input Ports:
  • Input - RegGrid2D to render.

Details:

Type of module: Output.Number|Number.Output
Version: 07.09.2004
Author: Miroslav Vavruška, Libor Váša


Zcu.Mve.Visualization.Renderers.RegGrid2DRenderer

You can set these properties:

  • AttrName
    Name of the cell attribute to be displayed. Must be present in input RegGrid2D and must be of Scalar or ColorRGBA type.


Zcu.Mve.Visualization.Loaders.BinaryReaderMultiAttributes

Module that can read various attributes.

Input Ports:
  • DataSubsetDefinition - ND vector of a dimension two times the data dimension. It specifies the data subset.
  • FileName - Path to the loaded file.

Output Ports:
  • OutputDataGrid - Loaded data in the RegGridND data structure.

Details:

Type of module: Loader.Volume|Volume.Loader
Version: 02.09.2008
Author: Josef Vyškovský


Zcu.Mve.Visualization.Loaders.BinaryReaderMultiAttributes

You can set these properties:

  • DataDesc
    Description of the data attributes. Syntax: <attribute>;<attribute> Attribute syntax:<string atrtibute name>,<string atrtibute type>[<int dimension>] or <string atrtibute name>,<string atrtibute type>[<int dimension>],"inv" where "inv" means endian change Known types: int8, int16, int32, int64, uint8, uint16, unit32, uint64, float32, float64
  • MaximalValues
    Maximal coordinate values in each axis. Syntax: <double>;<double>;...;<double>
  • HeaderSize
    Size in bytes if a header in the data file - number of bytes to skip.
  • MinimalValues
    Minimal coordinate values in each axis. Syntax: <double>;<double>;...;<double>
  • DataGridDimension
    Dimension of the loaded data grid. Must be form {2,3,4}
  • NumberOfSamples
    Number of samples in each axis. Syntax: <integer>;<integer>;...;<integer>
  • MaxIndeces
    Maximal indeces of the selection. Syntax: <int>;<int>;...;<int>
  • DataFilePath
    File to load the data from.
  • MinIndeces
    Minimal indeces of the selection. Syntax: <int>;<int>;...;<int>


Zcu.Mve.Visualization.Loaders.TriangleLoader

Module for loading of triangle mesh from .tri format file. Support [Vertices], [Points], [Vertices' Normals], [Triangles' Normals]

Input Ports:
  • FileName - Name of the file to load from. Not required, when no link connected, then the value of the FileName property is used.

Output Ports:
  • Output - Loaded Mesh.

Details:

Type of module: Loader.Mesh|Mesh.Loader
Version: 01.07.2004
Author: Miroslav Vavruška, Libor Váša


Zcu.Mve.Visualization.Loaders.TriangleLoader

You can set these properties:

  • InvertNormals
    Use this option if you are importing files originally made for right-handed coordinate systems.
  • FileName
    File to load data from. Should be in the .tri format. The property has no effect when there's a connection at the Filename port.
  • Reload
    Determines whether or not to reload data each time the modul is asked for result. Set to true when the contens of the input files change, otherwise keep false.


Zcu.Mve.Visualization.Loaders.PictureLoader

Module for loading of 2D image from a file. Supported formats (JPEG, GIF, BMP). Image is returned as RegGrid2D.

Output Ports:
  • Output - Loaded image.

Details:

Type of module: Loader.Image|Image.Loader
Version: 05.02.2005
Author: Miroslav Vavruška and Milan Frank


Zcu.Mve.Visualization.Loaders.PictureLoader

You can set these properties:

  • FileName
    File to load picture from.
  • Reload
    Determines whether or not to reload data each time the modul is asked for result. Set to true when the contens of the input files change, otherwise keep false.


Zcu.Mve.Visualization.Sources.Transform3DSource

Source of Transform3D matrix. Values from input ports are preffered. After input port disconnecting, last values remains.

Output Ports:
  • outTransform3D - Resulting transformation matrix.

Details:

Type of module: Source.Number|Number.Source
Version: 28.01.2014
Author: Jan Kaiser


Zcu.Mve.Visualization.Sources.Transform3DSource

You can set these properties:

  • M13
    M[id,j] - transform matrix element.
  • M20
    M[id,j] - transform matrix element.
  • M33
    M[id,j] - transform matrix element.
  • M23
    M[id,j] - transform matrix element.
  • M32
    M[id,j] - transform matrix element.
  • M22
    M[id,j] - transform matrix element.
  • M31
    M[id,j] - transform matrix element.
  • M21
    M[id,j] - transform matrix element.
  • M11
    M[id,j] - transform matrix element.
  • M01
    M[id,j] - transform matrix element.
  • M10
    M[id,j] - transform matrix element.
  • M00
    M[id,j] - transform matrix element.
  • M03
    M[id,j] - transform matrix element.
  • M30
    M[id,j] - transform matrix element.
  • inM00
    Shows input port for M[id,j] - transform matrix element.
  • inM01
    Shows input port for M[id,j] - transform matrix element.
  • inM02
    Shows input port for M[id,j] - transform matrix element.
  • inM03
    Shows input port for M[id,j] - transform matrix element.
  • inM12
    Shows input port for M[id,j] - transform matrix element.
  • inM13
    Shows input port for M[id,j] - transform matrix element.
  • M12
    M[id,j] - transform matrix element.
  • inM30
    Shows input port for M[id,j] - transform matrix element.
  • inM20
    Shows input port for M[id,j] - transform matrix element.
  • inM21
    Shows input port for M[id,j] - transform matrix element.
  • inM22
    Shows input port for M[id,j] - transform matrix element.
  • inM23
    Shows input port for M[id,j] - transform matrix element.
  • inM32
    Shows input port for M[id,j] - transform matrix element.
  • inM10
    Shows input port for M[id,j] - transform matrix element.
  • M02
    M[id,j] - transform matrix element.
  • inM31
    Shows input port for M[id,j] - transform matrix element.
  • inM33
    Shows input port for M[id,j] - transform matrix element.
  • inM11
    Shows input port for M[id,j] - transform matrix element.


Zcu.Mve.Visualization.Processing.GlyphsFromRegGridNd

Module can transfoms Normal3D or Vector3D or Scalar or Integer point atributes to glyphs

Input Ports:
  • RegGridNDIn - RegGridND from which point attributes will be created glyphs
  • UnstrGridGlyphIn - User defined glyph

Output Ports:
  • UnstrGridOut - Output Unstrgrid that contains glyphs

Details:

Type of module: Filter.Volume|Volume.Filter
Version: 28.01.2014
Author: Vaclav Bystricky


Zcu.Mve.Visualization.Processing.GlyphsFromRegGridNd

You can set these properties:

  • AttributeName
    Name of attribute that will used to generate glyphs
  • GlobalScale
    Value of global scale factor
  • OriginalAttributeName
    Name afo ettribute that contains original attribute values
  • Orient
    If true glyphs will be oriented accoeding to vector input attributes
  • AttributeType
    Type of actual glyph (sphere, cone, cylinder , arrow, box)
  • KeepAtributes
    If true, original attribute that was used from glyph generation will be add to output unstrgrid
  • UseScale
    If true local scalin will be perfomed
  • AddIndexes
    If true point attribute that contains index of point from wich glyph was created, will be add to output unstrgid
  • IndexAttributeName
    Name of attribute that contains original point indexes
  • RandomMode
    if true glzph will be generated in random order, else in equal
  • UseGlobalScale
    If true global scaling wiil be perfomed
  • MaxGlyphs
    Maximal number of glyphs
  • MaskPoints
    If true maximun nuber of glyphs condiditon will be used


Zcu.Mve.Visualization.Processing.RegGridNDCalculator

This is a RegGridND version of a module that calculates new attribute values from existing attributes based on given expression. You can choose whether to work with point attributes or cell attributes. With point data, you can save the result as new coordinates or as a point attribute. For cell data, you have to specify the name of the cells array to be used. The results can be saved to a new attribute or an existing one, if an attribute with the specified name already exists.

Expression syntax:
numbers with '.' or ',' as decimal separator
names of input attributes
basic operations '+', '-', '*', '/', '%'
point ... coordinates of the current point (only while working with points)
index ... index of the current point or cell
pow(x; y) ... x to the power of y
log(x; y) ... logarithm of x with the root y
exp(x) ... exponential function of x
ln(x) ... natural logarithm of x
sqrt(x) ... square root of x
sin(x), cos(x), tan(x) ... goniometric functions of x
asin(x), acos(x), atan(x) ... inverse goniometric functions of x
sinh(x), cosh(x), tanh(x) ... hyperbolic functions of x
abs(x) ... absolute value of x
ceil(x) ... x rounded to the next higher integer
floor(x) ... x rounded to the next lower integer
ivec, jvec, kvec ... unit vectors of coordinate axes
norm(x) ... magnitude of vector x
smul(x; y) ... dot product of vectors x and y
vmul(x; y) ... cross product of vectors x and y
x[n] ... value of the nth element of vector x

Functions norm, smul, vmul and [] require vector operand(s). Addition and subtraction can be performed on either two vectors or two scalars, multiplication and division on one vector and one scalar. All other functions work only with scalar operand(s). You can create a vector by multiplying the coordinates by ivec, jvec and kvec and adding them together.

Input Ports:
  • Input - Input RegGridND data structure. Must contain attributes used in the expression.

Output Ports:
  • Output -

Details:

Type of module: Filter.Volume|Volume.Filter
Version: 28.01.2014
Author: Jan Krejčíř, Oldřich Petřík


Zcu.Mve.Visualization.Processing.RegGridNDCalculator

Shows the module setup dialog.


Zcu.Mve.Visualization.Processing.PlaneCutting

Module for cutting by plane Module calculates distances from specified plane for all the grid.

Input Ports:
  • Input Grid - Input RegGridND data
  • Input Point1 - First Input PointND (Size N=3 is needed) to calculate a distance (CCW orientation of points)
  • Input Point2 - Second Input PointND (Size N=3 is needed) to calculate a distance (CCW orientation of points)
  • Input Point3 - Third Input PointND (Size N=3 is needed) to calculate a distance (CCW orientation of points)

Output Ports:
  • Output Grid - Output RegGridND data

Details:

Type of module: Filter.Volume|Volume.Filter
Version: 28.01.2014
Author: Roman Soukal


Zcu.Mve.Visualization.Processing.PlaneCutting

You can set these properties:

  • CuttingAttributeName
    Set name of RegGridND attribute with cutting information. Default set to"CuttingValues"
  • PointAttributeName
    Set name of RegGridND point attribute. Default set to "Values"
  • Plane
    Plane coordinates. The plane is needed in implicit form (a.x + b.y + c.z + d = 0). Example: a,b,c,d


Zcu.Mve.Visualization.Processing.ConvexPolyhedronCutting

Module for cutting by polyhedron Polyhedron is in UnstrGrid type and contains attribute with triangles, where one triangle is one cutting plane. Value -1 is inside, value 0 is on the surface, value 1 is outside the polyhedron.

Input Ports:
  • Input Grid - Input RegGridND data
  • Input Polyhedron - Input UnstrGrid

Output Ports:
  • Output Grid - Output RegGridND data

Details:

Type of module: Filter.Volume|Volume.Filter
Version: 28.01.2014
Author: Roman Soukal


Zcu.Mve.Visualization.Processing.ConvexPolyhedronCutting

You can set these properties:

  • CuttingAttributeName
    Set name of RegGridND attribute with cutting information. Default set to"CuttingValues"
  • PlaneAttributeName
    Set name of RegGridND attribute with each plane information. Default set to"Planes"
  • PointAttributeName
    Set name of RegGridND point attribute. Default set to "Values"


Zcu.Mve.Visualization.Processing.Tube

Module which converts lines into tubes and points into spheres.

Input Ports:
  • Input - Input data - Points and lines.

Output Ports:
  • Output - Output data - triangle mesh.

Details:

Type of module: Filter.Mesh|Mesh.Filter
Version: 28.01.2014
Author: Zdeněk Prokop


Zcu.Mve.Visualization.Processing.Tube

You can set these properties:

  • ConvertLines
    If this property is set to true, the source lines will be converted to tubes. Otherwise they won't be converted.
  • SphereRadius
    The value of this property sets the radius of the sphere.
  • InputCellName
    The property determines name of cell which is processed.
  • SphereNumberOfSides
    The value of this property indicates the number of faces of the meridian. The value must be greater than or equal to 2.
  • ConvertPoints
    If this property is set to true, the source points will be converted to spheres. Otherwise they won't be converted.
  • TubeNumberOfSides
    The value of this property indicates the number of faces around the circumference of the tube. The value must be greater than or equal to 3.
  • AddInput
    If this property is set to true, the input data will be added to output. Otherwise output won't contain input data
  • TubeRadius
    The value of this property sets the radius of the tube.
  • CellName
    The property determines name of cell type.
  • NormalAttributeName
    The property determines name of point attribute which contains normal in the point.


Zcu.Mve.Visualization.Processing.PointDistanceCutting

Module for cutting by distance from point input point Module calculates distances from point for all the grid.

Input Ports:
  • Input Grid - Input RegGridND data
  • Input Point - Input PointND (Size N=3 is needed) to calculate a distance

Output Ports:
  • Output Grid - Output RegGridND data

Details:

Type of module: Filter.Volume|Volume.Filter
Version: 28.01.2014
Author: Roman Soukal


Zcu.Mve.Visualization.Processing.PointDistanceCutting

You can set these properties:

  • CuttingAttributeName
    Set name of RegGridND attribute with cutting information. Default set to"CuttingValues"
  • PointAttributeName
    Set name of RegGridND point attribute. Default set to "Values"


Zcu.Mve.Visualization.Sources.PointNDSource

Output Ports:
  • Point - Resulting PointND

Details:

Type of module: Source.Number|Number.Source
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Visualization.Sources.PointNDSource

You can set these properties:

  • Coords
    Coordinates of the point. Should be a comma separated list of floating point numbers.


Zcu.Mve.Visualization.Processing.NeighborTetrahedra

Summary description for NeighborTetrahedrons.

Input Ports:
  • Input UnstrGrid -

Output Ports:
  • Output UnstrGrid -

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Visualization.Processing.NeighborTetrahedra


Zcu.Mve.Visualization.Sources.PlaneSource

A module that produces a planar triangle mesh. The plane is represented by a point and two vectors of any dimension. The planes is split into specified number of facets. A, V1 and V2 should be vectors of equal dimension.

Input Ports:
  • A - A point on the plane, on of the mesh corners.
  • V1 - One of the direction vectors of the plane. A+V1 will becone one of the corners of the plane.
  • V2 - One of the direction vectors of the plane. A+V2 will becone one of the corners of the plane.

Output Ports:
  • Plane - The resulting planar mesh.

Details:

Type of module: Source.Mesh|Mesh.Source
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Visualization.Sources.PlaneSource

You can set these properties:

  • YS
    Number of steps in the direction of the V2 vector, should be >=1.
  • XS
    Number of steps in the direction of the V1 vector, should be >=1.


Zcu.Mve.Visualization.Processing.CalculateDisplace

CalculateDisplace module setup dialog.

Input Ports:
  • InputGrid - Regular 2D grid with cell color attributes. Typically a bitmap image.

Output Ports:
  • OutputGrid - Regular 2D grid with point color attributes.

Details:

Type of module: Filter.Image|Image.Filter
Version: 12.05.2005
Author: Jiří Skála


Zcu.Mve.Visualization.Processing.CalculateDisplace

CalculateDisplace module setup dialog.

Elevation map color processing determines how cell colors will be processed. You can select color lightness (also called intensity or value) or make the module use only one of RGB color components.

In the Attribute names panel you can specify names for input cell color attributes and for output point elevation attributes. It is recomended to use default values unless you really need different attribute names.


Zcu.Mve.Visualization.Processing.MarchingCubes

Module extracts iso-surface from input volume data with Marching Cubes algorithm. Generates large amount of triangles/points to render - it would be nice to use some module for triangle mesh simplification or another suitable post-processing. Module shall be used with 'VolLoader' module, which provides desired input data.

Input Ports:
  • InRegGridND - Input volume data.
  • InThreshold - This value defines iso-surface threshold (in percents). Non-required input port.

Output Ports:
  • Out - Output data - triangle mesh.

Details:

Type of module: Filter.Volume|Volume.Filter
Version: 28.01.2014
Author: Jiří Zapletal


Zcu.Mve.Visualization.Processing.MarchingCubes

You can set these properties:

  • NormalAttributeName
    Set name of normals point attribute. Default set to "Normal3D"
  • PointAttributeName
    Set name of RegGridND point attributes. Default set to "Values"
  • UseThresholdAsIsoValue
    Specifies whether to use input threshold as percentual value from min/max interval or directly as iso value.
  • Threshold
    Threshold of iso-surface value in percents. If 'useThresholdAsIsoValue' flag is set to True, is this value directly used as iso value to be searched (used for implicit surfaces visualization).
  • LinearInterpolation
    Interpolation type: true = linear interpolation false = center point.


Zcu.Mve.Visualization.Processing.TriangleMeshFixer

Input Ports:
  • Input mesh -

Output Ports:
  • Output mesh -

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Visualization.Processing.TriangleMeshFixer


Zcu.Mve.Visualization.Loaders.ObjLoader

Obj triangle mesh file loader module.

Input Ports:
  • Filename - MveString that contains name of file to load. If nothing is connected, then the value of the FileName property is used

Output Ports:
  • TextureCoordinates -
  • TriangleMesh - Mesh instance that contains vertices and triangles loaded from the file

Details:

Type of module: Loader.Mesh|Mesh.Loader
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Visualization.Loaders.ObjLoader

You can set these properties:

  • FileName
    File to load data from. Should be in the .obj format. The property has no effect when there's a connection at the Filename port.
  • TrianglesCellName
    Sets the identifier for the triangle cells in the output TriangleMesh
  • Reload
    Determines whether or not to reload data each time the modul is asked for result. Set to true when the contens of the input files change, otherwise keep false.


Zcu.Mve.Visualization.Processing.NormalComputer

Summary description for NormalComputer.

Input Ports:
  • TriangleMesh - Input triangle mesh to be processed

Output Ports:
  • Computed TriangleMesh - Shallow copy of the input mesh with added attribute that represents vertex normals.

Details:

Type of module: Filter.Mesh|Mesh.Filter
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Visualization.Processing.NormalComputer

You can set these properties:

  • OverwriteNormals
    Specifies whether or not normals should be overwritten if they are already present in the mesh.
  • InvertNormals
    Use this option if you are importing files originally made for right-handed coordinate systems.
  • AttrName
    Gets or sets the attribute name that will contain the normals. Cannot be set to an empty string.


Zcu.Mve.Visualization.Processing.Elevation

Paints triangle mesh points according to their elevation. Direction of elevation may be specified arbitrary in module setup dialog or by Vector3D connected to module input.

Several color mappings are available. If input triangle mesh is planar and perpendicular to the direction of elevation then all points are painted in the same color that corresponds to the lowest elevation level.

How it works:
Algorithm proceeds it two passes. In the first pass an elevation level for each point is computed. The direction of elevation yields a normal vector that designates parallel planes. Each point then lies within one of these planes and it determines it's elevation level.

In the second pass color attributes are assigned to points according to their elevation. Point colors are determined by selected color mapping scheme which is adapted to fit point elevation range.

Input Ports:
  • ElevationVector - Optional. Direction in which the elevation will be computed.
  • InputMesh - Triangle mesh to paint.

Output Ports:
  • OutputMesh - Triangle mesh with point color attributes.

Details:

Type of module: Filter.Mesh|Mesh.Filter
Version: 16.05.2005
Author: Jiří Skála


Zcu.Mve.Visualization.Processing.Elevation

Elevation module setup dialog.

Elevation vector specifies direction in which point elevation will be computed. The three buttons below helps quickly align vectors with one of coordinate system axes. Elevation vector setting is ignored if there is a vector connected to module input port.

Color attribute name is the name for color attributes that will be assigned to points. It is recomended to use the default value unless you really need different attribute name.

In the Color mapping panel you can choose which color mapping scheme will be applied to triangle mesh points. If you want inverse mapping just reverse the elevation vector.


Zcu.Mve.Visualization.Processing.VolumeDataHistogram

This module analyzes volume data in the sense of creating histogram from its values.

Input Ports:
  • InVolData - Input volume data.

Details:

Type of module: Filter.Volume|Volume.Filter
Version: 28.01.2014
Author: Jirí Zapletal


Zcu.Mve.Visualization.Processing.VolumeDataHistogram

You can set these properties:

  • YLabels
    Number of labels on y axis.
  • Height
    Height of the form where histogram is drawn.
  • LogarithmicScale
    Use logarithmic scale for the y-axis.
  • Width
    Width of the form where histogram is drawn.
  • Margin
    Margin of the border of the form.
  • LeftMargin
    Left margin (between border of the form and the y axis).
  • OddBarColor
    Color of odd bars in histogram.
  • FontSize
    Number of labels on y axis.
  • EvenBarColor
    Color of even bars in histogram.
  • XLabels
    Number of labels on x axis.
  • ShowGuideLines
    Defines, whether to draw guidelines of the histogram.


Zcu.Mve.Visualization.Processing.VolumeDataConvertor

This module converts input volume from selected data type to output volume data of selected data type.

Input Ports:
  • InVolDataInt - Input integer volume data.

Output Ports:
  • OutVolDataDouble - Output double volume data.

Details:

Type of module: Filter.Volume|Volume.Filter
Version: 28.01.2014
Author: Jirí Zapletal


Zcu.Mve.Visualization.Processing.VolumeDataConvertor

You can set these properties:

  • ConvertTo
    To what data type to convert.
  • ConvertFrom
    From what data type to convert.


Zcu.Mve.Visualization.Processing.SeparateAttribute

Input Ports:
  • UnstrGrid -

Output Ports:
  • Attribute -

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Visualization.Processing.SeparateAttribute


Zcu.Mve.Visualization.Processing.GeometryCut

This modul provide cutting off geometric cells according to points scalar attribute. The name of points scalar attribute with evaluation for cut can be set by property. If attribut with given name not found, first points scalar attribute is use.

Input Ports:
  • In - Input port for UnstrGrid value with points evaluation to cut.

Output Ports:
  • Out - UnstrGrid with new cutted values.

Details:

Type of module: unspecified
Version: 28.01.2014
Author: Tomáš Hofhans


Zcu.Mve.Visualization.Processing.GeometryCut

You can set these properties:

  • TresholdValue
    Treshold value for cut.
  • CutFunctionAttrName
    Name of preffered points scalar attribute with evaluation for cut.
  • CutGreater
    True if you want cut greater values from treshold value, otherwise cut less values.


Zcu.Mve.Visualization.Loaders.BinaryReaderSingleAttribute

Reader that can read only one attribute, that can be specified by user.

Input Ports:
  • DataSubsetDefinition - ND vector of a dimension two times the data dimension. It specifies the data subset.
  • FileName - Path to the loaded file.
  • VifHeaderFile -

Output Ports:
  • OutputDataGrid - Loaded data in the RegGridND data structure.

Details:

Type of module: Loader.Volume|Volume.Loader
Version: 02.09.2008
Author: Josef Vyškovský


Zcu.Mve.Visualization.Loaders.BinaryReaderSingleAttribute

You can set these properties:

  • AttrDim
    Description of the data attributes. Syntax: <attribute>;<attribute> Attribute syntax:<string atrtibute name>,<string atrtibute type>[<int dimension>] Known types: int8, int16, int32, int64, uint8, uint16, unit32, uint64, float32, float64
  • MaxIndeces
    Maximal indeces of the selection. Syntax: <int>;<int>;...;<int>
  • HeaderSize
    Size in bytes of an embedded header in the data file.
  • MaximalValues
    Maximal coordinate values in each axis. Syntax: <double>;<double>;...;<double>
  • MinIndeces
    Minimal indeces of the selection. Syntax: <int>;<int>;...;<int>
  • HeaderFilePath
    File to load the data header from.
  • MinimalValues
    Minimal coordinate values in each axis. Syntax: <double>;<double>;...;<double>
  • InvertEndian
    Shall the readed data have their endian inverted?
  • DataGridDimension
    Dimension of the loaded data grid. Must be from {2,3,4}
  • NumberOfSamples
    Number of samples in each axis. Syntax: <integer>;<integer>;...;<integer>
  • AttrTypeName
    Description of the data attributes. Syntax: <attribute>;<attribute> Attribute syntax:<string atrtibute name>,<string atrtibute type>[<int dimension>] Known types: int8, int16, int32, int64, uint8, uint16, unit32, uint64, float32, float64
  • DataFilePath
    File to load the data from.
  • AttrName
    Description of the data attributes. Syntax: <attribute>;<attribute> Attribute syntax:<string atrtibute name>,<string atrtibute type>[<int dimension>] Known types: int8, int16, int32, int64, uint8, uint16, unit32, uint64, float32, float64


Zcu.Mve.Visualization.Sources.TransformTranslationSource

A source of a translation transform matrix.

Input Ports:
  • X - Scalar value of the translation in the X axis
  • Y - Scalar value of the translation in the Y axis
  • Z - Scalar value of the translation in the Z axis

Output Ports:
  • Transform - Resulting transformation matrix.

Details:

Type of module: Source.Number|Number.Source
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Visualization.Sources.TransformTranslationSource

You can set these properties:

  • Y
    Translation coefficient in the Y direction. Only works when nothing is connected to the Y input port.
  • Z
    Translation coefficient in the Z direction. Only works when nothing is connected to the Z input port.
  • X
    Translation coefficient in the X direction. Only works when nothing is connected to the X input port.


Zcu.Mve.Visualization.Savers.ObjSaver

Input Ports:
  • FileName -
  • Mesh -

Output Ports:
  • Mesh -

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Visualization.Savers.ObjSaver


Zcu.Mve.Visualization.Processing.MeshSmooth

Module makes TriangleMesh more complex using PN Triangles.

Input Ports:
  • InMesh - Input triangle mesh

Output Ports:
  • OutMesh - Input triangle mesh

Details:

Type of module: Filter.Mesh|Mesh.Filter
Version: 28.01.2014
Author: Luboš Kolářík


Zcu.Mve.Visualization.Processing.MeshSmooth


Zcu.Mve.Visualization.Processing.MeshDualGraph

Module constructs a dual graph for a triangular mesh. The module uses the first attribute of the Triangle type. The vertices of the output are located at centres of original triangles, neighbouring triangles are connected by edges.

Input Ports:
  • InMesh - Input mesh, should contain at least one attribute of the Triangle type. Vertices should be of the Point3D type.

Output Ports:
  • DualGraph - Output mesh, one vertex for each original triangle, neighbouring triangles connected by an edge.

Details:

Type of module: Filter.Mesh|Mesh.Filter
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Visualization.Processing.MeshDualGraph


Zcu.Mve.Visualization.Processing.AppendAttribute

Input Ports:
  • Attribute -
  • Unstrgrid -

Output Ports:
  • Result -

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Visualization.Processing.AppendAttribute


Zcu.Mve.Visualization.Processing.UniformDataArrayComposer

A general class that composes a new uniformDataArray. Any Dataobject can be attached to the input port, causing further ports of the same type to appear.

Input Ports:
  • Head - First element of the array shoud be connected to this port, causing further ports to appear

Output Ports:
  • Result - Resulting UniformDataArray

Details:

Type of module: Generic
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Visualization.Processing.UniformDataArrayComposer


Zcu.Mve.Visualization.Processing.Streamlines

Streamlines generator

Input Ports:
  • vectorGrid - Regular grid which contains vector point attribute to compute streamlines from. Only RegGrid2D and three dimensional RegGridND is supported. Vector attribute must be of type Vector2D or Vector3D.

Output Ports:
  • streamlines - Unstructured grid (UnstrGrid) holding streamlines and point attributes speed and time in their points.

Details:

Type of module: Filter.Volume|Volume.Filter
Version: 28.01.2014
Author: Martin Dohnal


Zcu.Mve.Visualization.Processing.Streamlines

You can set these properties:

  • Radius
    Maximal radius of generated seeds from specified source point.
  • MaxStepsBackward
    Maximum count of backward steps in one streamline.
  • TerminateSpeed
    Minimum speed when should be integration terminated.
  • StreamlinesAttributeName
    Name of cell attribute which holds streamlines stored in output.
  • SpeedAttributeName
    Speed attribute name.
  • VectorFieldName
    Name of vector field to create streamlines from. If vector field by given name is not found, module tries to find one.
  • SeedCount
    Seed count
  • StoreInputAttributes
    If input point attributes at streamline points should be stored in output.
  • LineEnd
    Line end point
  • ErrorTolerance
    Approximated maximum error of one integration step. Works only with RungeKutta4Adaptive integrator.
  • IntegratorType
    Integrator type. Euler integration is fastest but accumulates biggest error. Runge-Kutta 4 adaptive is slowest but offers error control and best precision.
  • Interpolation
    Interpolation type. Linear if less acurate but lot faster.
  • AutomaticSeedPosition
    Sets source point to the center of the grid.
  • SourcePoint
    Source point for generating seeds.
  • Recompute
    If streamlines should be recomputed every execution
  • MaxStepsForward
    Maximum count of forward steps in one streamline.
  • LineStart
    Line start point
  • TimeAttributeName
    Time attribute name.
  • SeedType
    Seed type
  • Dt
    Time step for integration.


Zcu.Mve.Visualization.Sources.ScaleTransformSource

A module that represents a source of a uniform scale matrix. The scale coefficient will be read from the Scale factor input.

Input Ports:
  • Scale factor - A scalar value taht will be used as the uniform scale factor.

Output Ports:
  • Transform matrix - The resulting transform matrix (Transform3D).

Details:

Type of module: Source.Number|Number.Source
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Visualization.Sources.ScaleTransformSource


Zcu.Mve.Visualization.Processing.AttributeHistogram

Input Ports:
  • Mesh -

Output Ports:
  • Histogram -

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Visualization.Processing.AttributeHistogram


Zcu.Mve.Visualization.Processing.UnstrGridCalculator

This is an UnstrGrid version of a module that calculates new attribute values from existing attributes based on given expression. You can choose whether to work with point attributes or cell attributes. With point data, you can save the result as new coordinates or as a point attribute. For cell data, you have to specify the name of the cells array to be used. The results can be saved to a new attribute or an existing one, if an attribute with the specified name already exists.

Expression syntax:
numbers with '.' or ',' as decimal separator
names of input attributes
basic operations '+', '-', '*', '/', '%'
point ... coordinates of the current point (only while working with points)
index ... index of the current point or cell
pow(x; y) ... x to the power of y
log(x; y) ... logarithm of x with the root y
exp(x) ... exponential function of x
ln(x) ... natural logarithm of x
sqrt(x) ... square root of x
sin(x), cos(x), tan(x) ... goniometric functions of x
asin(x), acos(x), atan(x) ... inverse goniometric functions of x
sinh(x), cosh(x), tanh(x) ... hyperbolic functions of x
abs(x) ... absolute value of x
ceil(x) ... x rounded to the next higher integer
floor(x) ... x rounded to the next lower integer
ivec, jvec, kvec ... unit vectors of coordinate axes
norm(x) ... magnitude of vector x
smul(x; y) ... dot product of vectors x and y
vmul(x; y) ... cross product of vectors x and y
x[n] ... value of the nth element of vector x

Functions norm, smul, vmul and [] require vector operand(s). Addition and subtraction can be performed on either two vectors or two scalars, multiplication and division on one vector and one scalar. All other functions work only with scalar operand(s). You can create a vector by multiplying the coordinates by ivec, jvec and kvec and adding them together.

Input Ports:
  • Input - Input UnstrGrid data structure. Must contain attributes used in the expression.

Output Ports:
  • Output -

Details:

Type of module: Filter.Mesh|Mesh.Filter
Version: 28.01.2014
Author: Jan Krejčíř, Oldřich Petřík


Zcu.Mve.Visualization.Processing.UnstrGridCalculator

Shows the module setup dialog.


Zcu.Mve.Visualization.IAttribute

Index | Overview | Members

Typical base class for any information that is about to be associated with geometrical and/or topological element.
Eg.: Neighbour, Normal, ColorRGBA.
This interface is not particulary important but it is recommended to mark typical attribute information with IAttribute interface.

Inheritance:

Zcu.Mve.Visualization.IAttribute

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.IAttribute

Index | Overview | Members


Zcu.Mve.Visualization.INeighbor

Index | Overview | Members

Interface for neighbors.

Inheritance:

Zcu.Mve.Visualization.INeighbor

Implements:

Zcu.Mve.Visualization.IAttribute
Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.INeighbor

Index | Overview | Members


Zcu.Mve.Visualization.VertexNeighbor

Index | Overview | Members

This structure represents Vertex neighbors.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Visualization.VertexNeighbor

Implements:

Zcu.Mve.Visualization.INeighbor
Zcu.Mve.Visualization.IAttribute
Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.VertexNeighbor

Index | Overview | Members

Constructors

VertexNeighbor ( System.Int32[] neighbors )
Creates an object with values.
  • neighbors
    Array of neighbor indices.

Public methods

final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
Read data from Xml file to current structure.
  • xmlTextReader
    Stream to be read.

System.Void Add ( System.Int32 neighbor ) ;
Adds a new neighbor to the list. If the list is already closed, the exception is thrown.

  • neighbor

final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
Deep copy of data object and its subelements.

    Returns:
    Same data, different memory space.

    System.Void Close ( ) ;
    Close the VertexNeighbor list, converts the list to an array and frees the memory. It will not be possible to add another neighbor.

      final virtual System.Boolean CheckConsistence ( ) ;
      Check the consistency of current data structure.

        Returns:
        True if structure is consistent.

        virtual System.String ToString ( ) ;
        Returns a String that represents the current Object.

          Returns:
          String that represents the current Object.

          final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
          Write current data to Xml file.

          • xmlTextWriter
            Stream to be write.

          Public properties

          final virtual System.String[] LibNames { get; }
          Returns array of assembly name.

          System.Int32 Item { get;set; }
          VertexNeighbor indexer.

          System.Int32 Count { get; }
          Number of neighbors.

          System.Boolean IsClosed { get; }
          Returns the status of VertexNeighbor list. If it is closed, it is not possible to use Add operation.

          System.Int32[] Neighbors { get; }
          Indices to neighboring vertices.


Zcu.Mve.Visualization.AbstractTransform

Index | Overview | Members

Abstract base class for any transormation.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.AbstractTransform

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.AbstractTransform

Index | Overview | Members

Constructors

AbstractTransform ( )
Implicit constructor.


Zcu.Mve.Visualization.Transform4D

Index | Overview | Members

General projective tranformation in 4D space.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.AbstractTransform
Zcu.Mve.Visualization.Transform4D

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.Transform4D

Index | Overview | Members

Constructors

Transform4D ( )
Creates a Transform4D object and initialize it (set identity).

    Public methods

    System.Void AddRotationXY ( System.Double angle ) ;
    Cumulative rotation in XY plane measured in radians.
    • angle
      Rotation angle masured in radians.

    System.Void AddRotationZW ( System.Double angle ) ;
    Cumulative rotation in ZW plane measured in radians.

    • angle
      Rotation angle masured in radians.

    System.Void AddRotationXW ( System.Double angle ) ;
    Cumulative rotation in XW plane measured in radians.

    • angle
      Rotation angle masured in radians.

    System.Void SetRotationYW ( System.Double angle ) ;
    Noncumulative rotation in YW plane measured in radians.

    • angle
      Rotation angle masured in radians.

    System.Void AddRotationXZ ( System.Double angle ) ;
    Cumulative rotation in XZ plane measured in radians.

    • angle
      Rotation angle masured in radians.

    virtual System.Boolean CheckConsistence ( ) ;
    Check the consistency of current data structure.

      Returns:
      True if structure is consistent.

      virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
      Read data from Xml file to current structure.

      • xmlTextReader
        Stream to be read.

      System.Void AddScale ( System.Double dx, System.Double dy, System.Double dz, System.Double dw ) ;
      Add scaling to current transformation. TODO: Optimize it!

      • dx
        Scaling in x-axis. 1 means no scale.
      • dy
        Scaling in y-axis. 1 means no scale.
      • dz
        Scaling in z-axis. 1 means no scale.
      • dw
        Scaling in w-axis. 1 means no scale.

      System.Void SetRotationXZ ( System.Double angle ) ;
      Noncumulative rotation in XZ plane measured in radians.

      • angle
        Rotation angle masured in radians.

      virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
      Deep copy of data object and its subelements.

        Returns:
        Same data, different memory space.

        System.Void SetIdentity ( ) ;
        Set identity transformation.

          System.Void SetRotationYZ ( System.Double angle ) ;
          Noncumulative rotation in YZ plane measured in radians.

          • angle
            Rotation angle masured in radians.

          virtual System.Int32 GetHashCode ( ) ;
          Returns a hash code for the current Object.

            Returns:
            A hash code for the current Object.

            virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
            Write current data to Xml file.

            • xmlTextWriter
              Stream to be write.

            System.Void SetRotationXW ( System.Double angle ) ;
            Noncumulative rotation in XW plane measured in radians.

            • angle
              Rotation angle masured in radians.

            virtual System.Boolean Equals ( System.Object obj ) ;
            Determines whether the specified Object is equal to the current Object.

            • obj
              Specified Object to compare with the current Object.

            Returns:
            True if the specified Object is equal to the current Object. Otherwise, false.

            System.Void SetRotation ( System.Int32 axis1, System.Int32 axis2, System.Double angle ) ;
            Noncumulative rotation in plane defined by two axes (0 represents the X axis, 3 represents the W axis.

            • angle
              Rotation angle masured in radians.
            • axis1
              First axis forming the rotation plane.
            • axis2
              Second axis forming the rotation plane.

            virtual System.String ToString ( ) ;
            Returns a String that represents the current Object.

              Returns:
              String that represents the current Object.

              static System.Boolean Equals ( System.Object a, System.Object b ) ;
              Determines whether the specified Objects are equal.

              • a
                First Object.
              • b
                Second Object.

              Returns:
              True if objects are equal. Otherwise, false.

              System.Void SetRotationXY ( System.Double angle ) ;
              Noncumulative rotation in XY plane measured in radians.

              • angle
                Rotation angle masured in radians.

              System.Void SetTranslation ( System.Double x, System.Double y, System.Double z, System.Double w ) ;
              Noncumlative translation.

              • x
                Translation in x-axis.
              • y
                Translation in y-axis.
              • z
                Translation in z-axis.
              • w
                Translation in w-axis.

              System.Void AddTranslation ( System.Double x, System.Double y, System.Double z, System.Double w ) ;
              Cumulative translation

              • x
                Translation in x-axis.
              • y
                Translation in y-axis.
              • z
                Translation in z-axis.
              • w
                Translation in w-axis.

              System.Void AddRotationYW ( System.Double angle ) ;
              Cumulative rotation in YW plane measured in radians.

              • angle
                Rotation angle masured in radians.

              System.Void AddRotationYZ ( System.Double angle ) ;
              Cumulative rotation in YZ plane measured in radians.

              • angle
                Rotation angle masured in radians.

              System.Void SetScale ( System.Double dx, System.Double dy, System.Double dz, System.Double dw ) ;
              Set curent matrix to scaling matrix of given values.

              • dx
                Scaling in x-axis. 1 means no scale.
              • dy
                Scaling in y-axis. 1 means no scale.
              • dz
                Scaling in z-axis. 1 means no scale.
              • dw
                Scaling in w-axis. 1 means no scale.

              System.Void SetRotationZW ( System.Double angle ) ;
              Noncumulative rotation in ZW plane measured in radians.

              • angle
                Rotation angle masured in radians.

              Zcu.Mve.Visualization.PointND Transform ( Zcu.Mve.Visualization.PointND op ) ;
              Transform the point.

              • op
                Point to be transformed. This parameter won't be changed.

              Returns:
              New instance of transformed point.

              System.Void AddRotation ( System.Int32 axis1, System.Int32 axis2, System.Double angle ) ;
              Cumulative rotation in a plane defined by two axes (0 represents the X axis, 3 represents the W axis.

              • angle
                Rotation angle masured in radians.
              • axis1
                First axis forming the rotation plane.
              • axis2
                Second axis forming the rotation plane.

              Public properties

              System.Double Item { get;set; }
              Full access to particular matrix elements.

              Public fields

              static System.Double Epsilon
              The toleration for equality operator.


Zcu.Mve.Visualization.DataSet

Index | Overview | Members

Base class for all composed data types.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.DataSet

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.DataSet

Index | Overview | Members

Constructors

DataSet ( )
Implicit constructor. Usually for XmlLoader only.

    Public methods

    virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
    Reads the dataset from a XML file. This base method should be called by its overrides, because it loads the user tags.
    • xmlTextReader
      XML reader to read from.

    virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
    Writes the dataset into a XML file. This base method should be called by its overrides, because it saves the user tags.

    • xmlTextWriter
      XML reader to use for writing data.

    Public properties

    System.Collections.Generic.Dictionary`2[[System.String, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Zcu.Mve.Core.IDataObject, MveCore, Version=0.2.5141.21388, Culture=neutral, PublicKeyToken=a46303622ff25f8d]] UserTags { get; }
    Public property that encapsulates the user defined tags

    Public fields

    Zcu.Mve.Visualization.AbstractTransform Trans
    Transformation.

    Protected methods

    System.Void SerializeUserTags ( System.Xml.XmlTextWriter writer ) ;
    User tags serialisation. Is called from the default implementation of the WriteData method. Can be called explicitly or from the overriden ReadData method using the base() calling. Writes a UserTags element, which contains a number of UserTag elements, which contain serialisations of the user tags.
    • writer
      Writer to be used

    System.Void DeserializeUserTags ( System.Xml.XmlTextReader reader ) ;
    User tags deserialization. Is called from the default implementation of the readXML method. Can be called explicitly or from the overriden ReadData method using the base() calling.

    • reader
      reader to be used. Should point to "data" elemt that contains the data.


Zcu.Mve.Visualization.UnstrGrid

Index | Overview | Members

Base class of the most general data type in Visualization library.
It consists of explicit arrays of points, cells, attributes.
Points are stored in one UniformDataArray. Thence it follows only one type of points is allowed.
Cells are stored in table of UniformDataArray. Thus there is possible to store arbitrary number of cells of different types. Each cell array is identified by a string ID. (Have to be unique in frame of one instance of UnstrGrid.)
Attribute arrays (uniform) are associated with points and cells array. Each cell or point array can have arbitrary number of attribute arrays. Attribute arrays are identified by a string ID. (Similar to cell arrays)

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.DataSet
Zcu.Mve.Visualization.UnstrGrid

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.UnstrGrid

Index | Overview | Members

Constructors

UnstrGrid ( )
Creates empty (no point array, no cell array and no attributes) unstructured grid.

    Public methods

    virtual System.Boolean CheckConsistence ( ) ;
    Check consistence of curent structure and its substructures (arrays).

      Returns:
      If OK returns true, otherwise false.

      virtual System.Void AddCells ( System.String cellId, Zcu.Mve.Visualization.UniformDataArray cells ) ;
      Add uniform cell array.

      • cellId
        Unique (in curent UnstrGrid) ID of cell array.
      • cells
        Uniform cells array.

      System.Boolean ContainsCellAttrs ( System.String cellId, System.String attrId ) ;
      Returns whether cell attributes named attrId are present.

      • cellId
        ID of cell.
      • attrId
        ID of attributes.

      Returns:
      True if cell attributes named attrId are present, otherwise false.

      System.Collections.Generic.ICollection`1[[System.String, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] GetCellAttrsIds ( System.String cellId ) ;
      Returns collection of cell attribute array ids.

      • cellId
        ID of cell array.

      Returns:
      Collection of cell attribute array ids.

      Zcu.Mve.Visualization.UniformDataArray GetPointAttrs ( System.String attrId ) ;
      Returns particular array of point attributes.

      • attrId
        Name of attribute array.

      Returns:
      Returns particular array of point attributes. If name is not present returns null.

      virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
      Read data from Xml file to current structure.

      • xmlTextReader
        Stream to be read.

      virtual System.String[] GetCellIds ( System.Type type ) ;
      Returns array of identifiers of cell arrays of given type.

        Returns:
        Array of identifiers of cell arrays of given type.

        Zcu.Mve.Visualization.UniformDataArray[] GetCells ( System.Type typeOfCells ) ;
        Returns array of cell arrays of given type.

        • typeOfCells
          Type of cells.

        Returns:
        Array of cell arrays of given type.

        Zcu.Mve.Visualization.UniformDataArray GetCellAttrs ( System.String cellId, System.String attrId ) ;
        Returns particular array of cell attributes.

        • cellId
          ID of cells.
        • attrId
          ID of attributes.

        Returns:
        Particular array of cell attributes. If name is not present, returns null.

        virtual System.Void RemoveCells ( System.String cellId ) ;
        Remove array of cells and associated attributes.

        • cellId
          Unique (in curent UnstrGrid) ID of cell array.

        virtual System.String ToString ( ) ;
        Returns a String that represents the current Object.

          Returns:
          String that represents the current Object.

          System.Boolean ContainsCells ( System.String cellId ) ;
          Returns whether cells named cellId are present.

          • cellId
            ID of cell.

          Returns:
          True if cells named cellId are present, otherwise false.

          virtual System.Collections.Generic.ICollection`1[[System.String, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] GetCellIds ( ) ;
          Returns array of identifiers of all cell arrays.

            Returns:
            Array of identifiers of all cell arrays.

            virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
            Write current data to Xml file.

            • xmlTextWriter
              Stream to be write.

            System.Void RemoveCellAttrs ( System.String cellId, System.String attrId ) ;
            Remove array of cell attributes. If do not exists throws an MveException.

            • cellId
              Id of cell array.
            • attrId
              Id of attribute array to be removed.

            Zcu.Mve.Visualization.UniformDataArray[] GetPointAttrs ( System.Type typeOfCells ) ;
            Returns array of point attributes of given type.

            • typeOfCells
              Type of attributes.

            Returns:
            Array of point attributes of given type.

            System.Collections.Generic.ICollection`1[[System.String, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] GetPointAttrsIds ( ) ;
            Returns collection of point attribute array.

              Returns:
              Collection of point attribute array.

              virtual System.Void AddPointAttrs ( System.String attrId, Zcu.Mve.Visualization.UniformDataArray attrs ) ;
              Add array of point attributes. The length should be equal length of points array. Id have to be unique in frame of curent instance of UnstrGrid.

              • attrId
                Id of attribute array.
              • attrs
                Uniform data array of point attributes.

              Zcu.Mve.Visualization.UniformDataArray[] GetCellAttrs ( System.String cellId, System.Type attrType ) ;
              Returns particular array of cell attributes.

              • cellId
                ID of cells.
              • attrId
                ID of attributes.

              Returns:
              Particular array of cell attributes. If name is not present, returns null.

              virtual System.Void AddCellAttrs ( System.String cellId, System.String attrId, Zcu.Mve.Visualization.UniformDataArray attrs ) ;
              Add array of cell attributes. The cell array have to exists. The length have to be equal length of cells array.

              • cellId
                Id of cell array.
              • attrId
                Id of attribute array to be removed.
              • attrs
                Attributes to be added.

              System.Boolean ContainsPointAttrs ( System.String attrId ) ;
              Returns whether point attributes named attrId are present.

              • attrId
                ID of point attributes.

              Returns:
              True if point attributes named attrId are present, otherwise false.

              virtual Zcu.Mve.Visualization.UnstrGrid ShallowCopy ( ) ;
              Returns a shallow copy of the Unstructured Grid. Useful when adding some attributes to an UnstrGrid you have received as an input when you want to keep all the existing ones.

                Returns:
                A shallow copy of the original - has all the points, cells and attributes of the original, but no copying is actually performed.

                virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
                Creates deep copy of current data structure (same data, different memory space). Handle with care, UnstrGrid is ment to be large.

                  Returns:
                  Deep copy of current data structure.

                  virtual Zcu.Mve.Visualization.UniformDataArray GetCells ( System.String cellId ) ;
                  Returns cell array with given ID.

                  • cellId
                    Unique (in curent UnstrGrid) ID of cell array.

                  Returns:
                  Cell array.

                  System.Void RemovePointAttrs ( System.String attrId ) ;
                  Remove array of point attributes. If do not exists throws an MveException.

                  • attrId
                    id of array to be removed

                  Public properties

                  Zcu.Mve.Visualization.AbstractTransform Transform { get;set; }
                  Get/Set transform of curent object.

                  virtual Zcu.Mve.Visualization.UniformDataArray Points { get;set; }
                  Get/Set an uniform array of points. Array have to be filled by childrens of Zcu.Mve.Visualization.Point.

                  Zcu.Mve.Visualization.BoundingBox BoundingBox { get; }
                  Returns Min-Max box.

                  virtual System.String[] LibNames { get; }
                  Returns list of assembly names where can be found containg data types.


Zcu.Mve.Visualization.StructGrid

Index | Overview | Members

Base class for all strucutured datatypes.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.DataSet
Zcu.Mve.Visualization.StructGrid

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.StructGrid

Index | Overview | Members

Constructors

StructGrid ( )
Implicit constructor.


Zcu.Mve.Visualization.Grid2D

Index | Overview | Members

Two dimensional structured grid. Contains two tables:

  • table of cell (pixel) attributes with height x width resolution 2D uniform arrays.
  • table of point ("pixel vertices") attributes with height+1 x width+1 resolution 2D uniform arrays.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.DataSet
Zcu.Mve.Visualization.StructGrid
Zcu.Mve.Visualization.Grid2D

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.Grid2D

Index | Overview | Members

Constructors

Grid2D ( )
For XmlLoader use only. Use parametric constructor instead.

    Grid2D ( System.Int32 height, System.Int32 width )
    Constructor - creates empty grid of given resolution

    • height
      Number of pixels in vertical direction.
    • width
      Number of pixels in horizontal direction.

    Public methods

    virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
    Read data from Xml file to current structure.
    • xmlTextReader
      Stream to be read.

    System.Void AddCellAttrs ( System.String attrid, Zcu.Mve.Visualization.UniformDataArray2D attrs ) ;
    Add cell (pixel) attributes. Array dimensions have to agree with Grid2D dimensions.

    • attrid
      Localy unique ID. Name of attribute type is recommended as default value.
    • attrs
      2D array of attributes.

    System.Collections.ICollection GetPointAttrIds ( ) ;
    Returns collection of point attribute ids.

      Returns:
      Collection of point attribute ids.

      Zcu.Mve.Visualization.UniformDataArray2D GetCellAttrs ( System.String attrid ) ;
      Return 2D-array of pixel attributes.

      • attrid
        Localy unique ID. Name of attribute type is recommended as default value.

      Returns:
      2D-array of pixel attributes.

      virtual System.Boolean CheckConsistence ( ) ;
      Check the consistency of current data structure.

        Returns:
        True if structure is consistent.

        virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
        Deep copy of data object and its subelements.

          Returns:
          Same data, different memory space.

          abstract virtual Zcu.Mve.Visualization.Point2D GetPoint ( System.Int32 i, System.Int32 j ) ;
          Returns point in i, j position. Point coordinates are given implicitly. Thus no points are stored in Grid2D data object. Point object is created and coordinates are calculated in implementation of getPoint function.

          • i
            Height index
          • j
            Width index

          Returns:
          Particular point

          System.Collections.ICollection GetCellAttrIds ( ) ;
          Returns collection of cell attribute ids.

            Returns:
            Collection of cell attribute ids.

            virtual System.String ToString ( ) ;
            Returns a String that represents the current Object.

              Returns:
              String that represents the current Object.

              System.Void AddPointAttrs ( System.String attrid, Zcu.Mve.Visualization.UniformDataArray2D attrs ) ;
              Add point attributes. Array dimensions have to agree with Grid2D dimensions.

              • attrid
                Localy unique ID. Name of attribute type is recommended as default value.
              • attrs
                2D array of attributes.

              virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
              Writes width, height, point attrs and cell attrs.

              • xmlTextWriter
                Stream to be write.

              Zcu.Mve.Visualization.UniformDataArray2D GetPointAttrs ( System.String attrid ) ;
              Return 2D-array of point attributes.

              • attrid
                Localy unique ID. Name of attribute type is recommended as default value.

              Returns:
              2D-array of point attributes.

              Public properties

              System.Int32 Width { get; }
              Returns horizontal pixel-resolution of Grid.

              System.Int32 Height { get; }
              Returns vertical pixel-resolution of Grid.

              Protected methods

              System.Void WriteCellAttrs ( System.Xml.XmlTextWriter xmlTextWriter ) ;
              Write all cell attributes into XML file.
              • xmlTextWriter
                Stream to be write.

              System.Void ReadHeader ( System.Xml.XmlTextReader xmlTextReader ) ;
              Reads width and height attributes.

              • xmlTextReader
                Stream to be read.

              System.Void WriteHeader ( System.Xml.XmlTextWriter xmlTextWriter ) ;
              Writes resolution of grid into XML file.

              • xmlTextWriter
                Stream to be write.

              System.Void WritePointAttrs ( System.Xml.XmlTextWriter xmlTextWriter ) ;
              Write all point attributes into XML file.

              • xmlTextWriter
                Stream to be write.

              System.Void ReadXmlNode ( System.Xml.XmlTextReader xmlTextReader ) ;
              Reads pointattrs and cellattrs nodes.

              • xmlTextReader
                Stream to be read.


Zcu.Mve.Visualization.RectilinearGrid2D

Index | Overview | Members

This class represents a structured, semiregular, 2-dimensional grid.
It means that topology is given implicitly and geometry is given by two arrays of scalar values.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.DataSet
Zcu.Mve.Visualization.StructGrid
Zcu.Mve.Visualization.Grid2D
Zcu.Mve.Visualization.RectilinearGrid2D

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.RectilinearGrid2D

Index | Overview | Members

Constructors

RectilinearGrid2D ( )
Creates an epmty object (Used by XmlLoader, otherwise useless).

    RectilinearGrid2D ( System.Double[] arrayHeight, System.Double[] arrayWidth )
    Constructor - creates empty grid.

    • arrayHeight
      Field represents y-coordinates of points.
    • arrayWidth
      Field represents x-coordinates of points.

    Public methods

    virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
    Method reads data from Xml file to structures of data object.
    • xmlTextReader
      Data stream to be read.

    virtual System.Boolean CheckConsistence ( ) ;
    Check the consistency of current data structure.

      Returns:
      True if structure is consistent.

      virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
      Deep copy of data object and its subelements.

        Returns:
        Same data, different memory space.

        virtual Zcu.Mve.Visualization.Point2D GetPoint ( System.Int32 i, System.Int32 j ) ;
        Returns x, y coordinates of point with i, j indices.

        • i
          Row index of point.
        • j
          Column index of point.

        Returns:
        New instance of point.

        virtual System.String ToString ( ) ;
        Returns a String that represents the current Object.

          Returns:
          String that represents the current Object.

          virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
          Method write content of this structure into Xml file.

          • xmlTextWriter
            Data stream to write.

          Public properties

          System.Double[] ArrayHeight { get; }
          Returns reference to internal array.

          System.Double[] ArrayWidth { get; }
          Returns reference to internal array.

          Protected methods

          System.Void ReadNode ( System.Xml.XmlTextReader xmlTextReader ) ;
          Reads pointattrs and cellattrs nodes.
          • xmlTextReader
            Data stream to be read.

          System.Void WriteArrays ( System.Xml.XmlTextWriter xmlTextWriter ) ;
          Write arrays of x and y coordinates.

          • xmlTextWriter
            Data stream to write.


Zcu.Mve.Visualization.GridND

Index | Overview | Members

N-dimensional structured grid. Contains two tables:

  • table of cell (element) attributes with height x width resolution ND uniform arrays.
  • table of point (element vertices) attributes with height+1 x width+1 resolution ND uniform arrays.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.DataSet
Zcu.Mve.Visualization.StructGrid
Zcu.Mve.Visualization.GridND

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.GridND

Index | Overview | Members

Constructors

GridND ( params System.Int32[] dimensions )
Constructor - creates empty grid of given resolution
  • dimensions
    Dimensions of the grid to be created. You can pass either an array of integers, or a number of integer parameters. Created grid has given number of cells, i.e. number of vertices in each direction is higher by one!

GridND ( )
For XmlLoader use only. Use parametric constructor instead.

    Public methods

    System.Void AddCellAttrs ( System.String attrid, Zcu.Mve.Visualization.MveArray attrs ) ;
    Add cell attributes. Array dimensions have to agree with GridND dimensions.
    • attrid
      Localy unique ID. Name of attribute type is recommended as default value.
    • attrs
      ND array of attributes.

    virtual System.Boolean CheckConsistence ( ) ;
    checks the consistence of the grid.

      Returns:
      Always returns true.

      virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
      Reads data for the GridND form an XML reader.

      • xmlTextReader
        XmlTextReader to read the data from

      System.Collections.ICollection GetCellAttrIds ( ) ;
      Returns collection of cell attribute ids.

        virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
        Writes dimensions, point attrs and cell attrs.

        • xmlTextWriter

        virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
        Creates new instance of GridND ...

          virtual System.String ToString ( ) ;
          Transforms the contents of the GridND into a string

            Returns:
            String representation. Contains pixel values and attributa names

            Zcu.Mve.Visualization.MveArray GetCellAttrs ( System.String attrid ) ;
            Return ND-array of pixel attributes.

            • attrid

            System.Void AddPointAttrs ( System.String attrid, Zcu.Mve.Visualization.MveArray attrs ) ;
            Add point attributes. Array dimensions have to agree with GridND dimensions.

            • attrid
              Localy unique ID. Name of attribute type is recommended as default value.
            • attrs
              ND array of attributes.

            Zcu.Mve.Visualization.MveArray GetPointAttrs ( System.String attrid ) ;
            Return ND-array of point attributes.

            • attrid

            System.Collections.ICollection GetPointAttrIds ( ) ;
            Returns collection of point attribute ids.

              abstract virtual Zcu.Mve.Visualization.PointND GetPoint ( params System.Int32[] coordinates ) ;
              Returns point in given position. Point coordinates are given implicitly. Thus no points are stored in GridND data object. Point object is created and coordinates are calculated in implementation of getPoint function.

              • coordinates
                Array of coordinates, dimension must be equal to the dimension of the GridND.

              Returns:
              Particular point

              System.Void RemoveCellAttrs ( System.String attrid ) ;
              Removes attribute associated with cells of the RegGrid. Throws MveException if the attribute of the given name does not exist.

              • attrid
                String identifier of the attribute to be removed.

              System.Void RemovePointAttrs ( System.String attrid ) ;
              Removes attribute associated with points of the RegGrid. Throws MveException if the attribute of the given name does not exist.

              • attrid
                String identifier of the attribute to be removed.

              Public properties

              System.Int32[] Dimensions { get; }
              Returns array containing grid dimensions (i.e. number of cells in each dimension)

              Protected methods

              System.Void WriteCellAttrs ( System.Xml.XmlTextWriter xmlTextWriter ) ;
              • xmlTextWriter

              System.Void ReadNode ( System.Xml.XmlTextReader xmlTextReader ) ;
              Reads pointattrs and cellattrs nodes.

              • xmlTextReader

              System.Void ReadHeader ( System.Xml.XmlTextReader xmlTextReader ) ;
              Reads width and height attributes

              • xmlTextReader

              System.Void WriteHeader ( System.Xml.XmlTextWriter xmlTextWriter ) ;
              Writes resolution of grid.

              • xmlTextWriter

              System.Void WritePointAttrs ( System.Xml.XmlTextWriter xmlTextWriter ) ;
              Write all point attributes into XML file.

              • xmlTextWriter


Zcu.Mve.Visualization.INormal

Index | Overview | Members

Represent a normal vector.

Inheritance:

Zcu.Mve.Visualization.INormal

Implements:

Zcu.Mve.Visualization.IAttribute
Zcu.Mve.Core.IDataObject
Zcu.Mve.Numerics.IVector


Zcu.Mve.Visualization.INormal

Index | Overview | Members


Zcu.Mve.Visualization.IColorVector

Index | Overview | Members

Interface that represents a color vector.

Inheritance:

Zcu.Mve.Visualization.IColorVector

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.IColorVector

Index | Overview | Members

Public properties

abstract virtual System.Int32 Length { get; }
Get number of elements of vector.

abstract virtual System.Byte Item { get;set; }
Get/Set element of vector.


Zcu.Mve.Visualization.ColorIntensity

Index | Overview | Members

Datastructure represents color in Grayscale. Internally it uses byte for the intensity componnent.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Visualization.ColorIntensity

Implements:

Zcu.Mve.Visualization.IAttribute
Zcu.Mve.Core.IDataObject
Zcu.Mve.Visualization.IColorVector


Zcu.Mve.Visualization.ColorIntensity

Index | Overview | Members

Constructors

ColorIntensity ( System.Single intensity )
Constructor creates an instance of ColorGray.
  • intensity
    Float intensity clamped to (0.0,1.0), converted to byte.

ColorIntensity ( System.Byte intensity )
Constructor creates an instance of ColorGray.

  • intensity
    Byte intensity

ColorIntensity ( System.Double intensity )
Constructor creates an instance of ColorGray.

  • intensity
    Double intensity clamped to (0.0,1.0), converted to byte.

Public methods

virtual System.Boolean Equals ( System.Object obj ) ;
Determines whether the specified Object is equal to the current Object.
  • obj
    Specified Object to compare with the current Object.

Returns:
True if the specified Object is equal to the current Object. Otherwise, false.

final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
Method read data from Xml file to structures of this data object.

  • xmlTextReader
    Xml stream to read.

final virtual System.Boolean CheckConsistence ( ) ;
Check the consistency of current data structure.

    Returns:
    True if structure is consistent.

    final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
    Deep copy of data object and its subelements.

      Returns:
      Same data, different memory space.

      virtual System.Int32 GetHashCode ( ) ;
      Returns a hash code for the current Object.

        Returns:
        A hash code for the current Object.

        static System.Boolean Equals ( System.Object a, System.Object b ) ;
        Determines whether the specified Objects are equal.

        • a
          First Object.
        • b
          Second Object.

        Returns:
        True if objects are equal. Otherwise, false.

        virtual System.String ToString ( ) ;
        Returns a String that represents the current Object.

          Returns:
          String that represents the current Object.

          final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
          Method write data from structures of this data object to Xml file.

          • xmlTextWriter
            Xml stream to write.

          Public properties

          final virtual System.Int32 Length { get; }
          Get number of elements of vector.

          System.Double IntensityD { get;set; }
          Gets or sets the intensity from double.

          final virtual System.Byte Item { get;set; }
          Get/Set element of color vector.

          final virtual System.String[] LibNames { get; }
          Returns array of assembly name.

          System.Single IntensityF { get;set; }
          Gets or sets the intensity from float.

          System.Byte Intensity { get;set; }
          Gets/sets intensity.


Zcu.Mve.Visualization.MveArray

Index | Overview | Members

Static multidimensional homogenous data array.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.MveArray

Implements:

Zcu.Mve.Core.IDataObject
System.Collections.IEnumerable


Zcu.Mve.Visualization.MveArray

Index | Overview | Members

Constructors

MveArray ( System.Type type, params System.Int32[] lenghts )
Creates abstract array of specified type
  • type
    Type of object (only this type is accepted). Must be inherited from Mve.Core.DataObject
  • lenghts
    An array of 32-bit integers that represent the size of each dimension of the Array to create.

MveArray ( )
For XmlLoader use only. Use parametric constructor instead.

    Public methods

    virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
    Read data from Xml file to current structure.
    • xmlTextReader
      Stream to be read.

    virtual System.Boolean CheckConsistence ( ) ;
    Check the consistency of current data structure. Can (and should) write remarks on Console and/or Debug or Trace console.

      Returns:
      true if structure is consistent

      virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
      Deep copy of data object and its subelements.

        Returns:
        same data, different memmory space.

        final virtual System.Collections.IEnumerator GetEnumerator ( ) ;
        Get array enumerator.

          Returns:
          Array enumerator.

          System.Int32 IndexOf ( Zcu.Mve.Core.IDataObject o ) ;
          Finds an element in the array and returns its index

          • o
            element to be found

          Returns:
          index of the given element, or -1 if not found.

          virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
          Write current data to Xml file.

          • xmlTextWriter
            Stream to be read.

          Public properties

          System.Array Array { get; }
          Returns the reference to array.

          Zcu.Mve.Core.IDataObject Item { get;set; }
          Get/Set element of array. ElemetnSetEvent is called and SetValue can be forbidden.

          System.Type ElemType { get; }
          Returns type accepted by curent array.

          System.Int32 Rank { get; }
          Gets the number of dimensions of array.

          System.Int32[] Lengths { get; }
          Returns size in all dimensions.

          Public events

          Zcu.Mve.Visualization.MveArray+ElementSetCallBack OnElementSetEvent;
          Called when an object is assigned to specified index in array

          Protected methods

          System.Boolean InvokeElementSetEvent ( System.Object element, params System.Int32[] indices ) ;
          Called before an object is assigned to specified index in array. This operation can be canceled via return value.
          • indices
            Index of element
          • element
            value to be assigned to the index position

          Returns:
          true - when element assignement is allowed
          false - when element assignement is not allowed

          Protected properties

          System.Type Type { get;set; }
          Get/Set type of elemnt. For XmlLoader use only.

          Protected fields

          System.Array array
          Array of data objects.


Zcu.Mve.Visualization.UniformDataArray

Index | Overview | Members

Homogenous one dimensional array of IDataObjects.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.MveArray
Zcu.Mve.Visualization.UniformDataArray

Implements:

Zcu.Mve.Core.IDataObject
System.Collections.IEnumerable


Zcu.Mve.Visualization.UniformDataArray

Index | Overview | Members

Constructors

UniformDataArray ( )
For XmlLoader use only. Use parametric construcotr instead.

    UniformDataArray ( System.Type type, System.Int32 count )
    Creates fixed size, one dimensional array of DataObjects

    • type
      Type of object (only this type is accepted). Must be inherited from Mve.Core.DataObject
    • count
      Number of array elements

    Public methods

    static Zcu.Mve.Visualization.UniformDataArray FromDictionaryKeys<TDataType,TValueType> ( System.Collections.Generic.Dictionary`2<TDataType,TValueType> l ) where TDataType : Zcu.Mve.Core.IDataObject;
    Creates a uniform data array from the keys of a dictionary
    • l

    static Zcu.Mve.Visualization.UniformDataArray FromArray<TDataType> ( Zcu.Mve.Visualization.TDataType[]<TDataType> array ) where TDataType : Zcu.Mve.Core.IDataObject;

      static Zcu.Mve.Visualization.UniformDataArray FromArrayList ( System.Type type, System.Collections.ArrayList list ) ;
      Creates UniformDataArray from ArrayList. Elements are not copied. Reference only is passed to the new array.

      • type
        Type of uniform data array.
      • list
        List to be converted (copied).

      Returns:
      New instance of UniformDataArray.

      static Zcu.Mve.Visualization.UniformDataArray FromList<TDataType> ( System.Collections.Generic.List`1<TDataType> l ) where TDataType : Zcu.Mve.Core.IDataObject;
      Creates a uniform data array from a list of IDataObject instances

      • l
        List to use for creating the new UniformDataArray.

      Public properties

      System.Int32 Count { get; }
      Number of elements.


Zcu.Mve.Visualization.UnstrGridEigCell

Index | Overview | Members

Specialization of UnstrGrid. It contains a hash table that represents a set of available cell types. For more details see Mesh class.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.DataSet
Zcu.Mve.Visualization.UnstrGrid
Zcu.Mve.Visualization.UnstrGridEigCell

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.UnstrGridEigCell

Index | Overview | Members

Constructors

UnstrGridEigCell ( )
Implicit constructor.

    Public methods

    virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
    Creates deep copy of current UnstrGridEigCell (i.e. Mesh, TriangleMesh...).

      Returns:
      Deep copy of current UnstrGridEigCell (same data, different memory space).

      virtual System.Void AddCells ( System.String cellId, Zcu.Mve.Visualization.UniformDataArray cells ) ;
      Method add cell array and check whether type of cells is in eigCells array.

      • cellId
        ID of the cell.
      • cells
        Uniform data array of cells.

      Protected fields

      System.Collections.Hashtable eigCells
      Contains System.Type as keys. It represents type of cells allowed for current UnstrGrid (i.e. Mesh, StripMesh, TriangleMesh...).


Zcu.Mve.Visualization.Mesh

Index | Overview | Members

Specialization of UnstrGrid. Can contain only Triangle, TriangleStrip, TriangleFan, Line, PolyLine cells, Polygon. Attributes are not limited.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.DataSet
Zcu.Mve.Visualization.UnstrGrid
Zcu.Mve.Visualization.UnstrGridEigCell
Zcu.Mve.Visualization.Mesh

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.Mesh

Index | Overview | Members

Constructors

Mesh ( )
Creates emtpy mesh. Eigen cells are: Triangle, TriangleStrip, TriangleFan, Line, PolyLine, Polygon.

    Public methods

    virtual Zcu.Mve.Visualization.UnstrGrid ShallowCopy ( ) ;
    Creates shallow copy of current mesh. Only array references are coppied.

      Returns:
      Shallow copy of current mesh.


Zcu.Mve.Visualization.TriangleStripMesh

Index | Overview | Members

Specialization of Mesh. Can contain only TriangleStrip cells. Attributes are not limited.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.DataSet
Zcu.Mve.Visualization.UnstrGrid
Zcu.Mve.Visualization.UnstrGridEigCell
Zcu.Mve.Visualization.Mesh
Zcu.Mve.Visualization.TriangleStripMesh

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.TriangleStripMesh

Index | Overview | Members

Constructors

TriangleStripMesh ( )
Create empty StripMesh. Eigen cell is TriangleStrip only.

    Public methods

    System.Int32 GetNTriangleStrips ( ) ;
    Returns number of triangle strips. (Number of elements in field named "TriangleStrip")

      Returns:
      Number of TriangleStrips.

      Zcu.Mve.Visualization.TriangleStrip GetTriangleStrip ( System.Int32 index ) ;
      Returns TrinagleStrip from array named "TriangleStrip".

      • index
        Index of the TriangleStrip.

      Returns:
      TriangleStrip with given index.


Zcu.Mve.Visualization.ICell

Index | Overview | Members

Represets a topological information.
Triangle, Line, Tetrahedron are its typical examples.
Only instaces of this type are accepted by UnstrGrid as topological information.

Inheritance:

Zcu.Mve.Visualization.ICell

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.ICell

Index | Overview | Members

Public properties

abstract virtual System.Int32 Item { get;set; }
Access to point indices.

abstract virtual System.Int32 PointCount { get; }
Number of point indices.


Zcu.Mve.Visualization.Polygon

Index | Overview | Members

Represent closed Polygon defined by array of point indices.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Visualization.Polygon

Implements:

Zcu.Mve.Visualization.ICell
Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.Polygon

Index | Overview | Members

Constructors

Polygon ( params System.Int32[] points )
Creates a Polygon object.
  • points
    Points indices.

Public methods

final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
Method load data from Xml file to structures of curent data object.
  • xmlTextReader
    XML stram to read

final virtual System.Boolean CheckConsistence ( ) ;
Check the consistency of current data structure. Returns false if some index is negative.

    Returns:
    True if structure is consistent.

    final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
    Deep copy of data object and its subelements.

      Returns:
      same data, different memmory space.

      System.Int32 GetPoint ( System.Int32 index ) ;
      Returns the point (its index in the DataSet) according to index in the Polygon (0, 1, 2, ...).

      • index
        Index of the point in the Polygon.

      Returns:
      Index of the point in the DataSet.

      virtual System.String ToString ( ) ;
      Returns a String that represents the current Object.

        Returns:
        String that represents the current Object.

        final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
        Method write data to Xml file.

        • xmlTextWriter
          Data stream to write.

        Public properties

        final virtual System.String[] LibNames { get; }
        Returns array of assembly name.

        final virtual System.Int32 PointCount { get; }
        Get the count of polygon points.

        final virtual System.Int32 Item { get;set; }
        Get/set the concrete vertex of polygon. First vertex has the index 0.


Zcu.Mve.Visualization.NormalND

Index | Overview | Members

Represents a n-dimensional normal defined by N elements.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Visualization.NormalND

Implements:

Zcu.Mve.Visualization.INormal
Zcu.Mve.Visualization.IAttribute
Zcu.Mve.Core.IDataObject
Zcu.Mve.Numerics.IVector


Zcu.Mve.Visualization.NormalND

Index | Overview | Members

Constructors

NormalND ( params System.Double[] values )
Create a NormalND object.
  • values
    n-dimensional array of vector values.

Public methods

final virtual System.Double Abs ( ) ;
Returns the absolute value of normal.

    Returns:
    The absolute value of normal.

    final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
    Read data from Xml file to current structure.

    • xmlTextReader
      Stream to be read.

    static System.Double AbsValue ( params System.Double[] values ) ;
    Computes absolute value of general n-dimensional vector of double values.

    • values
      n-dimensional vector of double values.

    Returns:
    Absolute value of the n-dimensional vector.

    static System.Boolean Equals ( System.Object a, System.Object b ) ;
    Determines whether the specified Objects are equal.

    • a
      First Object.
    • b
      Second Object.

    Returns:
    True if objects are equal. Otherwise, false.

    final virtual System.Boolean CheckConsistence ( ) ;
    Check the consistency of current data structure.

      Returns:
      True if structure is consistent.

      final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
      Deep copy of data object and its subelements.

        Returns:
        Same data, different memory space.

        virtual System.Boolean Equals ( System.Object obj ) ;
        Determines whether the specified Object is equal to the current Object.

        • obj
          Specified Object to compare with the current Object.

        Returns:
        True if the specified Object is equal to the current Object. Otherwise, false.

        virtual System.Int32 GetHashCode ( ) ;
        Returns a hash code for the current Object.

          Returns:
          A hash code for the current Object.

          System.Void Normalize ( ) ;
          Method check whether absolute value equals 1 (+- NormalND.EPSILON). If no, normal is normalized.

            virtual System.String ToString ( ) ;
            Returns a String that represents the current Object.

              Returns:
              String that represents the current Object.

              final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
              Write current data to Xml file.

              • xmlTextWriter
                Stream to be write.

              Public properties

              final virtual System.Int32 Length { get; }
              Get dimension of normal.

              final virtual System.String[] LibNames { get; }
              Returns array of assembly name.

              final virtual System.Double Item { get;set; }
              Get/Set element of normal.

              System.Double[] Values { get; }
              Get the n-dimensional array of normal elements. For acces to concrete normal elements use indexer.

              Public fields

              static System.Double EPSILON
              Constant for The toleration for CheckConsistence() method. The normal is consistent when its absolute value lies inside the interval: 1 - (EPSILON / 2) ... 1 + (EPSILON / 2)

              static System.Double Epsilon
              The toleration for equality operator.


Zcu.Mve.Visualization.UniformDataArray2D

Index | Overview | Members

This class represents two dimensional static array of one specific DataObject.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.MveArray
Zcu.Mve.Visualization.UniformDataArray2D

Implements:

Zcu.Mve.Core.IDataObject
System.Collections.IEnumerable


Zcu.Mve.Visualization.UniformDataArray2D

Index | Overview | Members

Constructors

UniformDataArray2D ( )
For XmlLoader use only. Use parametric constructor instead.

    UniformDataArray2D ( System.Type type, System.Int32 height, System.Int32 width )
    Creates empty 2D array of given type.

    • height
      Number of lines
    • width
      Number of columns
    • type
      The only accepted type

    Public properties

    System.Int32 Width { get; }
    Returns width of curent data array.

    System.Int32 Height { get; }
    Returns height of curent data array.


Zcu.Mve.Visualization.SliceSet

Index | Overview | Members

Specialization of UnstrGrid. Class represents set of slices. Only Slice can be a topological element.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.DataSet
Zcu.Mve.Visualization.UnstrGrid
Zcu.Mve.Visualization.UnstrGridEigCell
Zcu.Mve.Visualization.SliceSet

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.SliceSet

Index | Overview | Members

Constructors

SliceSet ( )
Create empty SliceSet. Only Slice can be a topological element.


Zcu.Mve.Visualization.Line

Index | Overview | Members

Simple line between two points.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Visualization.Line

Implements:

Zcu.Mve.Visualization.ICell
Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.Line

Index | Overview | Members

Constructors

Line ( System.Int32 V1, System.Int32 V2 )
Simple parametric constructor.
  • V1
    Index of first vertex.
  • V2
    Index of second vertex.

Line ( System.Int32 V1, System.Int32 V2, System.Boolean oriented )
Simple parametric constructor.

  • V1
    Index of first vertex.
  • V2
    Index of second vertex.
  • oriented
    Defines whether line is oriented or not. Unoriented lines always lead from lower index towards higher index

Public methods

virtual System.Boolean Equals ( System.Object obj ) ;
Equality check. Lines are equal when vertices are equal, vertex order must be kept (Different orientation results in false).
  • obj
    target to be compared

Returns:
true when equal, false otherwise

final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
Read data from XML file.

  • xmlTextReader
    Stream to be read.

final virtual System.Boolean CheckConsistence ( ) ;
Line with negative index is considered inconsistent. If two identical indices are detected warning is given.

    Returns:
    True if the Line is consistent.

    final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
    Deep copy of curent object

      Returns:
      Deep copy (same data, different memory place)

      System.Int32 GetPoint ( System.Int32 index ) ;
      Returns index of vertex.

      • index
        0 or 1 are only acceptable vaules.

      Returns:
      Index of vertex

      virtual System.Int32 GetHashCode ( ) ;
      Hash code generator, uses XOR of vertex indices.

        Returns:
        XOR of vertex indices.

        virtual System.String ToString ( ) ;
        Line information

          Returns:
          String that contain name of this object and indices of curent object.

          final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
          Write data to XML file.

          • xmlTextWriter
            Stream to be write.

          Public properties

          final virtual System.String[] LibNames { get; }
          Returns array of used assembly names.

          final virtual System.Int32 PointCount { get; }
          Return number of points of cell.

          final virtual System.Int32 Item { get;set; }
          Get/Set index of line vertex

          System.Int32[] Points { get; }
          Returns array of two vertices of the line. Change of returned array do not cause change inside line object.

          Public fields

          System.Int32 V1
          Index of first vertex of line.

          System.Int32 V2
          Index of second vertex of line.


Zcu.Mve.Visualization.Triangle

Index | Overview | Members

Specialization of Mesh. Can contain only TriangleStrip cells. Attributes are not limited.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Visualization.Triangle

Implements:

Zcu.Mve.Visualization.ICell
Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.Triangle

Index | Overview | Members

Constructors

Triangle ( System.Int32 V1, System.Int32 V2, System.Int32 V3 )
Create a Triangle object.
  • V1
    Index of first vertex of the triangle.
  • V2
    Index of second vertex of the triangle.
  • V3
    Index of third vertex of the triangle.

Public methods

virtual System.Boolean Equals ( System.Object obj ) ;
Determines equality of triangles based on vertex indexing. Differently oriented triangles are considered equal
  • obj
    Target to be compared to. Instance of Triangle class or it's descendant is expected, other data types result in false value.

Returns:
true if vertices have same indexes (different order possible), false otherwise

final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
Read data from XML file.

  • xmlTextReader
    Stream to be read.

final virtual System.Boolean CheckConsistence ( ) ;
Triangle with negative index is considered inconsistent. If two or three identical indices are detected warning is given.

    Returns:
    True if the Triangle is consistent.

    final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
    Deep copy of curent object

      Returns:
      Deep copy (same data, different memory place).

      System.Int32 GetPoint ( System.Int32 index ) ;
      Returns index of vertex.

      • index
        0, 1, 2 are only acceptable vaules.

      Returns:
      Index of vertex.

      virtual System.Int32 GetHashCode ( ) ;
      Hash code generator, uses XOR of triangle vertices to obtain integer value.

        Returns:
        Generated hashcode

        virtual System.String ToString ( ) ;
        Triangle information

          Returns:
          String that contain name of this object and indices of curent object.

          final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
          Write data to XML file.

          • xmlTextWriter
            Stream to be write.

          Public properties

          final virtual System.String[] LibNames { get; }
          Returns array of assembly name.

          final virtual System.Int32 PointCount { get; }
          Return number of points of cell.

          final virtual System.Int32 Item { get;set; }
          Get/Set index of Triangle vertex

          System.Int32[] Points { get; }
          Returns array of three vertices of the triangle. Change of returned array do not cause change inside line object.

          Public fields

          System.Int32 V1
          Index of first vertex of the triangle.

          System.Int32 V3
          Index of third vertex of the triangle.

          System.Int32 V2
          Index of second vertex of the triangle.


Zcu.Mve.Visualization.TriangleNeighbor

Index | Overview | Members

This structure represents Triangle neighbors.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Visualization.TriangleNeighbor

Implements:

Zcu.Mve.Visualization.INeighbor
Zcu.Mve.Visualization.IAttribute
Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.TriangleNeighbor

Index | Overview | Members

Constructors

TriangleNeighbor ( System.Int32 t1, System.Int32 t2, System.Int32 t3, System.Int32 count )
Creates an object with values .
  • t1
    Index of neighbor.
  • t2
    Index of neighbor.
  • t3
    Index of neighbor.
  • count
    Number of neighbors.

TriangleNeighbor ( System.Int32 t1, System.Int32 t2, System.Int32 t3 )
Creates an object with values.

  • t1
    Index of neighbor.
  • t2
    Index of neighbor.
  • t3
    Index of neighbor.

Public methods

final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
Write current data to Xml file.
  • xmlTextWriter
    Stream to be write.

final virtual System.Boolean CheckConsistence ( ) ;
Check the consistency of current data structure.

    Returns:
    True if structure is consistent.

    final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
    Read data from Xml file to current structure.

    • xmlTextReader
      Stream to be read.

    final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
    Deep copy of data object and its subelements.

      Returns:
      Same data, different memory space.

      virtual System.String ToString ( ) ;
      Returns a String that represents the current Object.

        Returns:
        String that represents the current Object.

        Public properties

        final virtual System.String[] LibNames { get; }
        Returns array of assembly name.

        System.Int32 Item { get;set; }
        TriangleNeighbor indexer.

        System.Int32 Count { get; }
        Number of neighbors. The neighbor cannot have negative value.

        Public fields

        System.Int32[] Neighbors
        Indices to three neighboring triangles.


Zcu.Mve.Visualization.IPoint

Index | Overview | Members

Represents any geometric information.
Point2D and Point3D are its typical subclasses.
Only this type is accepted by UnstrGrid as geometric information.

Inheritance:

Zcu.Mve.Visualization.IPoint

Implements:

Zcu.Mve.Numerics.IVector
Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.IPoint

Index | Overview | Members


Zcu.Mve.Visualization.PointND

Index | Overview | Members

Represents a n-dimensional point defined by N coordinates.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Visualization.PointND

Implements:

Zcu.Mve.Visualization.IPoint
Zcu.Mve.Numerics.IVector
Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.PointND

Index | Overview | Members

Constructors

PointND ( System.Int32 dimension )
Creates new instance of PointND of given dimension
  • dimension
    Dimension of PointND.

PointND ( params System.Double[] values )
Create a PoinND object.

  • values
    n-dimensional array of vector values.

Public methods

final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
Deep copy of data object and its subelements.

    Returns:
    Same data, different memory space.

    final virtual System.Boolean CheckConsistence ( ) ;
    Check the consistency of current data structure.

      Returns:
      True if structure is consistent.

      static Zcu.Mve.Visualization.PointND ChangeDimension ( Zcu.Mve.Visualization.IPoint point, System.Int32 newDim ) ;
      Creates new instance of PointND of given dimension and copies content of given point.

      • point
        Point to be copied
      • newDim
        Dimension of new point

      final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
      Read data from Xml file to current structure.

      • xmlTextReader
        Stream to be read.

      final virtual System.Double Abs ( ) ;
      Returns the distance of point and coordinate origin.

        Returns:
        The distance of point from and coordinate origin.

        final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
        Write current data to Xml file.

        • xmlTextWriter
          Stream to be write.

        Zcu.Mve.Numerics.Scalar dotProduct ( Zcu.Mve.Visualization.PointND p ) ;
        Dot product of two PointNDs

        • p
          secornd argument

        Returns:
        Scalar value of the dot product

        virtual System.String ToString ( ) ;
        Returns a String that represents the current Object.

          Returns:
          String that represents the current Object.

          static Zcu.Mve.Visualization.PointND crossProduct4 ( Zcu.Mve.Visualization.PointND a, Zcu.Mve.Visualization.PointND b, Zcu.Mve.Visualization.PointND c ) ;
          Computes a ternary, i.e. four-dimensional cross-product of three points.

          • a
            first argument, must be at least four-dimensional
          • b
            first argument, must be at least four-dimensional
          • c
            first argument, must be at least four-dimensional

          Returns:
          cross product axbxc

          System.Void Normalize ( ) ;
          Puts the point into unit distance from the origin.

            static Zcu.Mve.Numerics.Scalar dotProduct ( Zcu.Mve.Visualization.PointND p1, Zcu.Mve.Visualization.PointND p2 ) ;
            dot product of two PointNDs

            • p1
              first argument
            • p2
              secornd argument

            Returns:
            dot product as Scalar

            virtual System.Int32 GetHashCode ( ) ;
            Returns a hash code for the current Object.

              Returns:
              A hash code for the current Object.

              static System.Boolean Equals ( System.Object a, System.Object b ) ;
              Determines whether the specified Objects are equal.

              • a
                First Object.
              • b
                Second Object.

              Returns:
              True if objects are equal. Otherwise, false.

              System.Double Size ( ) ;
              Computes Euclidean size of the vector between the origin and the point

                Returns:
                Euclidean size of the vector between the origin and the point

                virtual System.Boolean Equals ( System.Object obj ) ;
                Determines whether the specified Object is equal to the current Object.

                • obj
                  Specified Object to compare with the current Object.

                Returns:
                True if the specified Object is equal to the current Object. Otherwise, false.

                Public properties

                final virtual System.Int32 Length { get; }
                Get dimension of point.

                final virtual System.String[] LibNames { get; }
                Returns array of assembly name.

                final virtual System.Double Item { get;set; }
                Get/Set element of point.

                System.Double[] Values { get; }
                Get the n-dimensional array of point coordinates. For acces to concrete point coordinates use indexer.

                Public fields

                static System.Double Epsilon
                The toleration for equality operator.


Zcu.Mve.Visualization.IGridCell

Index | Overview | Members

Interface for grid topological elemnts (Pixel, Voxel, GridCellND, ...).

Inheritance:

Zcu.Mve.Visualization.IGridCell

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.IGridCell

Index | Overview | Members


Zcu.Mve.Visualization.Pixel

Index | Overview | Members

This structure represents a Pixel - elementary element of Grid. Pixel determinates the topological information. Pixel is given by four points. Real points coordinates are irrelevant. We work with the indices [i,j] of points in the Grid. We hold in the memory only the point no. 0 (left bottom corner of Pixel). Other points are computed automaticaly.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Visualization.Pixel

Implements:

Zcu.Mve.Visualization.IGridCell
Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.Pixel

Index | Overview | Members

Constructors

Pixel ( System.Int32 i, System.Int32 j )
Create Pixel object and fill it with data.
  • i
    Index of left bottom point of Pixel (in reference to Grid in the x-axes direction).
  • j
    Index of left bottom point of Pixel (in reference to Grid in the y-axes direction).

Public methods

final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
Read data from Xml file to current structure.
  • xmlTextReader
    Stream to be read.

final virtual System.Boolean CheckConsistence ( ) ;
Check the consistency of current data structure. Returns false if the Pixel is out of bounds of the Grid. Possible minimum is: [i,j] = [0,1].

    Returns:
    True if structure is consistent.

    final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
    Deep copy of data object and its subelements.

      Returns:
      Same data, different memory space.

      virtual System.String ToString ( ) ;
      Returns a String that represents the current Object.

        Returns:
        String that represents the current Object.

        final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
        Write current data to Xml file.

        • xmlTextWriter
          Stream to be write.

        System.Int32[] GetPoint ( System.Int32 m, System.Int32 n ) ;
        Returns indices [i,j] of point in the Grid according to indices [m,n] of point in the Pixel. Indices [i,j] refer to concrete Grid.

        • m
          Index of the point in the Pixel (in x-axes direction) - can be only {0, 1}.
        • n
          Index of the point in the Pixel (in y-axes direction) - can be only {0, 1}.

        Returns:
        One-dimensional array 1 x 2 that represents indices [i,j] of the point in the Grid.

        System.Int32[] GetPoint ( System.Int32 index ) ;
        Returns indices [i,j] of point in the Grid according to the index of point in the Pixel. Indices [i,j] refer to concrete Grid.

        • index
          Index of the point in the Pixel - can be only {0, 1, 2, 3}.

        Returns:
        One-dimensional array 1 x 2 that represents indices [i,j] of the point in the Grid.

        Public properties

        System.Int32[] Item { get; }
        Get one-dimensional array 1 x 2 that represents indices [i,j] of the point in the Grid. Indices [i,j] refer to the concrete Grid, while the indices [m,n] refer to the Pixel.

        final virtual System.String[] LibNames { get; }
        Returns array of assembly name.

        System.Int32 J { get; }
        Get the index of left bottom point of Pixel (in reference to Grid in the y-axes direction).

        System.Int32[] Item { get; }
        Get one-dimensional array 1 x 2 that represents indices [i,j] of the point in the Grid. The index determines the point of the Pixel and can be {0, 1, 2, 3} only.

        System.Int32 I { get; }
        Get the index of left bottom point of Pixel (in reference to Grid in the x-axes direction).


Zcu.Mve.Visualization.Tetrahedron

Index | Overview | Members

Class represent topology of a Tetrahedron. Defined by four point indices.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Visualization.Tetrahedron

Implements:

Zcu.Mve.Visualization.ICell
Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.Tetrahedron

Index | Overview | Members

Constructors

Tetrahedron ( System.Int32 V1, System.Int32 V2, System.Int32 V3, System.Int32 V4 )
Creates a Tetrahedron object.
  • V1
    Index of first vertex of the Tetrahedron.
  • V2
    Index of second vertex of the Tetrahedron.
  • V3
    Index of third vertex of the Tetrahedron.
  • V4
    Index of fourth vertex of the Tetrahedron.

Public methods

System.Boolean ContainsPoint3D ( Zcu.Mve.Visualization.Point3D p, Zcu.Mve.Visualization.UniformDataArray pointsCoordinates ) ;
determines wether a point3D lies within a the tetrahedron.
  • p
    The Point3D in question
  • pointsCoordinates
    UniformDataArray of vertex coordinates.

Returns:
true if the point lies within the tetrahedron, false otherwise

final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
Read data from XML file.

  • xmlTextReader
    Stream to be read.

final virtual System.Boolean CheckConsistence ( ) ;
Tetrahedron with negative index is considered inconsistent. If two, three or four identical indices are detected warning is given.

    Returns:
    True if the Tetrahedron is consistent.

    final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
    Deep copy of curent object.

      Returns:
      Deep copy (same data, different memory place).

      virtual System.Boolean Equals ( System.Object obj ) ;
      Equality test based on vertex index equality. Order of vertices must be equal in order for the test to return true.

      • obj
        Target object to be tested. Only instances of Tetrahedron or it's descendant may return true, other data types return false

      Returns:
      true if vertex indexes are equal, false otherwise

      System.Int32 GetPoint ( System.Int32 index ) ;
      Returns index of vertex.

      • index
        0 .. 3 are only acceptable vaules.

      Returns:
      Index of vertex.

      virtual System.Int32 GetHashCode ( ) ;
      Returns hash code generated from tetrahedron indices.

        virtual System.String ToString ( ) ;
        Returns a String that represents the current Object.

          Returns:
          String that represents the current Object.

          final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
          Write data to XML file.

          • xmlTextWriter
            Stream to be write.

          Public properties

          final virtual System.String[] LibNames { get; }
          Returns array of assembly name.

          final virtual System.Int32 PointCount { get; }
          Return number of points of cell.

          final virtual System.Int32 Item { get;set; }
          Get/Set index of Tetrahedron vertex

          System.Int32[] PointArray { get; }
          Returns array of three vertices of the Tetrahedron. Change of returned array do not cause change inside line object.

          Public fields

          System.Int32 V4
          Index of fourth vertex of the Tetrahedron.

          System.Int32 V1
          Index of first vertex of the Tetrahedron.

          System.Int32 V3
          Index of third vertex of the Tetrahedron.

          System.Int32 V2
          Index of second vertex of the Tetrahedron.


Zcu.Mve.Visualization.RegGridND

Index | Overview | Members

Object represent orthogonal, regular N dimensional grid. Structure consists of points only. Point location is given implicitly.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.DataSet
Zcu.Mve.Visualization.StructGrid
Zcu.Mve.Visualization.GridND
Zcu.Mve.Visualization.RegGridND

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.RegGridND

Index | Overview | Members

Constructors

RegGridND ( )
For XmlLoader use only. Use parametric constructor instead.

    RegGridND ( System.Double[] mins, System.Double[] maxs, params System.Int32[] sizes )
    Creates empty grid

    • sizes
      Structure dimensions.
    • mins
      Position of minima in all dimensions.
    • maxs
      Position of maxima in all dimensions.

    RegGridND ( params System.Int32[] sizes )
    Creates empty grid

    • sizes
      Structure dimensions.

    Public methods

    Zcu.Mve.Visualization.RegGridND ShallowCopy ( ) ;
    Creates a shallow copy of the reggridND instance. The cell attributes and point attributes are referenced. Useful when adding new attributes, working with separate attributes etc.

      Returns:
      Shallow copy of the instance

      virtual Zcu.Mve.Visualization.PointND GetPoint ( params System.Int32[] coords ) ;
      Returns x, y coordinates of point with i, j indices.

      • coords
        Point coordinates. Count must be equal to structure dimension

      Returns:
      new instance of point

      Public properties

      System.Double[] Maxs { get;set; }
      Gets/sets positions of maxima in all dimensions

      System.Double[] Mins { get;set; }
      Gets/sets positions of minima in all dimensions


Zcu.Mve.Visualization.ColorRGBA

Index | Overview | Members

Converts ColorRGBA from one data type to another. Access this class through the TypeDescriptor.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Visualization.ColorRGBA

Implements:

Zcu.Mve.Visualization.IAttribute
Zcu.Mve.Core.IDataObject
Zcu.Mve.Visualization.IColorVector


Zcu.Mve.Visualization.ColorRGBA

Index | Overview | Members

Constructors

ColorRGBA ( System.Single red, System.Single green, System.Single blue )
Constructor create an instance of Color with implicit alpha value 1.0 (opaque)
  • red
    Red chanel (0.0 to 1.0).
  • green
    Green chanel(0.0 to 1.0).
  • blue
    Blue chanel (0.0 to 1.0).

ColorRGBA ( System.Byte red, System.Byte green, System.Byte blue, System.Byte alpha )
Constructor create an instance of Color with explicit alpha (opaque)

  • red
    Red chanel (0 to 255).
  • green
    Green chanel(0 to 255).
  • blue
    Blue chanel (0 to 255).
  • alpha
    Alpha chanel (transparency)(0 to 255).

ColorRGBA ( System.Byte red, System.Byte green, System.Byte blue )
Constructor create an instance of Color with alpha value 255 (opaque)

  • red
    Red chanel (0 to 255).
  • green
    Green chanel(0 to 255).
  • blue
    Blue chanel (0 to 255).

ColorRGBA ( System.Single red, System.Single green, System.Single blue, System.Single alpha )
Constructor create an instance of Color with explicit alpha (opaque)

  • red
    Red chanel (0.0 to 1.0).
  • green
    Green chanel(0.0 to 1.0).
  • blue
    Blue chanel (0.0 to 1.0).
  • alpha
    Alpha chanel (transparency)(0.0 to 1.0).

Public methods

virtual System.Boolean Equals ( System.Object obj ) ;
Determines whether the specified Object is equal to the current Object.
  • obj
    Specified Object to compare with the current Object.

Returns:
True if the specified Object is equal to the current Object. Otherwise, false.

System.Int32 GetInt ( ) ;
Returns color as an intereger, red at highest bits, blue at lowest bits.

    Returns:
    Color represented as a single integer.

    final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
    Method read data from Xml file to structures of this data object.

    • xmlTextReader
      Xml stream to read.

    final virtual System.Boolean CheckConsistence ( ) ;
    Check the consistency of current data structure.

      Returns:
      True if structure is consistent.

      final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
      Deep copy of data object and its subelements.

        Returns:
        Same data, different memory space.

        virtual System.Int32 GetHashCode ( ) ;
        Returns a hash code for the current Object.

          Returns:
          A hash code for the current Object.

          static System.Boolean Equals ( System.Object a, System.Object b ) ;
          Determines whether the specified Objects are equal.

          • a
            First Object.
          • b
            Second Object.

          Returns:
          True if objects are equal. Otherwise, false.

          virtual System.String ToString ( ) ;
          Returns a String that represents the current Object.

            Returns:
            String that represents the current Object.

            final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
            Method write data from structures of this data object to Xml file.

            • xmlTextWriter
              Xml stream to write.

            Public properties

            System.Byte Alpha { get;set; }
            Gets/sets alpha channel.

            System.Single AlphaF { get;set; }
            Get/Set alpha channel as float (0 to 1).

            System.Single GreenF { get;set; }
            Get/Set green channel as float (0 to 1).

            final virtual System.String[] LibNames { get; }
            Returns array of assembly name.

            System.Byte Red { get;set; }
            Gets/sets red channel.

            System.Single RedF { get;set; }
            Get/Set red channel as float (0 to 1).

            final virtual System.Byte Item { get;set; }
            Get/Set element of color vector.

            System.Single BlueF { get;set; }
            Get/Set blue channel as float (0 to 1).

            System.Byte Green { get;set; }
            Gets/sets green channel.

            System.Byte Blue { get;set; }
            Gets/sets blue channel.

            final virtual System.Int32 Length { get; }
            Get number of elements of vector.


Zcu.Mve.Visualization.TriangleStrip

Index | Overview | Members

Specialization of Mesh. Can contain only TriangleStrip cells. Attributes are not limited.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Visualization.TriangleStrip

Implements:

Zcu.Mve.Visualization.ICell
Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.TriangleStrip

Index | Overview | Members

Constructors

TriangleStrip ( params System.Int32[] points )
Create a TriangleStrip object.
  • points
    Indices of points defined TriangleStrip.

Public methods

virtual System.String ToString ( ) ;
Returns a String that represents the current Object.

    Returns:
    String that represents the current Object.

    final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
    Read data from XML file.

    • xmlTextReader
      Stream to be read.

    System.Int32 AddPoint ( System.Int32 index ) ;
    Add index of the point into TriangleStrip.

    • index
      Index of the point (in reference to DataSet).

    Returns:
    Index of the point (in reference to TriangleStrip).

    final virtual System.Boolean CheckConsistence ( ) ;
    Check the consistency of current data structure. TriangleStrip with negative index is considered inconsistent.

      Returns:
      True if structure is consistent.

      final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
      Deep copy of curent object

        Returns:
        Deep copy (same data, different memory place).

        System.Int32 GetPoint ( System.Int32 index ) ;
        Get index of the point.

        • index
          Index of the point in reference to TriangleStrip (0, 1, 2, ...).

        Returns:
        Index of the point in reference to DataSet.

        System.Void FromArrayList ( System.Collections.ArrayList points ) ;
        Copy elements from given ArrayList to current TriangleStrip. Original indices are deleted.

        • points
          Array of point indices.

        final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
        Write data to XML file.

        • xmlTextWriter
          Stream to be write.

        Public properties

        final virtual System.String[] LibNames { get; }
        Returns array of assembly name.

        final virtual System.Int32 PointCount { get; }
        Return number of points of cell.

        final virtual System.Int32 Item { get;set; }
        Get/set index of the point.

        Public fields

        System.Int32[] Points
        Array of point indices.


Zcu.Mve.Visualization.PolyLine

Index | Overview | Members

Represents unclosed PolyLine defined by array of point indices.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Visualization.PolyLine

Implements:

Zcu.Mve.Visualization.ICell
Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.PolyLine

Index | Overview | Members

Constructors

PolyLine ( params System.Int32[] points )
Creates a PolyLine object.
  • points
    Points indices.

Public methods

final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
Method load data from Xml file to structures of curent data object.
  • xmlTextReader
    XML stram to read

final virtual System.Boolean CheckConsistence ( ) ;
Check the consistency of current data structure. Returns false if some index is negative.

    Returns:
    True if structure is consistent.

    final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
    Deep copy of data object and its subelements.

      Returns:
      same data, different memmory space.

      System.Int32 GetPoint ( System.Int32 index ) ;
      Returns the point (its index in the DataSet) according to index in the PolyLine (0, 1, 2, ...).

      • index
        Index of the point in the Polygon.

      Returns:
      Index of the point in the DataSet.

      virtual System.String ToString ( ) ;
      Returns a String that represents the current Object.

        Returns:
        String that represents the current Object.

        final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
        Method write data to Xml file.

        • xmlTextWriter
          Data stream to write.

        Public properties

        final virtual System.String[] LibNames { get; }
        Returns array of assembly name.

        final virtual System.Int32 PointCount { get; }
        Get the count of polyLine points.

        final virtual System.Int32 Item { get;set; }
        Get/set the concrete vertex of PolyLine. First vertex has the index 0.


Zcu.Mve.Visualization.Normal2D

Index | Overview | Members

Class represents 2D normal vector defined by two elements - Nx and Ny.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Visualization.Normal2D

Implements:

Zcu.Mve.Visualization.INormal
Zcu.Mve.Visualization.IAttribute
Zcu.Mve.Core.IDataObject
Zcu.Mve.Numerics.IVector


Zcu.Mve.Visualization.Normal2D

Index | Overview | Members

Constructors

Normal2D ( System.Double nx, System.Double ny )
Creates a structure and fill in given values
  • nx
    x-normal value.
  • ny
    y-normal value.

Public methods

final virtual System.Double Abs ( ) ;
Returns distance from beginning of coordinate system.

    final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
    Read data from Xml file to current structure.

    • xmlTextReader
      Stream to be read.

    static System.Boolean Equals ( System.Object a, System.Object b ) ;
    Determines whether the specified Objects are equal.

    • a
      First Object.
    • b
      Second Object.

    Returns:
    True if objects are equal. Otherwise, false.

    final virtual System.Boolean CheckConsistence ( ) ;
    Check whether normal absolute value equals 1 +- NormalND.EPSILON.

      Returns:
      Returns true if normal absolute value equals 1 +- NormalND.EPSILON.

      final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
      Deep copy of data object and its subelements.

        Returns:
        Same data, different memory space.

        virtual System.Boolean Equals ( System.Object obj ) ;
        Determines whether the specified Object is equal to the current Object.

        • obj
          Specified Object to compare with the current Object.

        Returns:
        True if the specified Object is equal to the current Object. Otherwise, false.

        virtual System.Int32 GetHashCode ( ) ;
        Returns a hash code for the current Object.

          Returns:
          A hash code for the current Object.

          System.Void Normalize ( ) ;
          Method check whether absolute value equals 1 (+- NormalND.EPSILON). If no, normal is normalized.

            virtual System.String ToString ( ) ;
            Returns a String that represents the current Object.

              Returns:
              String that represents the current Object.

              final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
              Write current data to Xml file.

              • xmlTextWriter
                Stream to be write.

              Public properties

              final virtual System.Int32 Length { get; }
              Get number of elements of normal.

              final virtual System.String[] LibNames { get; }
              Returns array of assembly name.

              final virtual System.Double Item { get;set; }
              Get/Set element of normal.

              Public fields

              System.Double Ny
              y-normal value.

              System.Double Nx
              x-normal value.

              static System.Double Epsilon
              The toleration for equality operator.


Zcu.Mve.Visualization.TriangleFan

Index | Overview | Members

Clas represent fan of triangels defined by atatic array of point indices.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Visualization.TriangleFan

Implements:

Zcu.Mve.Visualization.ICell
Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.TriangleFan

Index | Overview | Members

Constructors

TriangleFan ( params System.Int32[] points )
Create a TriangleFan object.
  • points
    Indices of points defined TriangleFan.

Public methods

virtual System.String ToString ( ) ;
Returns a String that represents the current Object.

    Returns:
    String that represents the current Object.

    final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
    Read data from XML file.

    • xmlTextReader
      Stream to be read.

    System.Int32 AddPoint ( System.Int32 index ) ;
    Add index of the point into TriangleFan.

    • index
      Index of the point (in reference to DataSet).

    Returns:
    Index of the point (in reference to TriangleFan).

    final virtual System.Boolean CheckConsistence ( ) ;
    Check the consistency of current data structure. TriangleFan with negative index is considered inconsistent.

      Returns:
      True if structure is consistent.

      final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
      Deep copy of curent object

        Returns:
        Deep copy (same data, different memory place).

        System.Int32 GetPoint ( System.Int32 index ) ;
        Get index of the point.

        • index
          Index of the point in reference to TriangleFan (0, 1, 2, ...).

        Returns:
        Index of the point in reference to DataSet.

        System.Void FromArrayList ( System.Collections.ArrayList points ) ;
        Copy elements from given ArrayList to current TriangleFan. Original indices are deleted.

        • points
          Array of point indices.

        final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
        Write data to XML file.

        • xmlTextWriter
          Stream to be write.

        Public properties

        final virtual System.String[] LibNames { get; }
        Returns array of assembly name.

        final virtual System.Int32 PointCount { get; }
        Return number of points of cell.

        final virtual System.Int32 Item { get;set; }
        Get/set index of the point.

        Public fields

        System.Int32[] Points
        Array of point indices.


Zcu.Mve.Visualization.Normal3D

Index | Overview | Members

Class represent 3D normal vector defined by 3 elements - Nx, Ny, Nz.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Visualization.Normal3D

Implements:

Zcu.Mve.Visualization.INormal
Zcu.Mve.Visualization.IAttribute
Zcu.Mve.Core.IDataObject
Zcu.Mve.Numerics.IVector


Zcu.Mve.Visualization.Normal3D

Index | Overview | Members

Constructors

Normal3D ( System.Double nx, System.Double ny, System.Double nz )
Creates a structure and fill in given values
  • nx
    x-normal value.
  • ny
    y-normal value.
  • nz
    z-normal value.

Public methods

final virtual System.Boolean CheckConsistence ( ) ;
Check whether normal absolute value equals 1 +- NormalND.EPSILON.

    Returns:
    Returns true if normal absolute value equals 1 +- NormalND.EPSILON.

    final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
    Method load data from Xml file to structures of curent data object.

    • xmlTextReader
      XML stram to read

    final virtual System.Double Abs ( ) ;
    Returns distance from beginning of coordinate system.

      Returns:
      Distance from beginning of coordinate system.

      Zcu.Mve.Visualization.Normal3D CrossProduct ( Zcu.Mve.Visualization.Normal3D arg ) ;
      Returns the cross product of two normals.

      • arg
        Second argument of the cross product operation.

      Returns:
      Normal3D representing the resulting vector.

      System.Double SquareDistanceTo ( Zcu.Mve.Visualization.Normal3D p ) ;
      Returns squared euclidean distance between two normals (is slightly faster than the DistanceTo function as no square root is computed).

      • p
        Argument normal to which distance will be computed.

      Returns:
      Square euclidean distance between the normals.

      final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
      Method write data to Xml file.

      • xmlTextWriter
        Data stream to write.

      final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
      Deep copy of data object and its subelements.

        Returns:
        same data, different memmory space.

        virtual System.String ToString ( ) ;
        Returns a String that represents the current Object.

          Returns:
          String that represents the current Object.

          System.Double DotProduct ( Zcu.Mve.Visualization.Normal3D arg ) ;
          Returns the dot product of two normals.

          • arg
            Second argument of the dot product operation.

          Returns:
          Scalar value of this.arg.

          System.Void Normalize ( ) ;
          Method check whether absolute value equals 1 (+- NormalND.EPSILON). If no, normal is normalized.

            virtual System.Int32 GetHashCode ( ) ;
            Returns a hash code for the current Object.

              Returns:
              A hash code for the current Object.

              static System.Boolean Equals ( System.Object a, System.Object b ) ;
              Determines whether the specified Objects are equal.

              • a
                First Object.
              • b
                Second Object.

              Returns:
              True if objects are equal. Otherwise, false.

              System.Double DistanceTo ( Zcu.Mve.Visualization.Normal3D p ) ;
              Returns euclidean distance between two normals.

              • p
                Argument normal to which distance will be computed.

              Returns:
              Euclidean distance between the normal.

              virtual System.Boolean Equals ( System.Object obj ) ;
              Determines whether the specified Object is equal to the current Object.

              • obj
                Specified Object to compare with the current Object.

              Returns:
              True if the specified Object is equal to the current Object. Otherwise, false.

              Public properties

              final virtual System.Int32 Length { get; }
              Get number of elements of normal.

              final virtual System.String[] LibNames { get; }
              Returns array of assembly name.

              final virtual System.Double Item { get;set; }
              Get/Set element of normal.

              Public fields

              System.Double Nz
              z-normal value.

              System.Double Ny
              y-normal value.

              System.Double Nx
              x-normal value.

              static System.Double Epsilon
              The toleration for equality operator.


Zcu.Mve.Visualization.UniformDataArrayND

Index | Overview | Members

This class represents multi dimensional static array of one specific DataObject.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.MveArray
Zcu.Mve.Visualization.UniformDataArrayND

Implements:

Zcu.Mve.Core.IDataObject
System.Collections.IEnumerable


Zcu.Mve.Visualization.UniformDataArrayND

Index | Overview | Members

Constructors

UniformDataArrayND ( System.Type type, params System.Int32[] lengths )
Creates empty ND array of given type.
  • lengths
    Number of lines
  • type
    The only accepted type

UniformDataArrayND ( )
For XmlLoader use only. Use parametric constructor instead.


Zcu.Mve.Visualization.Slice

Index | Overview | Members

Specialization of UnstrGrid. Class represents set of slices. Only Slice can be a topological element.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.Slice

Implements:

Zcu.Mve.Core.IDataObject
Zcu.Mve.Visualization.ICell


Zcu.Mve.Visualization.Slice

Index | Overview | Members

Constructors

Slice ( )
Implicit constructor - creates an empty slice.

    Public methods

    virtual System.String ToString ( ) ;
    Returns a String that represents the current Object.

      Returns:
      String that represents the current Object.

      virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
      Read data from Xml file to current structure.

      • xmlTextReader
        Stream to be read.

      virtual System.Boolean CheckConsistence ( ) ;
      Check the consistency of current data structure.

        Returns:
        True if structure is consistent.

        virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
        Deep copy of data object and its subelements.

          Returns:
          Same data, different memory space.

          Zcu.Mve.Visualization.PolyLine GetPolyLine ( System.Int32 index ) ;
          Get PolyLine.

          • index
            Index of PolyLine.

          Returns:
          PolyLine with given index

          virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
          Write current data to Xml file.

          • xmlTextWriter
            Stream to be write.

          System.Void AddPolyLine ( Zcu.Mve.Visualization.PolyLine polyLine ) ;
          Add a PolyLine to the Slice.

          • polyLine
            PolyLine.

          System.Void SetPolyLine ( System.Int32 index, Zcu.Mve.Visualization.PolyLine val ) ;
          Set PolyLine.

          • index
            Index of PolyLine.
          • val
            PolyLine with given index.

          Public properties

          System.Collections.Generic.ICollection`1[[Zcu.Mve.Visualization.PolyLine, Visualization, Version=1.1.5141.21393, Culture=neutral, PublicKeyToken=null]] PolyLineList { get; }
          Get the list of polyLines.

          System.Int32 PolyLineCount { get; }
          Get the count of polyLines.

          final virtual System.Int32 Item { get;set; }
          Composed cell. Do not have meaning in case of Slice.

          final virtual System.Int32 PointCount { get; }
          Composed cell. Do not have mening in case of Slice.


Zcu.Mve.Visualization.TriangleMesh

Index | Overview | Members

Specialization of Mesh. Can contain only Triangle cells. Attributes are not limited.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.DataSet
Zcu.Mve.Visualization.UnstrGrid
Zcu.Mve.Visualization.UnstrGridEigCell
Zcu.Mve.Visualization.Mesh
Zcu.Mve.Visualization.TriangleMesh

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.TriangleMesh

Index | Overview | Members

Constructors

TriangleMesh ( )
Create empty TriangleMesh. Only Triangle is eigen cell.

    Public methods

    Zcu.Mve.Visualization.Triangle GetTriangle ( System.Int32 index ) ;
    Returns triangle from array named "Triangle".
    • index
      Index of the triangle.

    Returns:
    Triangle with given index.

    System.Int32 GetNTriangles ( ) ;
    Returns number of triangles. (Number of elements in field named "Triangle")

      Returns:
      Number of triangles.

      virtual System.Boolean CheckConsistence ( ) ;
      checks the consistence of the triangle mesh. Checks number of faces incident with each edge.

        Returns:
        true if no open edges are found, no unused vertices are found, no non-manifold edges are found and no degenerate triangles are found. False otherwise.

        virtual Zcu.Mve.Visualization.UnstrGrid ShallowCopy ( ) ;
        Creates shallow copy of current mesh. Only array references are coppied.

          Returns:
          Shallow copy of current mesh.


Zcu.Mve.Visualization.Point2D

Index | Overview | Members

Represents a 2D point defined by two coordinates - X and Y.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Visualization.Point2D

Implements:

Zcu.Mve.Visualization.IPoint
Zcu.Mve.Numerics.IVector
Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.Point2D

Index | Overview | Members

Constructors

Point2D ( System.Double x, System.Double y )
Create a Point2D object.
  • x
    x-coordinate of point.
  • y
    y-coordinate of point.

Public methods

final virtual System.Double Abs ( ) ;
Returns the distance of point and coordinate origin.

    Returns:
    The distance of point from and coordinate origin.

    System.Double DotProduct ( Zcu.Mve.Visualization.Point2D arg ) ;
    Returns the dot product of two points.

    • arg
      Second argument of the dot product operation.

    Returns:
    Scalar value of this.arg.

    final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
    Read data from Xml file to current structure.

    • xmlTextReader
      Stream to be read.

    virtual System.Int32 GetHashCode ( ) ;
    Returns a hash code for the current Object.

      Returns:
      A hash code for the current Object.

      System.Double DistanceTo ( Zcu.Mve.Visualization.Point3D p ) ;
      Returns euclidean distance between two points.

      • p
        Argument point to which distance will be computed.

      Returns:
      Euclidean distance between the points.

      final virtual System.Boolean CheckConsistence ( ) ;
      Check the consistency of current data structure.

        Returns:
        True if structure is consistent.

        final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
        Deep copy of data object and its subelements.

          Returns:
          Same data, different memory space.

          virtual System.Boolean Equals ( System.Object obj ) ;
          Determines whether the specified Object is equal to the current Object.

          • obj
            Specified Object to compare with the current Object.

          Returns:
          True if the specified Object is equal to the current Object. Otherwise, false.

          System.Double SquareDistanceTo ( Zcu.Mve.Visualization.Point3D p ) ;
          Returns squared euclidean distance between two points (is slightly faster than the DistanceTo function as no square root is computed),

          • p
            Argument point to which distance will be computed.

          Returns:
          Square euclidean distance between the points.

          static System.Boolean Equals ( System.Object a, System.Object b ) ;
          Determines whether the specified Objects are equal.

          • a
            First Object.
          • b
            Second Object.

          Returns:
          True if objects are equal. Otherwise, false.

          virtual System.String ToString ( ) ;
          Returns a String that represents the current Object.

            Returns:
            String that represents the current Object.

            final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
            Write current data to Xml file.

            • xmlTextWriter
              Stream to be write.

            Public properties

            final virtual System.Int32 Length { get; }
            Get number of elements of point.

            final virtual System.String[] LibNames { get; }
            Returns array of assembly name.

            final virtual System.Double Item { get;set; }
            Get/Set element of point.

            Public fields

            static System.Double Epsilon
            The toleration for equality operator.

            System.Double Y
            y-coordinate of point.

            System.Double X
            x-coordinate of point.


Zcu.Mve.Visualization.Transform3D

Index | Overview | Members

General tranformation of a 3D object.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.AbstractTransform
Zcu.Mve.Visualization.Transform3D

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.Transform3D

Index | Overview | Members

Constructors

Transform3D ( )
Creates a Transform3D object and initialize it (set identity).

    Public methods

    System.Void AddRotationZ ( System.Double angle ) ;
    Cumulative rotation about axis Z.
    • angle
      Rotation angle masured in radians.

    virtual System.Boolean CheckConsistence ( ) ;
    Check the consistency of current data structure.

      Returns:
      True if structure is consistent.

      System.Void SetRotaionZ ( System.Double angle ) ;
      Noncumulative rotation about axis Z measured in radians.

      • angle
        Rotation angle masured in radians.

      System.Void AddTranslation ( System.Double x, System.Double y, System.Double z ) ;
      Cumulative translation

      • x
        Translation in x-axis.
      • y
        Translation in y-axis.
      • z
        Translation in z-axis.

      System.Void SetIdentity ( ) ;
      Set identity transformation.

        System.Void AddTranslation ( Zcu.Mve.Visualization.Point3D d ) ;
        Cumulative translation

        • x
          Translation in x-axis.
        • y
          Translation in y-axis.
        • z
          Translation in z-axis.

        virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
        Read data from Xml file to current structure.

        • xmlTextReader
          Stream to be read.

        System.Void AddScale ( System.Double dx, System.Double dy, System.Double dz ) ;
        Add scaling to current transformation. TODO: Optimize it!

        • dx
          Scaling in x-axis. 1 means no scale.
        • dy
          Scaling in y-axis. 1 means no scale.
        • dz
          Scaling in z-axis. 1 means no scale.

        System.Void SetScale ( System.Double dx, System.Double dy, System.Double dz ) ;
        Set curent matrix to scaling matrix of given values.

        • dx
          Scaling in x-axis. 1 means no scale.
        • dy
          Scaling in y-axis. 1 means no scale.
        • dz
          Scaling in z-axis. 1 means no scale.

        System.Void SetTranslation ( System.Double x, System.Double y, System.Double z ) ;
        Noncumlative translation.

        • x
          Translation in x-axis.
        • y
          Translation in y-axis.
        • z
          Translation in z-axis.

        Zcu.Mve.Visualization.Transform3D Transpose ( ) ;

          System.Void SetRotaionY ( System.Double angle ) ;
          Noncumulative rotation about axis Y measured in radians.

          • angle
            Rotation angle masured in radians.

          System.Void AddRotationX ( System.Double angle ) ;
          Cumulative rotation about axis X.

          • angle
            Rotation angle masured in radians.

          virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
          Write current data to Xml file.

          • xmlTextWriter
            Stream to be write.

          virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
          Deep copy of data object and its subelements.

            Returns:
            Same data, different memory space.

            virtual System.String ToString ( ) ;
            Returns a String that represents the current Object.

              Returns:
              String that represents the current Object.

              System.Void SetRotaionX ( System.Double angle ) ;
              Noncumulative rotation about axis X measured in radians.

              • angle
                Rotation angle masured in radians.

              System.Void AddRotationY ( System.Double angle ) ;
              Cumulative rotation about axis Y.

              • angle
                Rotation angle masured in radians.

              static Zcu.Mve.Visualization.Transform3D gerealRotation ( Zcu.Mve.Visualization.Point3D axisA, Zcu.Mve.Visualization.Point3D axisB, System.Double angleRadians ) ;
              Creates a general rotation matrix. The rotation axis is specified by vertices passed as and , the rotation angle is specified by .

              • axisA
                First point specifying the rotation axis
              • axisB
                Second point specifying the rotation axis
              • angleRadians
                Angle of rotation in radians.

              Returns:
              Resulting general rotation matrix

              Zcu.Mve.Visualization.Point3D Transform ( Zcu.Mve.Visualization.Point3D op ) ;
              Transform the point.

              • op
                Point to be transform. This parameter won't be changed.

              Returns:
              New instance of transformed point.

              static System.Boolean Equals ( System.Object a, System.Object b ) ;
              Determines whether the specified Objects are equal.

              • a
                First Object.
              • b
                Second Object.

              Returns:
              True if objects are equal. Otherwise, false.

              virtual System.Int32 GetHashCode ( ) ;
              Returns a hash code for the current Object.

                Returns:
                A hash code for the current Object.

                virtual System.Boolean Equals ( System.Object obj ) ;
                Determines whether the specified Object is equal to the current Object.

                • obj
                  Specified Object to compare with the current Object.

                Returns:
                True if the specified Object is equal to the current Object. Otherwise, false.

                Public properties

                System.Double Item { get;set; }
                Full access to particular matrix elements.

                Public fields

                static System.Double Epsilon
                The toleration for equality operator.


Zcu.Mve.Visualization.TextureCoord

Index | Overview | Members

Class represent a texture coordinate.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Visualization.TextureCoord

Implements:

Zcu.Mve.Visualization.IAttribute
Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.TextureCoord

Index | Overview | Members

Constructors

TextureCoord ( System.Single u, System.Single v, System.Int32 TextureID )
Creates a TextureCoord object.
  • u
    Line index in texture image.
  • v
    Column index in texture image.
  • TextureID
    ID of related texture.

Public methods

final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
Write current data to Xml file.
  • xmlTextWriter
    Stream to be write.

final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
Read data from Xml file to current structure.

  • xmlTextReader
    Stream to be read.

final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
Deep copy of data object and its subelements.

    Returns:
    Same data, different memory space.

    final virtual System.Boolean CheckConsistence ( ) ;
    Check the consistency of current data structure.

      Returns:
      True if structure is consistent.

      virtual System.String ToString ( ) ;
      Returns a String that represents the current Object.

        Returns:
        String that represents the current Object.

        Public properties

        final virtual System.String[] LibNames { get; }
        Returns array of assembly name.

        Public fields

        System.Single U
        Line index in texture image.

        System.Single V
        Column index in texture image.

        System.Int32 TextureID
        ID of related texture.


Zcu.Mve.Visualization.RegGrid2D

Index | Overview | Members

Object represent ortogonal, regular two dimensional grid. Structure consists of pixels (cells) and points. Point location is given implicitly. Point with zero indices have [0,0] cooordinate values. Point with [height, width] indices have [1,1] cooordinate values.

Inheritance:

System.Object
Zcu.Mve.Core.DataObject
Zcu.Mve.Visualization.DataSet
Zcu.Mve.Visualization.StructGrid
Zcu.Mve.Visualization.Grid2D
Zcu.Mve.Visualization.RegGrid2D

Implements:

Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.RegGrid2D

Index | Overview | Members

Constructors

RegGrid2D ( )
For XmlLoader use only. Use parametric constructor instead.

    RegGrid2D ( System.Int32 height, System.Int32 width )
    Creates empty grid

    • height
      Number of pixels in height dimension.
    • width
      Number of pixels in width dimension.

    Public methods

    virtual Zcu.Mve.Visualization.Point2D GetPoint ( System.Int32 i, System.Int32 j ) ;
    Returns x, y coordinates of point with i, j indices.
    • i
      Row index of point.
    • j
      Column index of point.

    Returns:
    New instance of point.


Zcu.Mve.Visualization.Point3D

Index | Overview | Members

Converts Point3D from one data type to another. Access this class through the TypeDescriptor.

Inheritance:

System.Object
System.ValueType
Zcu.Mve.Visualization.Point3D

Implements:

Zcu.Mve.Visualization.IPoint
Zcu.Mve.Numerics.IVector
Zcu.Mve.Core.IDataObject


Zcu.Mve.Visualization.Point3D

Index | Overview | Members

Constructors

Point3D ( System.Double x, System.Double y, System.Double z )
Create a Point3D object.
  • x
    x-coordinate of point.
  • y
    y-coordinate of point.
  • z
    z-coordinate of point.

Point3D ( params System.Double[] position )
default constructor, constructs a new instance from an array of three integers. If smaller array is passed then an exception is thrown.

  • position
    Three element array of XYZ coordinates.

Public methods

final virtual System.Boolean CheckConsistence ( ) ;
Check the consistency of current data structure.

    Returns:
    True if structure is consistent.

    System.Double SquareDistanceTo ( Zcu.Mve.Visualization.Point3D p ) ;
    Returns squared euclidean distance between two points (is slightly faster than the DistanceTo function as no square root is computed),

    • p
      Argument point to which distance will be computed.

    Returns:
    Square euclidean distance between the points.

    System.Double DotProduct ( Zcu.Mve.Visualization.Point3D arg ) ;
    Returns the dot product of two points.

    • arg
      Second argument of the dot product operation.

    Returns:
    Scalar value of this.arg.

    System.Double DistanceTo ( Zcu.Mve.Visualization.Point3D p ) ;
    Returns euclidean distance between two points.

    • p
      Argument point to which distance will be computed.

    Returns:
    Euclidean distance between the points.

    final virtual System.Void ReadData ( System.Xml.XmlTextReader xmlTextReader ) ;
    Read data from Xml file to current structure.

    • xmlTextReader
      Stream to be read.

    final virtual System.Double Abs ( ) ;
    Returns the distance of point and coordinate origin.

      Returns:
      The distance of point from and coordinate origin.

      Zcu.Mve.Visualization.Point3D CrossProduct ( Zcu.Mve.Visualization.Point3D arg ) ;
      Returns the cross product of two points.

      • arg
        Second argument of the cross product operation.

      Returns:
      Point3D representing the resulting vector.

      final virtual System.Void WriteData ( System.Xml.XmlTextWriter xmlTextWriter ) ;
      Write current data to Xml file.

      • xmlTextWriter
        Stream to be write.

      final virtual Zcu.Mve.Core.IDataObject DeepCopy ( ) ;
      Deep copy of data object and its subelements.

        Returns:
        Same data, different memory space.

        virtual System.String ToString ( ) ;
        Returns a String that represents the current Object.

          Returns:
          String that represents the current Object.

          System.Double Sqr ( ) ;
          Returns a dot product of the point with itself.

            Returns:
            Squared distance to the coordinte origin.

            virtual System.Int32 GetHashCode ( ) ;
            Returns a hash code for the current Object.

              Returns:
              A hash code for the current Object.

              static System.Boolean Equals ( System.Object a, System.Object b ) ;
              Determines whether the specified Objects are equal.

              • a
                First Object.
              • b
                Second Object.

              Returns:
              True if objects are equal. Otherwise, false.

              virtual System.Boolean Equals ( System.Object obj ) ;
              Determines whether the specified Object is equal to the current Object.

              • obj
                Specified Object to compare with the current Object.

              Returns:
              True if the specified Object is equal to the current Object. Otherwise, false.

              Public properties

              System.Double Y { get;set; }
              Get/Set y-vector value.

              final virtual System.String[] LibNames { get; }
              Returns array of assembly name.

              System.Double Z { get;set; }
              Get/Set z-vector value.

              final virtual System.Double Item { get;set; }
              Get/Set element of point.

              System.Double X { get;set; }
              Get/Set x-vector value.

              final virtual System.Int32 Length { get; }
              Get number of elements of point.

              Public fields

              static System.Double Epsilon
              The toleration for equality operator.


Testing

Title: Modular Virtual Environment 2 - Testing
Company: University of West Bohemia in Pilsen, Czech Republic
Copyright: © 2004 - 2005 University of West Bohemia, Czech Republic
Version: 1.0.5141.21395
Runtime version: 4.0.30319

Modules

Zcu.Mve.Testing.ArrayDownsampler | Module for downsampling MveArray of Scalar values.
Zcu.Mve.Testing.ConvSource | Zdroj konvoluční masky
Zcu.Mve.Testing.DummyModule |
Zcu.Mve.Testing.ElevationFilter |
Zcu.Mve.Testing.GravityAcceleration |
Zcu.Mve.Testing.MveArray2RegGridND |
Zcu.Mve.Testing.OrthoSlicer | Module for slicing volume data.
Zcu.Mve.Testing.Oscilation |
Zcu.Mve.Testing.Pendulum |
Zcu.Mve.Testing.PositionRenderer | Modul vykreslí 2D vektory v kartézských souřadnicích jako kruh. Zobrazitelný rozsah je <-1, 1>
Zcu.Mve.Testing.RandomPoint2DGenerator |
Zcu.Mve.Testing.TestFilter |
Zcu.Mve.Testing.TestSource | Test source
Zcu.Mve.Testing.UniformArray2RegGrid |
Zcu.Mve.Testing.VolumeImageLoader | Module for loading volume data from a series of images


Zcu.Mve.Testing.PositionRenderer

Position renderer.

Input Ports:
  • A - první pozice
  • B - druhá pozice

Details:

Type of module: Output.Number|Number.Output
Version: 28.01.2014
Author: Milan Frank


Zcu.Mve.Testing.PositionRenderer


Zcu.Mve.Testing.UniformArray2RegGrid

Converts UniformDataArray2D to RegGrid2D.

Input Ports:
  • Input array -

Output Ports:
  • Output grid -

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Testing.UniformArray2RegGrid


Zcu.Mve.Testing.Oscilation

Oscilator module.

Input Ports:
  • v -
  • x -

Output Ports:
  • a -

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Testing.Oscilation


Zcu.Mve.Testing.ConvSource

Source of a convolution mask

Output Ports:
  • Mask - Konvoluční maska.

Details:

Type of module: Source.Number|Number.Source
Version: 28.01.2014
Author: Milan Frank


Zcu.Mve.Testing.ConvSource

Creates a setup dialog for the module.


Zcu.Mve.Testing.OrthoSlicer

Module for slicing volume data

Input Ports:
  • Input array - MveArray of any kind of data and any dimension to be sliced.

Output Ports:
  • Output array - UniformDataArray2D that represent a slice of the input data.

Details:

Type of module: Filter.Volume|Volume.Filter
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Testing.OrthoSlicer

You can set these properties:

  • HeightDim
    Index of the dimension that will be used as height of the slice. Must be >=0 and cannot exceed dimension of the input data.
  • WidthDim
    Index of the dimension that will be used as width of the slice. Must be >=0 and cannot exceed dimension of the input data.
  • Coordinates
    Comma separated integer values that represent a point within the input data through which the slice will pass. Number of elements must be equal to number of dimensions of the input data.


Zcu.Mve.Testing.DummyModule

Dummy module

Output Ports:
  • Output -

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Testing.DummyModule


Zcu.Mve.Testing.ArrayDownsampler

A module used for downsampling of MveArrays of Scalar values. Downsampling is performed in selected dimension by selected amount. To downsample in multiple dimensions use multiple modules. Averaging is used to compute the output values.

Input Ports:
  • Input array - MveArray of any kind of data and any dimension to be downsampled.

Output Ports:
  • Output array - MveArray of downsampled input data.

Details:

Type of module: Filter.Volume|Volume.Filter
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Testing.ArrayDownsampler

You can set these properties:

  • DownsampleFactor
    Integer value that sets how many input samples will make one output sample
  • SelectedDimension
    Integer value that sets the dimension to be downsampled.


Zcu.Mve.Testing.VolumeImageLoader

This is a module useful when loading a series of bitmap images containig volume data. It produces a MveArray of either one color value, or RGB triplet. Use the properties StartIndex, EndIndex, Prefix and Suffix to specify input files (filenames will be generated from the prefix number suffix pattern, where number changes from startIndex to endIndex, no leading zeroes are added. Any bitmap format that can be loaded by System.Drawing.Bitmap constructor can be used as input. Use the DataType property to specify what data should be used. You can use one of following values: DataType values that will produce array of Mve.Numerics.Scalar: R for values of red component (0-1) G for values of green component (0-1) B for values of blue component (0-1) H for values of hue (0-360 degrees) S for values of saturation (0-1) V for values of brightness (value) (0-1)

Output Ports:
  • VolumeArray - A 3D MveArray that contains the images where first two dimensions represent X and Y directions in the inputs, third being the index of the image

Details:

Type of module: Loader.Volume|Volume.Loader
Version: 28.01.2014
Author: Libor Váša


Zcu.Mve.Testing.VolumeImageLoader

You can set these properties:

  • Prefix
    Filename prefix for the <prefix><number><suffix> pattern. Should also contain full path.
  • EndIndex
    Ending index for the <prefix><number><suffix> pattern. This index will be used.
  • StartIndex
    Starting index for the <prefix><number><suffix> pattern. This index will be used.
  • AlwaysReload
    Defines wether the data should be reloaded even when no filename generating parameteres are changed. Set to true if the data in the files may change between the runs of the map, otherwise set to false to speed the process up significantly.
  • Suffix
    Filename suffix for the <prefix><number><suffix> pattern. Should also contain file extension.
  • DataType
    Specifies data to be loaded. Use R, G or B for channel values, H S or V for Hue, Saturation or Brightness, or RGB for color triplet.


Zcu.Mve.Testing.GravityAcceleration

Acceleration simulation module

Input Ports:
  • oveckin -
  • pos1 -
  • pos2 -
  • weight1 -
  • weight2 -

Output Ports:
  • acceleration1 -
  • acceleration2 -

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Testing.GravityAcceleration


Zcu.Mve.Testing.ElevationFilter

Elevation filter.

Input Ports:
  • Mesh -

Output Ports:
  • Mesh -

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Testing.ElevationFilter


Zcu.Mve.Testing.TestSource

Test source. Generates a new 2D grid and adds color cells to it.

Output Ports:
  • value - data array

Details:

Type of module: Source.Image|Image.Source
Version: 28.01.2014
Author: Milan Frank


Zcu.Mve.Testing.TestSource


Zcu.Mve.Testing.MveArray2RegGridND

Converts MveArray to RegGridND.

Input Ports:
  • Input MveArray -

Output Ports:
  • Output RegGridND -

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Testing.MveArray2RegGridND


Zcu.Mve.Testing.TestFilter

Sample filter which sets the first point of an UnstrGrid to position (10,0,0). Demonstration only, has many flaws.

Input Ports:
  • in -

Output Ports:
  • out -

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Testing.TestFilter


Zcu.Mve.Testing.RandomPoint2DGenerator

Generates an array of random 2D points.

Output Ports:
  • Points -

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Testing.RandomPoint2DGenerator

You can set these properties:

  • PointCount
    Number of points to be generated. Must be greater than zero.


Zcu.Mve.Testing.Pendulum

Summary description for PendulumPanel.

Input Ports:
  • pendulumPosition -

Details:

Type of module: unspecified
Version:
Author:


Zcu.Mve.Testing.Pendulum


Examples.GenerateGraph


Examples.VertexEdgeDetector


Zcu.Mve.Elementals.MultiPortEvaluator


Zcu.Mve.Elementals.XmlLoader


Zcu.Mve.Elementals.XmlSaver


Zcu.Mve.Numerics.ComplexBinaryOp


Zcu.Mve.Numerics.ComplexSource


Zcu.Mve.Numerics.IntegerBinaryOp


Zcu.Mve.Numerics.IntegerSource


Zcu.Mve.Numerics.LinearTransform


Zcu.Mve.Numerics.ScalarBinaryOp


Zcu.Mve.Numerics.ScalarSource


Zcu.Mve.Numerics.VectorSource


Zcu.Mve.Strings.FileNameComposer


Zcu.Mve.Strings.StringSource


Zcu.Mve.Testing.ArrayDownsampler


Zcu.Mve.Testing.ConvSource


Zcu.Mve.Testing.OrthoSlicer


Zcu.Mve.Testing.RandomPoint2DGenerator


Zcu.Mve.Testing.VolumeImageLoader


Zcu.Mve.Visualization.Loaders.BinaryReaderMultiAttributes


Zcu.Mve.Visualization.Loaders.BinaryReaderSingleAttribute


Zcu.Mve.Visualization.Loaders.DICOM_Loader


Zcu.Mve.Visualization.Loaders.ObjLoader


Zcu.Mve.Visualization.Loaders.PictureLoader


Zcu.Mve.Visualization.Loaders.TriangleLoader


Zcu.Mve.Visualization.Processing.BlockCutting


Zcu.Mve.Visualization.Processing.CalculateDisplace


Zcu.Mve.Visualization.Processing.ConvexPolyhedronCutting


Zcu.Mve.Visualization.Processing.DisplaceMap


Zcu.Mve.Visualization.Processing.EditablePalette


Zcu.Mve.Visualization.Processing.Elevation


Zcu.Mve.Visualization.Processing.GeometryCut


Zcu.Mve.Visualization.Processing.Glyphs


Zcu.Mve.Visualization.Processing.GlyphsFromRegGridNd


Zcu.Mve.Visualization.Processing.GlyphsFromUnstrGrid


Zcu.Mve.Visualization.Processing.IsoSurfaceExtractor


Zcu.Mve.Visualization.Processing.MarchingCubes


Zcu.Mve.Visualization.Processing.MarchingTetrahedra5


Zcu.Mve.Visualization.Processing.MarchingTetrahedra6


Zcu.Mve.Visualization.Processing.MarchingTetrahedra


Zcu.Mve.Visualization.Processing.NormalComputer


Zcu.Mve.Visualization.Processing.PaletteLinear


Zcu.Mve.Visualization.Processing.PaletteRainbow


Zcu.Mve.Visualization.Processing.PlaneCutting


Zcu.Mve.Visualization.Processing.PointDistanceCutting


Zcu.Mve.Visualization.Processing.RegGridNDCalculator


Zcu.Mve.Visualization.Processing.Slicer


Zcu.Mve.Visualization.Processing.Streamlines


Zcu.Mve.Visualization.Processing.Tube


Zcu.Mve.Visualization.Processing.UnstrGridCalculator


Zcu.Mve.Visualization.Processing.UnstrGridModifyTransform


Zcu.Mve.Visualization.Processing.VolumeCut


Zcu.Mve.Visualization.Processing.VolumeDataConvertor


Zcu.Mve.Visualization.Processing.VolumeDataHistogram


Zcu.Mve.Visualization.Renderers.CurveRenderer


Zcu.Mve.Visualization.Renderers.RegGrid2DRenderer


Zcu.Mve.Visualization.Renderers.VolumeRendererWrapper


Zcu.Mve.Visualization.Renderers.VolumeSliceViewer


Zcu.Mve.Visualization.Sources.PlaneSource


Zcu.Mve.Visualization.Sources.PointNDSource


Zcu.Mve.Visualization.Sources.RegGridNDSource


Zcu.Mve.Visualization.Sources.RotationTransformSource


Zcu.Mve.Visualization.Sources.Transform3DSource


Zcu.Mve.Visualization.Sources.TransformTranslationSource